[MPlayer-users] RTSP and trick-play

Christophe Lemoine christophe at lemoine-fr.com
Wed Feb 3 15:34:34 CET 2010


I have setup a VOD server using live555 (streaming a MPEG2 TS video, the 
index file is present).
Playing the video stream works fine on both mplayer and vlc. But the 
issue is with the trick play actions (forward, random seeking, ......): 
it does not work at all on mplayer (it does on VLC, so the streaming 
server is ok). I do not get the controls and using the keys (arrows) 
freeze the video for about a second and then continue playing with some 

Anyone knows how to get the trick play working on mplayer ?

Here is what I get in the console when connecting to live555 server:

# mplayer  rtsp://vsettop:8554/up.ts
MPlayer 1.0rc2-4.3.3 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     P9400  @ 2.40GHz (Family: 6, Model: 
23, Stepping: 6)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Playing rtsp://vsettop:8554/up.ts.
Resolving vsettop for AF_INET6...
Couldn't resolve name for AF_INET6: vsettop
Resolving vsettop for AF_INET...
Connecting to server vsettop[]: 8554...
Cache size set to 640 KBytes
Cache fill: 13.75% (90112 bytes)  
Win32 LoadLibrary failed to load: avisynth.dll, 
/usr/lib/win32/avisynth.dll, /usr/local/lib/win32/avisynth.dll
TS file format detected.
VIDEO MPEG2(pid=256) AUDIO AAC(pid=257) NO SUBS (yet)!  PROGRAM N. 1
VIDEO:  MPEG2  720x576  (aspect 1)  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
xscreensaver_disable: Could not find XScreenSaver window.
GNOME screensaver disabled
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
Forced audio codec: mad
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) 
AO: [pulse] Failed to connect to server: Connection refused
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.25:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 720x576 Planar YV12

When I connect mplayer to a Darwin Server, I get a clear message 
(although the server does support trick play, as I can see when using 
QuickTime player on Mac):

rtsp_session: unsupported RTSP server. Server type is 'DSS/6.0.3-L2 
(Build/526.3; Platform/Linux; Release/Darwin Streaming Server; 
State/Development; )'.
STREAM_LIVE555, URL: rtsp://vsettop:8000/up.mp4
Stream not seekable!"


More information about the MPlayer-users mailing list