[MPlayer-users] video scaling doesn't work

Grant emailgrant at gmail.com
Tue Feb 11 20:10:18 CET 2014

>> >>> >> I'm using omapfb and video scaling doesn't seem to work.  Does
>> >>anyone
>> >>> >> know if it should work and if there's anything I can do to get it
>> >>> >> working?
>> >>> >
>> >>> > "omapfb" meaning what?
>> >>> > The X11 omapfb driver? You should ask on their list.
>> >>> > There is no omapfb vo in MPlayer, that is not supported by us
>> >>> > if that's what you use.
>> >>> > Either way, upscaling needs special kernel support and userspace
>> >>that
>> >>> > is updated to make use of this support.
>> >>>
>> >>> Does mplayer have swscale capabilities like vlc?
>> >>
>> >>Yes, see options -zoom, -sws and -vf scale.
>> >
>> > I can only highly recommend to look for a proper solution. Unless you only care about playing 320x480 videos on a screen with not much higher resolution it won't work.
>> > There is a very good reason for all that scaling hardware to be in the SoC, ignoring it instead of making it work won't get you far.
>> I'm not up to the challenge of programming scaling support into omapfb
> Well, someone got it working at some point with X11 and its omapfb
> XVideo implementation. So that definitely is possible without
> programming, it's just a matter of finding the "magic incantations"
> (aka where did they hide the magic combination of programs that worked
> on exactly one day).

I didn't realize that was ever working.  How do you know it used to work?

>> so I can either prescale with mencoder/ffmpeg or try to get mplayer to
>> scale on the fly.  This works nicely except the video only appears in
>> the top 35% of the screen:
>> mplayer -vf scale=1360:-1 -fs file.mp4
> You'll want something like "-vf scale=1360:-2,expand=aspect=16/9"
> but the saying about lipstick and pig applies...

That scales it perfectly although performance isn't up to snuff as expected.

> Also I don't know what code you are using, but since this code in the
> comment right on top:
> http://cgit.openembedded.org/openembedded/plain/recipes/mplayer/files/vo_omapfb.c
> explicitly says that _downscaling_ doesn't work that should
> mean that upscaling certainly should work.
> (Note: there is some ancient code there, so that link is not meant as
> endorsement...)

I've been using the xf86-video-omapfb driver but I haven't tried -vo
omapfb.  How can I get mplayer to consider that omapfb C file at
compile time?  Does it just need to be in a certain folder in the

- Grant

More information about the MPlayer-users mailing list