[MPlayer-users] mencoder: failure to copy audio tracks on certain DVDs

Alexander Roalter alex at roalter.it
Tue Mar 11 14:27:36 CET 2014

Am 28.02.2014 21:15, schrieb Reimar Döffinger:
> On Fri, Feb 28, 2014 at 09:11:34PM +0100, Pascal Stumpf wrote:
>> On Fri, 28 Feb 2014 20:29:32 +0100, Reimar =?iso-8859-1?Q?D=F6ffinger?= wrote:
>>> Yes, or exact command-lines. I tried something with mencoder
>>> and it worked, but I did maybe not test quite the same
>>> thing, and I certainly did not get a crash with lavf. So I'm
>>> afraid you'll have to instruct me how to reproduce these
>>> issues.
> [...]
>> For this particular DVD, mplayer -dumpaudio does not work.  I've
>> uploaded a 10mb sample that shows the problem for me.
>> ./mplayer -v -dumpaudio -aid 131 /tmp/tng.nosound
> I should have told you:
> You should be able to fix any of these by in demux_mpg.c
> editing this line (824 currently) to use a larger number:
> int max_packs=2048;
> The problem is I am concerned that raising this much higher
> might cause serious issues in some cases, so currently I
> don't know what to do about this issue.

I get the same error (non-playing audio with the standard demuxer, 
working with lavf). With the standard demuxer, I get

Too many audio packets in the buffer: (4096 in 8257532 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

Changing line 824 to 5000 works now, but since you mentioned it, I’m 
afraid of keeping it that way... What does lavf do different so that the 
number of audio packets is not an issue there?

More information about the MPlayer-users mailing list