[MPlayer-users] MPlayer – changing ‘ao=’ codec order in mplayer.conf does not appear to work for per user config?

Jim Cross jimgcross at gmail.com
Fri Sep 12 11:37:22 CEST 2014

Thanks for your quick response and detail Reimar. I did wonder if it was a
file or directory, so tried both.
I can get it to work from command line (logged in as pi, has a home
directory which mplayer obviously finds)

But: I am trying to work out how to run MPlayer from a python script that
is called from a browser (javascript) using lighttpd web server (user and
group www-data:www-data). MPlayer response is 'Cannot find HOME directory.'
and therefore, I guess, can not pick-up the new audio codec order.... I
have tried creating a 'home' dir for www-data with config in .mplayer to no
avail. I don't have the expertise to work out what MPlayer is searching for
or if I can change what it looks for as way of a 'home' dir.?

On Thu, Sep 11, 2014 at 9:33 AM, Reimar Döffinger <Reimar.Doeffinger at gmx.de>

> On 11 September 2014 09:32:26 CEST, Jim Cross <jimgcross at gmail.com> wrote:
> >changes to the mplayer.conf file in ~/.mplayer/config
> You should probably look more closely at the output for errors,
> ~/.mplayer/config is the config file, if you made it a directory and put a
> mplayer.conf in it it can't work.
> The easiest way is to remove .mplayer and only edit the files mplayer
> creates there instead of guessing the right names.
> _______________________________________________
> MPlayer-users mailing list
> MPlayer-users at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users

More information about the MPlayer-users mailing list