[MPlayer-users] MPlayer – changing ‘ao=’ codec order in mplayer.conf does not appear to work for per user config?

Jim Cross jimgcross at gmail.com
Sat Sep 13 19:24:01 CEST 2014

You would think!

But I set the perms so anyone can change the fifo as follows:
'sudo chmod 777 /run/shm/mpcontrol'

$ ls -al /run/shm/mpcontrol
prwxrwxrwx 1 www-data www-data 0 Sep 13 11:15 /run/shm/mpcontrol

But mplayer does not read the fifo (data stays in fifo and mplayer does not
change volume for example ) unless I run mplayer with sudo, then it appears
to work OK.

I have tried changing owner of fifo to pi:pi and root:root with the same
response, i.e. does not read fifo unless run with 'sudo'.

On Sat, Sep 13, 2014 at 12:19 PM, Reimar Döffinger <Reimar.Doeffinger at gmx.de
> wrote:

> On 13.09.2014, at 12:36, Jim Cross <jimgcross at gmail.com> wrote:
> > Thanks again for the suggestion.
> > Currently, programmatically (python script) I modify owner & group  of
> > '/etc/mplayer/mplayer.conf' to 'www-data:www-data' and then append
> > 'include=/var/www/mplayer.conf'.
> As long as you know you really shouldn't allow anyone but root to write
> the global one or anything it includes.
> If the www-data account is compromised the config file can be used to take
> any other accounts that use MPlayer.
> > Obviously, this allows the same goal and
> > have a modifiable config file but is a bit hackish. That said, there is
> > still an issue to get the fifo (obviously slave mode) to work (for
> mplayer
> > to read the fifo), I still need to start mplayer with sudo for it to read
> > the fifo, again a bit hackish.
> Fifos should have permissions like any other file, so you just adjust them?
> _______________________________________________
> MPlayer-users mailing list
> MPlayer-users at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users

More information about the MPlayer-users mailing list