[MPlayer-users] MPlayer – changing ‘ao=’ codec order in mplayer.conf does not appear to work for per user config?

Tom Evans tevans.uk at googlemail.com
Mon Sep 15 11:14:57 CEST 2014

On Mon, Sep 15, 2014 at 8:59 AM, Jim Cross <jimgcross at gmail.com> wrote:
> It is still not clear if this is expected behavior, a bug or I'm not
> configuring correctly?:
> Trying to run MPlayer from a browser using javascript via lighttpd web
> server and a python script.

This makes no sense to me. I have a similar home-brew
"mplayer+python+fifo" media player, it works like this - X starts,
.xinitrc starts mplayer in idle, slave mode, mplayer reads commands
from a fifo, the fifo is writable by user www, user www opens the fifo
and writes to it when it wants to.

> The 'home' directory is '/var/www' but MPlayer
> notifies 'Cannot find HOME directory.' - Does the home dir MPlayer looks
> for have to be located in the '/home/' directory structure?

mplayer looks at $HOME. Perhaps lighttpd is cleaning your environement
so that $HOME is not set. It's still unclear to me why you are trying
to make lighty invoke mplayer..

> As Mplayer is not able to locate home for lighttpd user www-data and the
> 'local' config file is not found, I tried using the
> 'include=/var/www/mplayer.conf' line in /etc/www/mplayer.conf but still
> need to run MPlayer with sudo to successfully read the fifo in slave mode.

This implies permissions. Work out where it is not correct and make it
correct. The user running mplayer should own the fifo, the user
writing to the fifo must be able to access it, there aren't that many
combinations to test..



More information about the MPlayer-users mailing list