[MPlayer-users] MPlayer – changing ‘ao=’ codec order in mplayer.conf does not appear to work for per user config?

Reimar Döffinger Reimar.Doeffinger at gmx.de
Tue Sep 16 01:39:08 CEST 2014

On 15.09.2014, at 21:25, Jim Cross <jimgcross at gmail.com> wrote:
> The problem or issue(s) (or bug) with this I believe is, MPlayer can not
> find the users config file. This can be resolved by editing the
> /etc/mplayer/mplayer.conf file to point to a config file (not ideal).

You (unintentionally) it seems explicitly undefined HOME and did not set MPLAYER_HOME.
MPlayer will not try to dig into your system internals just to work around this, if you tell it there is no home directory by undefining HOME it will just accept that.

> The
> second issue this appears to have, is with the fifio - mplayer does not
> read the fifo (data stays in fifo and mplayer does not change volume for
> example ) unless I run mplayer with sudo, then it appears to work OK.
> Currenty, I use the following fifo:
> -input file=/run/shm/mpcontrol

I would suggest starting with a simpler/saner location like /tmp.

> Even setting the perms so anyone can change the fifo as follows, doesn't
> work:
> 'sudo chmod 777 /run/shm/mpcontrol'
> Checking:
> $ ls -al /run/shm/mpcontrol
> prwxrwxrwx 1 www-data www-data 0 Sep 13 11:15 /run/shm/mpcontrol
> I have tried changing owner of fifo to pi:pi and root:root with the same
> response, i.e. does not read fifo unless mplayer is run with 'sudo'.

You say "it does not read it". That means it doesn't actually print any error?
In that case it's likely it does not read it because it is blocked.
One reason can be not reading its stdout, but there are other options like permission errors causing it to use a different ao that blocks it in the end etc.

More information about the MPlayer-users mailing list