[MPlayer-users] VDPAU missing out on AMD

Mikus Grinbergs mikus at mikusj.com
Mon Dec 7 07:39:53 CET 2015

I wanted to use hardware acceleration (playback) with an AMD video card, 
but I'm stymied.  My system runs 32-bit Fedora 23 with a Radeon HD 7770. 
  The DRI2 driver is 'radeonsi'.

It's difficult to assemble information abut AMD video acceleration. 
I've installed all the packages I've seen mentioned in conjunction with 
AMD acceleration, such as 'mesa-vdpau'.

Information on "What is needed to have MPlayer use video acceleration" 
isn't in one easy-to-understand place.  The main thing seems to be '-vo 
vdpau' to specify the "what" and '-vc ff...vdpau' to specify the "how".


With '-vo vdpau' in MPayer 1.2-5.1.1 (from Fedora), if I put in any '-vc 
ff...vdpau' (appropriate to the video file I was trying to play - I 
tried h264 and hevc and vc1 videos), MPlayer told me "The selected 
video_out device is incompatible with this codec", as well as a bunch of 
"Unexpected decoder output format Planar YV12" lines, then exited.

With '-vo vdpau' in MPlayer SVN-r37561-5.1.1 (I built), putting in any 
appropriate '-vc ff...vdpau' still had the same result, but with the 
hevc video the "Unexpected" lines kept coming until I stopped MPlayer.

I am NOT asking for a fix -- I'm just sharing what I saw.  I can 
continue video-watching even if hardware acceleration doesn't work.


What does surprise me is MPlayer telling me (on demanding videos): "Your 
system is too SLOW to play this!"  With my multi-core CPU at 3+GHz, and 
putting in 'threads=6', I would have thought I wasn't slow.


More information about the MPlayer-users mailing list