[MPlayer-users] use mplayer with slow rtmp stream

john smith wempwer at gmail.com
Sun Mar 6 21:04:18 CET 2016

On 3/6/16, Reimar Döffinger <Reimar.Doeffinger at gmx.de> wrote:
> On Sun, Mar 06, 2016 at 07:44:46PM +0100, john smith wrote:
>> I use rtmpdump to get a livestream I want to put as a screensaver
>> inside mplayer inside xscreensaver.  The command I use is:
>> rtmpdump -live -r 'rtmp://cdn-03.whatsupcams.com/live/es_laspalmas3' \
>>          -W http://www.whatsupcams.com/static/flowplayer/flowplayer.swf \
>>          -quiet | mplayer -cache 8192 -
>> The problem is that playback does not start at all but only in a
>> couple of minutes, instead I get a lot of this:
>> Cache empty, consider increasing -cache and/or -cache-min. [performance
>> issue]
> There are a few things that go wrong.
> On in particular is that FFmpeg has issues with the audio stream,
> it thinks there is one but it can't figure out the format.
> All issues can be worked around with:
> -lavfdopts probesize=32 -demuxer lavf

I tried this:

rtmpdump -v -r 'rtmp://cdn-03.whatsupcams.com/live/es_laspalmas3' \
         -W http://www.whatsupcams.com/static/flowplayer/flowplayer.swf  | \
          mplayer -lavfdopts probesize=64 -demuxer lavf -

but somewhere in the middle of output mplayer says:

34.155 kB / 10200.47 sec[live_flv @ 0x7f73ba6c2220]Stream #0: not
enough frames to estimate rate; consider increasing probesize
[live_flv @ 0x7f73ba6c2220]decoding for stream 0 failed
[live_flv @ 0x7f73ba6c2220]Could not find codec parameters for stream
1 (Audio: none, 0 channels): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options

I tried increasing probesize to 128 but to no avail. Playback is still
not started but on the bottom I can see this:

Load subtitles in ./
1248.490 kB / 10417.33 sec

Both numbers are growing - no cache errors this time.

<wempwer at gmail.com>

More information about the MPlayer-users mailing list