[Ffmpeg-devel-irc] ffmpeg.log.20140501

burek burek021 at gmail.com
Fri May 2 02:05:01 CEST 2014

[00:15] <GTAXL> How can I capture/record a dynamic stream to a file? The stream appears to be several f4f files
[00:18] <codepython777> klaxa: I cut my movie into 3 segments - but when i concatenate it, i see errors. with or without -c copy, both go wrong in the 3rd segment
[00:19] <codepython777> klaxa: http://pastebin.com/8ZJpYvHe
[00:33] <c_14> If you only want to delete part of your video, you would only need 2 segments. Can you paste the commandline[s]?
[01:37] <funyun> hi. how can i force an aspect ratio? i want to encode a video that has a wrong AR of 3:2 instead of the correct 4:3. i've tried -vf scale but it keeps the AR 3:2.. any help?
[01:39] <c_14> tried -aspect yet?
[01:42] <funyun> c_14: that did it. thanks :)
[01:42] <c_14> np
[01:51] <kleing> hey guys i need to stream live video/audio from multiple inputs over very low bandwidth WiMax to another WiMax point that may also be streaming as well. I was thinking of using ffmpeg server and H.264 with RTSP. does this seem good or is ffmpeg overkill for this or any ideas appreciated. thanks
[01:53] <kleing> also people very unfamiliar with computers will be using this system, and can't provide support for it after installed. is possible to make ffmpeg automated/simple enough (GUI?) to use for this situation?
[08:26] <crtxc> When compiling ffmpeg for linux must I specify for 64 bit architecture?
[11:11] <kolizer> Hey, tell me how I can make a record with an overlay screen webcam?
[11:19] <kolizer> I need to capture the desktop and webcam at the same time. help
[11:48] <ubitux> -f v4l2 -i /dev/video... for webcam, -f x11grab -i ... for the desktop, -lavfi "[0:0][1:0] overlay=..." to make the overlay
[11:54] <kolizer> hmmm
[11:57] <kolizer> Can detail how to make an Overlay?
[12:03] <ubitux> kolizer: http://ffmpeg.org/ffmpeg-filters.html#overlay-1
[12:04] <ubitux> you have examples below
[12:07] <kolizer> ok
[12:39] <kolizer> Low FPS-lavfi "[0:0] [1:0] overlay =
[12:40] <kolizer> I need to to stream on twitch
[12:40] <kolizer> flv format
[13:13] <kcynice> hello, could I play a video without SDL? I don't need it, it maintain its own events loop, i want to control all by myself
[13:19] <kolizer> http://pastebin.com/vJY7k9EG
[13:20] <kolizer> webcam is not recorded
[13:21] <kcynice> to whom?
[13:21] <kolizer> image only
[13:22] <kolizer> What is wrong?
[13:22] <kcynice> a invalid pastebin
[13:23] <kcynice> oh, sorry, might due to my network
[13:32] <kcynice> i just don't know your were talk to me or not
[13:36] <kcynice> The fact is, I use slackware linux, however, most of the media player were not do well in for my local language, although they all perfect.
[13:37] <kcynice> And, I start to learning GUI development, so, I want to implement a simple player for myself, support my local language
[13:37] <kcynice> And, do what I want to.
[13:39] <kcynice> now, i have to decode every frame into RGB, and copy to another buffer to display on the window. Its too slow, so that, the video looks not smooth.
[13:41] <kcynice> If following the tutorial, i will can work with SDL, but can't insert more window elements i want.
[13:55] <Mavrik> kcynice, you can play video however you want
[13:55] <Mavrik> ffmpeg decoders will give you raw frames and you display them in whatever way is suitable (and fast enough) for you
[13:56] <kcynice> yes, for so long a period, i have use play music and video by command line
[13:56] <kcynice> yes, im puzzled how to display them
[13:57] <kcynice> SDL might not suit for multiple subwindows, etc
[14:32] <GTAXL> Which -target type would I use with mp4?
[14:33] <JEEB> I don't think the -target option has been relevant for a really long time
[14:33] <GTAXL> well I keep getting this
[14:33] <GTAXL> Unable to find a suitable output format for '/home/gtaxl/newsvid/Thu-May-01-2014-'
[14:34] <JEEB> that's because your output file name doesn't seem to have an extension?
[14:34] <GTAXL> but it does
[14:34] <JEEB> well then you didn't write it down in a manner that ffmpeg parses it
[14:34] <GTAXL> it did work before I removed -r
[14:34] <GTAXL> /home/gtaxl/newsvid/$TIME.mp4
[14:34] <GTAXL> I removed -r cuz audio kept getting out of sync
[14:35] <JEEB> -r should have nothing to do with it :P
[14:35] <GTAXL> JEEB, the audio gets out of sync due to the dropped frames
[14:35] <JEEB> no, I mean
[14:35] <GTAXL> atleast that's what I've heard
[14:35] <JEEB> removing or keeping the -r
[14:35] <JEEB> should not affect the file name stuff at all
[14:35] <JEEB> anyways, if what you pasted is true, you have failed somewhere to pass the full generated path to ffmpeg
[14:36] <JEEB> see how the string gets generated
[14:36] <JEEB> try printing it out
[14:37] <JEEB> see if there are spaces, commas or anything else that has to be dealt with
[14:37] <JEEB> as in, escaping stuff that has to be escaped
[14:39] <crazy_crawler> Hi, all, would someone please help me with the following?
[14:39] <crazy_crawler> I want to capture video and audio in a computer inside a network where I can open ports
[14:40] <crazy_crawler> and I want to live stream that capture in a remote server
[14:40] <crazy_crawler> using netcat for example
[14:41] <crazy_crawler> i tryed with the following in the capturing machine: cat /dev/video0 | nc <remote_server> 9500
[14:42] <crazy_crawler> but real problems being in the remote server: nc -l -p 9500 | ffmpeg -v verbose -r 5 -s 640x480 -f rawvideo -i - http://localhost/webcam.ffm
[14:42] <crazy_crawler> does not work
[14:43] <crazy_crawler> begin*
[14:45] <GTAXL> yeah somehow there is a space between the Y and K
[14:45] <GTAXL> TIME=$(date +"%a-%b-%d-%Y-%k-%M")
[14:47] <JEEB> GTAXL, so yeah, escape that and you should be fine. Or find out why it puts a space there and have fun
[14:57] <fsad> hello
[14:58] <fsad> I would like to ask how to run ffplay on fbdev  (without X11)
[15:59] <manolo> hey anybody online?
[16:00] <manolo> hi all!!
[16:23] <manolo> hi all, anyone online willing to help?
[16:23] <c_14> Just post your problem and if someone can help you, they will.
[16:26] <manolo> ok thx
[16:27] <manolo> I have two computers. One local with a webcam under a firewall I cannot change and then another remote under I firewall I administer. I want to send via netcat the video stream capture in the first computer and show it via web in the second one.
[16:28] <manolo> video + audio
[16:29] <c_14> What do you mean "show it via web".
[16:31] <manolo> I want the users to type a url and watch the video
[16:31] <manolo> like http://remotemachine.com/stream or similar
[16:33] <manolo> I say netcat because I cant figure out nothing better, but feel free to tell me about other approaches if u happen to know any other
[16:34] <c_14> If you want to use netcat && stream it in a browser, you'd have to emulate a webserver using netcat and then offer up the stream in a format that the browser can play.
[16:34] <c_14> You could also try using ffserver.
[16:34] <c_14> But this sort of string isn't my forte.
[16:35] <manolo> I was thinking of streaming with ffmpeg and sending the stream with nc to the remote computer
[16:35] <manolo> and capturing it with ffmpeg or mplayer and create the http socket
[16:37] <manolo> whatever you find easier
[16:37] <manolo> as long as it works
[16:37] <c_14> If you want to play it with ffmpeg or mplayer, you don't need to go through the trouble of of working with http, just use ffmpeg to capture the webcam, pipe that to an nc -l $port, use nc on the other computer to connect to otherpc $port and pipe that into mplayer/ffmpeg.
[16:40] <manolo> ok
[16:40] <manolo> i've been with that pipe thing
[16:40] <manolo> but i found myself unable to pipe the output to the stout
[16:40] <manolo> ffmpeg -f alsa -i plughw:CARD=Intel,DEV=0 -f video4linux2 -s vga -i /dev/video0 outputfile.mpg
[16:41] <manolo> this is what I have so far and it is working
[16:41] <manolo> but it goes to a file not to the stdout
[16:42] <c_14> instead of outputfile.mpg try -f mpegts pipe:1
[16:42] <manolo> cool
[16:42] <manolo> lemme see
[16:44] <manolo> coool
[16:44] <manolo> it looks like it works
[16:45] <manolo> cool hahaha
[16:46] <manolo> now lets say i would like to serve this video+audio stream in a URL
[16:46] <manolo> ffmpeg -v verbose -r 5 -s 640x480 -f rawvideo -i - http://localhost/webcam.ffm
[16:47] <manolo> i've seen things like this
[16:47] <c_14> That would be ffserver: https://trac.ffmpeg.org/wiki/Streaming%20media%20with%20ffserver https://www.ffmpeg.org/ffserver.html
[16:49] <manolo> yup, already running
[16:49] <manolo> lettme have a lot at that anyway
[16:51] <manolo> got ir running
[16:51] <manolo> but when i try to access the url
[16:51] <manolo> the browser tries to download it
[16:53] <c_14> Ye, browsers tend to do that. You'll probably have to embed it into a webpage somehow or use a format that the browser knows how to handle.
[16:53] <manolo> sounds good
[16:54] <manolo> lemme google
[16:57] <manolo> flv format would be automatically interpreted by the browser, right?
[16:57] <sacarasc> Not necessarily.
[16:57] <sacarasc> Depends on the browser.
[16:58] <manolo> chrome and firefox would if i'm not wrong
[16:58] <manolo> letme see how do i turn input video into flv
[17:06] <manolo> nope, it wants to download the flv file too
[17:07] <manolo> any idea?
[17:08] <manolo> how do i get the browser to read this? maybe I can code some html and embed the flv, does that make sense?
[17:27] <manolo> im back
[17:45] <manolo> ok, im finding hard to make the flv thing work
[18:08] <blippyp> manolo: http://www.ehow.com/how_6881535_embed-flv-video-html.html
[18:10] <manolo> thx
[18:10] <manolo> i think i failed one step before
[18:11] <manolo> iam back to mpeg
[18:11] <manolo> i start the capturing computer with the netcat
[18:11] <manolo> and the remote computer
[18:11] <manolo> if I create a file as output in the remote computer, it works
[18:12] <manolo> i can play that file and works
[18:12] <manolo> but if try to do an http stream it fails
[18:12] <c_14> That's because netcat doesn't server http
[18:13] <manolo> let's start over and see where I am failing
[18:13] <manolo> 2 computers
[18:13] <manolo> one with the webcam and behind a firewall that i dont manage
[18:14] <manolo> one remote computer, the one that will be access by the clients
[18:14] <manolo> I can change the firewall rules
[18:14] <manolo> i run the following command in the remote server:
[18:14] <manolo> sudo nc -l -p 110 | avconv -v verbose -r 30 -s 640x480 -f rawvideo -i - http://localhost/webcam.ffm
[18:15] <manolo> ffserver already up
[18:15] <manolo> and then inthe local machine:
[18:15] <manolo> ffmpeg -f alsa -i plughw:CARD=Intel,DEV=0 -f video4linux2 -s vga -i /dev/video0 -f mpegts pipe:1 | sudo netcat <server> 110
[18:16] <manolo> what's wrong?
[18:17] <c_14> What error are you getting?
[18:18] <manolo> actually none
[18:18] <manolo> i try ffplay http://<server>:8080/webcam.mjpeg
[18:18] <manolo> but it does not work
[18:19] <c_14> What is the ffserver output saying?
[18:20] <manolo> where do i find that?
[18:20] <c_14> You said >ffserver already up. ffserver by default doesn't background itself, so wherever ffserver is putting stdout/stderr
[18:20] <manolo> invoked it with &
[18:21] <manolo> lemme see
[18:23] <manolo> I see no output
[18:23] <manolo> used a new terminal and no &
[18:23] <manolo> and there is no output
[18:23] <c_14> Try with -loglevel debug
[18:23] <c_14> And the output when the client tries connecting.
[18:24] <manolo> cool
[18:24] <c_14> And the output when ffmpeg tries connecting
[18:25] <manolo> this is what i get when a client connects
[18:25] <manolo> [ffm @ 0x645280] Probed with size=2048 and score=101
[18:25] <manolo> one line per try
[18:27] <c_14> Can you paste your ffserver.conf
[18:27] <manolo> ok
[18:28] <manolo> http://pastebin.com/3w39Yujj
[18:31] <c_14> What errors is ffplay giving you?
[18:31] <manolo> it simply does nothing
[18:32] <c_14> Can you paste the complete output of the ffmpeg -f alsa command and the avconv -v verbose command?
[18:33] <manolo> on my way
[18:34] <manolo> this both in the remote server, right?
[18:34] <blippyp> correct me if I'm wrong (he is useing avconv, not ffmpeg) - but I don't think he's using the ffmserver.conf file - he's sending rawvideo through the server....???
[18:34] <manolo> avconv in the remote
[18:34] <manolo> ffmpeg in the local computer
[18:34] <c_14> he's doing both
[18:34] <manolo> avconv.conf
[18:35] <blippyp> he didn't specify the ffserver.conf file though - he fed the options in manually no?
[18:35] <manolo> http://pastebin.com/3w39Yujj
[18:35] <manolo> avserver.conf
[18:35] <manolo> not avconf.conf sorry
[18:36] <blippyp> yes - I read your conf file - but you didn't specify it in you avconv command when server it... with ffserver you need to do that I believe... (but I may be wrong - I know in my example I specify my conf file)
[18:36] <manolo> remote machine: avserver -f /etc/avserver.conf -loglevel debug
[18:37] <blippyp> oh sorry
[18:37] <manolo> no no keep it up
[18:37] <manolo> i'm doing something wrong
[18:38] <c_14> That paste was your conf file again, did you forget to update your paste buffer?
[18:38] <blippyp> I'm looking -  but I was clearly on the wrong track
[18:38] <blippyp> your conf file is fine
[18:38] <blippyp> it's identical to mine basically
[18:38] <manolo> sorry c_14 gimme a second
[18:38] <manolo> just a question
[18:38] <manolo> ffmpeg in the local machine and avconf in the remote, write?
[18:39] <manolo> i mean ffmpeg -f alsa in the local (webcam capturing computer)
[18:39] <manolo> and in the remote computer avconv -v verbose
[18:39] <manolo> right?
[18:40] <c_14> I wanted the output of the commands you were using, what I said was just a short snippet of the command you were using so you could identify which ones I meant.
[18:41] <blippyp> what is the output of your avconv command: sudo nc -l -p 110 | avconv -v verbose -r 30 -s 640x480 -f rawvideo -i - http://localhost/webcam.ffm
[18:42] <manolo> http://pastebin.com/DNY1ZUWG
[18:42] <manolo> that the output of the commands
[18:42] <manolo> ohh cool
[18:42] <manolo> one sec
[18:43] <blippyp> why are you piping it - what's the point of: ffmpeg -f alsa -i plughw:CARD=Intel,DEV=0 -f video4linux2 -s vga -i /dev/video0 -f mpegts pipe:1 | sudo netcat <server> 110
[18:44] <manolo> i need that output in a remote computer
[18:45] <manolo> I dont know any other way
[18:45] <blippyp> oh - you're sending the video from your client - to the server and then serving it on the web? (sorry I haven't read everything)
[18:45] <blippyp> is that right?
[18:45] <manolo> http://pastebin.com/mHvRRPin
[18:46] <manolo> no problem blippyp I can explain once again
[18:46] <blippyp> no that's okay - just correct me if I was wrong - I think I'm on the same page now (I've never tried this though)
[18:46] <manolo> I'm sending the captured video + audio to a remote machine
[18:47] <manolo> and I want the remote machine to serve it as kind of web, i want clients to just visit a url
[18:47] <manolo> if possible
[18:47] <blippyp> everything looks good to me - but I haven't done the piping bit - but everything in my example seems to match - I'm guessing that your piping isn't working
[18:48] <blippyp> you need to work on that I think...
[18:48] <manolo> if i do:
[18:49] <blippyp> what happens when you open the page?
[18:49] <manolo> sudo nc -l -p 110 | avconv -v verbose -r 30 -s 640x480 -f rawvideo -i - manolo.mpeg I get a working video
[18:49] <blippyp> from your piped source?
[18:50] <manolo> when I open the page the browser wants to download some file
[18:50] <blippyp> what browser are you using?
[18:50] <blippyp> I'm using luakit - and mjpeg's work fine through it...
[18:51] <blippyp> I didn't have to change anything to get it working - but in your browser you might
[18:51] <manolo> chrome
[18:51] <blippyp> change your output format to something else in your server.conf file and try a different format until you get one that will work for you...
[18:51] <manolo> when i make it go to a video file
[18:51] <manolo> i get this errors:
[18:51] <manolo> [mpeg @ 0x64cb00] packet too large, ignoring buffer limits to mux it [mpeg @ 0x64cb00] buffer underflow i=0 bufi=278688 size=284432
[18:52] <blippyp> http://sprunge.us/CahW
[18:52] <blippyp> http://sprunge.us/LdIR
[18:52] <blippyp> try those
[18:52] <manolo> ok
[18:53] <blippyp> sorry I gotta go - my kids crying
[18:53] <manolo> okk
[18:53] <manolo> thx
[18:56] <blippyp> did you try it?
[18:57] <manolo> yup
[18:57] <manolo> File '/webcam.mjpeg' not found
[18:57] <manolo> :(
[18:57] <blippyp> no it's not a mjpeg anymore
[18:57] <blippyp> just open the html page
[18:57] <blippyp> put it on your server
[18:57] <blippyp> now it's sending a flash file which is embed in the html
[18:59] <blippyp> (ie: you shouldn't have done anything different except start your avserver with the conf file I gave you, then put he index file on your server and open that link instead of the 80:80mjpeg link you had)
[18:59] <manolo> gimme a min
[18:59] <manolo> on my way
[18:59] <blippyp> keep all your other commands the same (the piping and everything) and it should work fine
[19:00] <blippyp> as long as you have flash installed on your client, you shouldn't run into problems
[19:01] <manolo> I get an empty white page
[19:01] <blippyp> is your page accessible to me? if so what's the link?
[19:02] <manolo> http://test.circulospodemos.info/ffmpeg.html
[19:02] <manolo> now i get output from the avconv server
[19:03] <manolo> http://pastebin.com/m57JYuRT
[19:04] <blippyp> maybe it can't convert from the ts file into the swf???
[19:04] <blippyp> Change your server conf file to produce an MPG file instead of an mjpeg format
[19:04] <manolo> :S no idea
[19:04] <manolo> ok
[19:04] <blippyp> delete that html page I gave you - it's no good
[19:05] <manolo> ok
[19:05] <blippyp> then when you open your link (should be an http://....:8080/webcam.mjpg) link instead it will probably ask you to download it
[19:05] <blippyp> if it does - then just open that link with mplayer instead
[19:06] <manolo> what do i have to change exactly?
[19:06] <blippyp> and it should play
[19:06] <blippyp> don't know - never done it in a mpg format yet - only in mjpeg and swf
[19:07] <manolo> ok letme see
[19:07] <blippyp>  https://www.ffmpeg.org/sample.html
[19:10] <blippyp> maybe you can't?
[19:10] <blippyp> you've proven that the pipe is working
[19:10] <blippyp> but I think it's having issues with converting your piped input to the output you need
[19:10] <manolo> I think so
[19:10] <manolo> can we try with a simple version
[19:10] <blippyp> you might need to change your piped output to a format that the server can instantly send...
[19:10] <blippyp> if that makes sense?
[19:11] <latenite> Hi folks, I try to make a screencast. But the video I record plays like in fast forward....
[19:11] <latenite> ffmpeg -f alsa -i plughw:0 -f x11grab -s 1440x900 -r 30 -i :0.0 -ar 22050 -ab 128k -acodec libmp3lame -vcodec libx264 -threads 0 Screencast.avi
[19:11] <manolo> and use mplayer o something?
[19:11] <latenite> What am I missing here?
[19:11] <manolo> I would totally do that
[19:11] <manolo> but how do I turn raw camera into something else?
[19:12] <blippyp> with that command you just sent
[19:12] <blippyp> you change your acodeca nd vdoecs to something different to pipe out a different format
[19:12] <manolo> -f flv?
[19:13] <blippyp> in the example you just sent - it would send an avi container with an mp3 audio codec and a x264 video codec
[19:13] <blippyp> it will get that automatically from your .avi extension - you shouldn't need to specify -f manually as far as I know
[19:14] <latenite> blippyp, to be honest....I fiddeled that together...
[19:14] <blippyp> actually from that link I gave you - I think it will serve and mpg file...
[19:14] <latenite> I thought mp3 as audio is ok?
[19:15] <manolo> i c
[19:15] <blippyp> yeah, I think that would work - but I usually use a mp4 or a mkv container - (I also usually use ac3 for audio) but I think you can put those codecs in an avi container either way...
[19:16] <blippyp> manolo: change your ffsever to state that the format is mpeg
[19:16] <blippyp> and change your filename to webcam.mpg
[19:16] <blippyp> and try to connect to it - I think that should work...
[19:16] <manolo> I can do it your way if you think it is easier o better
[19:17] <manolo> it is not necessary to keep my version
[19:17] <blippyp> you would still need to create a html5 page to view it - but you should be able to connect to your 80:80 port the same with mplayer and view it immediately...
[19:17] <manolo> as long as I can make it "web" later
[19:17] <manolo> ok
[19:18] <blippyp> oh wait - you might need to use avi format
[19:18] <blippyp> I see that mpeg is mpeg-1 according to this page
[19:18] <blippyp> so the way you said earlier with an avi is probably what you need
[19:18] <blippyp> then use mplayer to open the file
[19:20] <manolo> so i should change my avserver.conf
[19:20] <manolo> to serve avi?
[19:20] <blippyp> yup
[19:20] <galex-713> Hello
[19:20] <blippyp> and leave everything else you had it (even your piping with the ts format)
[19:21] <blippyp> that will pipe your ts to an x264 format - I think that will work fine
[19:21] <manolo> ok, lets play a little and see
[19:21] <blippyp> I'm trying it myself (only without the piping)
[19:21] <galex-713> I tried to extract audio from a webm file (499kbps) and convert it to libopus with avconv but it didnt work at all and crashed, so I retried with my precompiled static version of ffmpeg, and it worked, but it constantly bark in yellow Non-monotonous DTS in output stream 0:0; previous: <big number A = A_{n-1}+1>, current: <big number B < A>; changing to <big number A + 1>. This may result in incorrect time stamps in
[19:22] <galex-713> And it stoped at 1h, and some minutes afterward did it again
[19:23] <latenite> so how do I change up my command? sorry I am a littlel lost
[19:24] <manolo> if you get something post it I'll be watching
[19:24] <galex-713> Oh also, ffmpeg static precompiled version I have doesnt support libopus, so I used libvorbis in order to then convert it to opus with avconv when I would get a clean output
[19:24] <blippyp> doesn't seem to be working for me
[19:24] <blippyp> everything seems fine until I try to view and then it complains
[19:27] <blippyp> latenite: change your acodec to ac3 and your output file to screencast.mp4
[19:27] <blippyp> try that
[19:28] <blippyp> sorry - i wasn't paying attention I was lost with manolo
[19:30] <latenite> blippyp, Ok let me try that....and thanks :D
[19:30] <latenite> it still plays like in fast foreward
[19:30] <latenite> ffmpeg -f alsa -i plughw:0 -f x11grab -s 1440x900 -r 30 -i :0.0 -ar 22050 -ab 128k -acodec ac3 -vcodec libx264 -threads 0 Screencast.mp4
[19:33] <latenite> does it work with you?
[19:33] <blippyp> never tried - here's what I used for a basic grab: ffmpeg -f x11grab -i :0.0 -s 1366x768 -r 30 -c:v libx264 -preset ultrafast -an sc.mp4
[19:35] <blippyp> latenite: for more options, here's the last screencapture script I was working on: http://sprunge.us/YEBe
[19:38] <latenite> blippyp, cool :D
[19:38] <latenite> I treid
[19:38] <latenite> ffmpeg -f x11grab -i :0.0 -s 1440x900 -r 30 -c:v libx264 -preset ultrafast -an sc.mp4
[19:38] <latenite> but it only captures like 2/3 of my screen. Although changes the resolution
[19:39] <JEEB> that's because the -s after -i scales the input
[19:39] <JEEB> I think there was a -resolution or whatever option that you could tuck there before -i
[19:39] <blippyp> look at the sprunge link I gave it - it's more detailed
[19:39] <blippyp> it has options for video/audio etc...
[19:40] <JEEB> or yes, -s before -i
[19:40] <JEEB> before -i = input settings, after -i = output settings
[19:40] <JEEB> in ffmpeg in general
[19:42] <latenite> JEEB, but my screen is 1440x900
[19:43] <latenite> that's why I went for-s 1440x900
[19:43] <JEEB> re-read my last sentences
[19:43] <JEEB> before and after -i do different things
[19:44] <blippyp> change your -i to -i :0.0+1440x900
[19:45] <blippyp> get rid of the -s 1440x900
[19:45] <blippyp> and after the -c:v libx264 add a -qp 0
[19:46] <blippyp> that will record a perfect quality video for you really fast - but it will create a large file
[19:46] <blippyp> so you will likely want to edit/re-encode it again later or play with your compressions settings for you command to get a match you like
[19:48] <blippyp> ie: if you're doing basic screencasting with little load on your system (like using an editor or something) you can get away with higher compression, but if you're capturing gameplay, you will want to keep it as it is so that ffmpeg isn't chewing up your resources while you play, then re-encode later when you're done
[19:49] <blippyp> manolo: you having any luck? I can't get it...
[19:50] <latenite> blippyp, so the -qp 0 is kind of the a "gameplay" switch?!
[19:50] <latenite> it fails https://gist.github.com/anonymous/04000785450b308a7afa
[19:50] <blippyp> -qp - is a lossless encoding...
[19:50] <blippyp> creates a large file
[19:50] <latenite> thing is...I dont get the error
[19:50] <manolo> I'm on my way
[19:50] <manolo> If i get it I will post the solution here
[19:50] <manolo> this is really driving me crazy
[19:51] <blippyp> if you want to compress the video as you get it then get rid of the -qp 0 option and instead use a -crf 17 (or similar) - the lower the better compression (anything higher than 17 will clearly alter your video)
[19:51] <blippyp> manolo: yeah - I think it's having problems with converting the v4l feed
[19:51] <blippyp> maybe use your original command - and pipe that into another command that sends it out?
[19:52] <bakers> Is the VP9 encoder not multi-threaded yet?
[19:52] <blippyp> I don't know - it crashes on me while trying to send the video
[19:52] <manolo> mm
[19:52] <manolo> do you think the compresion is necessary to get a basic working version?
[19:52] <blippyp> no
[19:52] <blippyp> I would try anything just to get a 'working' version
[19:52] <blippyp> then alter from there
[19:53] <latenite> the -i :0.0+1440x900 crashes? What is difference to using -s -1440x900 ?
[19:53] <blippyp> -s resizes your output
[19:54] <latenite> can you tell by my paste what is failing?
[19:54] <blippyp> the -i :0.0+1440x900 tells it to capture screen 0:0 (from top left corner with a width of 1440x900)
[19:54] <blippyp> paste your command and output and I'll look
[19:54] <latenite> https://gist.github.com/anonymous/04000785450b308a7afa
[19:56] <manolo> that's it blippyp, that's what I'll do
[19:56] <blippyp> ^works for me
[19:57] <blippyp> latentie: works for me
[19:57] <blippyp> all I did was change the resolution to match my screen - copied your command exactly
[19:58] <blippyp> run ffmpeg by itself (no options) and paste the output
[19:58] <blippyp> oh wait - no need
[19:59] <latenite> https://gist.github.com/anonymous/01c29c46738452348ad4
[19:59] <latenite> :D
[19:59] <blippyp> not sure why it's crashing for you...???
[19:59] <blippyp> what distro are you using?
[19:59] <latenite> arch linux
[20:00] <blippyp> same here
[20:00] <blippyp> you got ffmpeg from the aur?
[20:00] <blippyp> or is 2.2 in the community now?
[20:01] <latenite> its in community :D
[20:01] <blippyp> when I built that script it was for an older ffmpeg - but it worked for the ffmpeg I pulled from the aur - I compiled my own version of ffmpeg now though, and it still works fine for me...
[20:01] <blippyp> I am at a loss for you...
[20:02] <blippyp> one thing I notice that's weird though
[20:02] <blippyp> is that you're pulling 1440x900 - but the width and height from x11 says 640x480?
[20:02] <blippyp> x11grab
[20:04] <latenite> https://gist.github.com/anonymous/9ee092c0cf5e1f8cdc27
[20:04] <blippyp> you do still need the -s option - that's why it's spitting it out at 640x480
[20:04] <latenite> I dont have x11grab but I this ^^ does it.
[20:05] <latenite> blippyp, I though I had to take it out
[20:05] <latenite> ffmpeg -f x11grab -i :0.0+1440x900 -r 30 -c:v libx264 -qp 0 -preset ultrafast -an sc.mp4
[20:05] <latenite> Where does it go?
[20:05] <blippyp> but I still can't figure out why it's erroing on you
[20:05] <latenite> sorry I feel stupid now :/
[20:05] <blippyp> it goes in the current path - in a file sc.mp4
[20:06] <blippyp> no need - something's wrong
[20:06] <blippyp> it should work for you without erroring
[20:06] <latenite> hmm ... :D I am clueless :D
[20:09] <blippyp> I am to - you have everything enabled that you need for that command - you're using ffmpeg and not avcon (so no problems there) - the only difference between your version and mine is that I compiled mine myself (ie: basically the same versions) - maybe it's something with your video driver or something???
[20:15] <latenite> blippyp, maybe ....I could try the same with my gentoo box
[20:15] <latenite> but
[20:16] <latenite> ffmpeg -f x11grab -s 1440x900 -i :0.0 -r 30 -c:v libx264 -preset ultrafast -an sc.mp4
[20:16] <latenite> works just fine :D
[20:16] <blippyp> I can tell you this though - I have two screens on the system I'm on (it's a laptop with an external monitor also attached) - if I try to record my maximum resolution (both screens) I get the same error as you
[20:16] <blippyp> weird
[20:16] <blippyp> I wonder why that is
[20:16] <latenite> well than maybe that a ffmpeg bug...
[20:17] <blippyp> maybe because you're specifically specifying the exact size of the screen - change it to drop a few pixels on your width and height and see if it still crashes on you
[20:17] <blippyp> I think it has something more to do with your video driver - it works fine for me unless I go beyond my screen size - BUT I can still specify my maximum and lower screen sizes without any issues
[20:17] <blippyp> or maybe an issue with x11?
[20:18] <blippyp> that would make more sense actually...
[20:18] <latenite> I tried 1200x800
[20:18] <latenite> some error though
[20:18] <blippyp> hm
[20:18] <latenite> what wrong about using
[20:18] <latenite> ffmpeg -f x11grab -s 1440x900 -i :0.0 -r 30 -c:v libx264 -preset ultrafast -an sc.mp4
[20:19] <latenite> because it just works....the result is just what I want
[20:19] <blippyp> there is nothing wrong with it
[20:19] <blippyp> but that means you can't use the other option for whatever reason
[20:19] <blippyp> not sure why
[20:19] <latenite> well cool. Lets not worry than. I am happy with that :D
[20:19] <blippyp> you probably don't care - it would bother me
[20:19] <blippyp> it's built into my script...  ;)
[20:20] <blippyp> glad you got it
[20:20] <latenite> oh ok, thats a bummer
[20:20] <blippyp> not for me - it still works for me...  :P
[20:20] <latenite> yeah I super happy for your help
[20:20] <blippyp> it's a feature you SHOULD be able to use - not sure why it isn't for you though
[20:20] <latenite> and I like the size of the file
[20:20] <latenite> 30min like 200MB
[20:20] <latenite> is cool
[20:20] <blippyp> that's small?
[20:21] <latenite> kind of yes
[20:21] <blippyp> and that was ith ultrafast and a qp 0?
[20:21] <blippyp> something doesn't add up
[20:21] <latenite> no qp 0
[20:21] <latenite> :D
[20:21] <blippyp> ah
[20:21] <blippyp> that's why
[20:21] <latenite> those get huge
[20:21] <latenite> I am fine the quality ...
[20:21] <blippyp> a crf or just no compression settings specified?
[20:21] <blippyp> it defaults to crf 23 I think
[20:22] <latenite> jst the command I pasted
[20:22] <latenite> ffmpeg -f x11grab -s 1440x900 -i :0.0 -r 30 -c:v libx264 -preset ultrafast -an sc.mp4
[20:22] <blippyp> I use 17 for a 'near lossless' encoding
[20:22] <blippyp> just remember if you're using a lot of your resources - you'll likely want to add the -qp 0 option to free some of those resources
[20:23] <blippyp> now alter that command to include your adio
[20:23] <blippyp> audio
[20:23] <latenite> lol...
[20:23] <latenite> how?
[20:23] <blippyp> you had it originally
[20:23] <latenite> ah ok...
[20:24] <blippyp> I can't find it - if you can't get it paste your original command again
[20:24] <blippyp> -f alsa -i plughw:0
[20:24] <blippyp> that
[20:24] <latenite> ffmpeg -f alsa -i plughw:0 -f x11grab -s 1440x900 -i :0.0 -r 30 -c:v libx264 -crf 17 -preset ultrafast -an sc.mp4
[20:24] <latenite> yes...
[20:24] <blippyp> an remove the -an option
[20:25] <latenite> what does the  -an do?
[20:25] <blippyp> removes the audio
[20:25] <latenite> there is no sound
[20:25] <blippyp> ;)
[20:25] <latenite> ahh lol
[20:26] <blippyp> do you have a cam? you can overlay your camera on top of the video
[20:26] <latenite> https://gist.github.com/anonymous/28c26a9c816a9cf69d6e
[20:26] <latenite> should I use a different one?
[20:26] <latenite> I SO wanted to do that....
[20:26] <latenite> Is that possible?
[20:27] <blippyp> looks good
[20:27] <blippyp> yup
[20:27] <blippyp> hold on
[20:29] <latenite> I sais to use "-strict 2"
[20:29] <latenite> https://gist.github.com/anonymous/9b55415f1bfc3b0c50be
[20:29] <latenite> but no luck :D
[20:29] <blippyp> ffmpeg -f alsa -i plughw:0 -f x11grab -s 1440x900 -i :0.0 -i /dev/video0 -lavfi "[2:v] scale=-1:240 [cam]; [3:v][cam] overlay" -r 30 -c:v libx264 -crf 17 -preset ultrafast  sc.mp4
[20:29] <blippyp> something like that - didn't test it - but it will be something like that
[20:30] <latenite> for now I need audio first....and that somehow fails
[20:34] <blippyp> after -preset ultrafast add -c:a ac3
[20:35] <latenite> there is "sound"....it does sound like me....BUT its broken....like stutter
[20:36] <blippyp> ffmpeg -f alsa -i plughw:0 -f x11grab -s 1440x900 -i :0.0 -f v4l2 -i /dev/video0 -lavfi "[2:v] scale=-1:240 [cam]; [1:v][cam] overlay" -r 30 -c:v libx264 -crf 17 -preset ultrafast -c:a ac3  sc.mp4
[20:36] <blippyp> that worked for me
[20:37] <blippyp> remove the -crf 17 and change it to -qp 0
[20:37] <blippyp> your stutter will probably disappear
[20:39] <latenite> It feels my machine is on super load
[20:40] <blippyp> your system might not (probably won't) handle the overaly in real time - recording them seperately and the overlaying them after is probably the best bet
[20:40] <blippyp> it is
[20:40] <latenite> my camera video is ON but frozen (no movement) and sound is stuttery
[20:40] <blippyp> is that with the overlay?
[20:40] <latenite> yes
[20:40] <blippyp> look at my previous statement
[20:40] <latenite> let my try that on my "monster" box :D
[20:40] <latenite> let see it "she" handles it :D
[20:41] <blippyp> you're better off just recording both video's into a seperate video stream on the same file - then overlay the video's when you're done
[20:43] <blippyp> ffmpeg -f alsa -i plughw:0 -f x11grab -s 640x480 -i :0.0 -f v4l2 -i /dev/video0 -map 0:0 -map 1:0 -map 2:0 -c:v libx264 -qp 0 -preset ultrafast -c:a ac3  sc.mp4 -y
[20:43] <blippyp> then overlay the two feeds
[20:43] <blippyp> streams
[20:44] <latenite> that creates the  sc.mp4 file
[20:44] <iamtakin1iteasy> hello, can ffmpeg for windows capture DirectX games?
[20:44] <latenite> blippyp, where is the second file?
[20:44] <blippyp> yes - but that sc.mp4 file will have two video streams
[20:45] <blippyp> run ffprobe on teh sc.mp4 file
[20:45] <latenite> ahhh how cool is that :D
[20:45] <iamtakin1iteasy> i know it can capture dshow, recording the regular screen effectively, but what about directx ?
[20:45] <blippyp> not sure
[20:45] <blippyp> never used ffmpeg on windows
[20:46] <iamtakin1iteasy> not much alternatives here :/
[20:46] <latenite> blippyp, I see :D . now how do I merge them into one?
[20:46] <blippyp> I think you have some options with directx though - you'll have to google them or wait till someone comes on who knows...
[20:47] <blippyp> ffmpeg -i sc.mp4 "[2:v] scale=-1:240 [cam]; [1:v][cam] overlay" -r 30 -c:v libx264 -crf 17 -preset ultrafast -c:a ac3  sc2.mp4
[20:47] <iamtakin1iteasy> blippyp: i have been trying googling -- didn't found anything that proofs that ffmpeg can do that, but i didn't found anything against either
[20:47] <blippyp> didn't test it yet - but something like that
[20:47] <iamtakin1iteasy> wikipedia places "?" mark at ffmpeg capability of recording directx in comparison table
[20:48] <blippyp> I don't think there's a lot of documentation on it - you'd have to look - you might need to be more familiar with directx to get further with it - like I said, I haven't played with it....
[20:48] <blippyp> I'm pretty sure it does it
[20:48] <latenite> blippyp, I played the unmerged sc.mp4...and it has perfect audio :D....make me happy
[20:51] <latenite> blippyp, now if you could help me merging them.....I could make the screencast I wanted to have (sound and cam in place)
[20:51] <latenite> that would be too cool
[20:51] <latenite> but I get this
[20:51] <latenite> https://gist.github.com/anonymous/d1ef12bf37101e573fe5
[20:52] <blippyp> ffmpeg -i sc.mp4 -lavfi "[0:2:v] scale=-1:240 [screen]; [0:1:v][screen] overlay" -c:v libx264 -qp 0 -preset ultrafast -c:a ac3  sc2.mp4
[20:52] <blippyp> that worked for me
[20:54] <blippyp> you might have to switch the 0:2:v to 0:1:v and the 0:1:v to 0:2:v (I think your feeds were saved in reverse)
[20:54] <blippyp> but either way
[20:55] <blippyp> you have the basic commands now - you just need to 'tweak' them to your needs
[20:56] <blippyp> run: man ffmpeg-filters for more options - you'll find all kinds of neat things you can use - I highly recommend learning how to use alphamerge
[20:57] <latenite> blippyp, thank you tons
[20:57] <latenite> the merge did work. Its heavily out of sync.....but oh well :D
[20:57] <latenite> alphamerge is a tool?
[20:57] <blippyp> it's a filter
[20:57] <blippyp> your video was out of sync because your recordings were too heavy on your system...
[20:58] <blippyp> it's best to record the video streams separately with different systems/devices
[20:58] <blippyp> I record my camera using my camera
[20:58] <blippyp> my screen using ffmpeg
[20:58] <blippyp> and merge them later
[20:59] <blippyp> my audio get's recorded on another device/system as well - I sync them all and only use the 'good' audio recording compbined with the audio from my ffmpeg recording and get rid of any other audio
[20:59] <latenite> I can try that too :D
[20:59] <blippyp> it's better
[20:59] <blippyp> your sync issues with disappear
[20:59] <blippyp> with-will
[21:00] <latenite> but how do you sync them? manually?
[21:00] <latenite> I meen they dont start all at the same time. right?
[21:00] <blippyp> it sesms complicated, but in the end I run a script to combine it all and make a nice video with preset settings for my videos and audio - it's pretty simple once you figure it out, and I never have to touch a video editor
[21:01] <blippyp> you recorded your desktop at too high of a resolution - the initial recording got screwed up because it couldn't handle the load you put it on - that's why you record them using different systems/devices and combine later with ffmpeg
[21:01] <blippyp> the only thing I have to do manually is sync my streams
[21:02] <blippyp> I have a few scripts I'm working on... ffmpeg is awesome
[21:02] <latenite> that is what I was asking. How do you sync the 3 streams to they are in sync?
[21:02] <blippyp> clap
[21:03] <latenite> I would "hate" to use a gui editor for that
[21:03] <blippyp> record audio in all of your streams and clap
[21:03] <blippyp> my final script is cool - if I'm recording my desktop it records a video of my choosing for the 'backdrop' - like gameplay or something...
[21:04] <latenite> ok then all have a "peak - clap" but how to I match/sync?
[21:04] <blippyp> then it overlays the screen capture of my desktop on the screen...
[21:04] <blippyp> use an audio editor to pull the 'time code' of the clap from each stream - and split the streams accordingly so that they all begin at the 'clap'
[21:04] <blippyp> ex: audio: clap is at 00:10:15
[21:05] <blippyp> ffmpeg -i audio.mp3 -s 00:10:15 output.mp3
[21:05] <blippyp> ex: video cam: clap is at 00:09:45
[21:05] <blippyp> ffmpeg -i cam.mkv -s 00:09:45 cam-out.mkv
[21:06] <blippyp> that way all the streams start at the same time with the video /audio syncing properly
[21:06] <latenite> yes but thats manual work. Now way a script could do that. ....also, sound is only in sync my +-1sec that is hardly enough?!
[21:06] <blippyp> trust me - it works really well and it's very simple and easy once you've done it a couple of times
[21:07] <latenite> cool, I will try that ....
[21:07] <blippyp> once everything is 'synced' you use video editors and stuff to add special effects or whatever you want done that ffmpeg won't do
[21:07] <latenite> I ll be back like mid next week....afert I play with it for a while...
[21:07] <blippyp> then when everything is ready you run ffmpeg to merge everything together all nicely for you
[21:08] <blippyp> it takes a while - get to know the ffmpeg-filters man page - it's your best friend
[21:08] <blippyp> my script even detects 'when I talk' and removes my camera video and displays my camera video depending on whether or not I'm actually speaking
[21:09] <latenite> wow? thats cool :D
[21:09] <latenite> you should "release" it once its done...
[21:09] <blippyp> yeah - it took a little c code to make that work in the end - but that basic functionality of it is built into ffmpeg
[21:10] <blippyp> the script also turns my camera feed into a 'cartoon' and removes the background with a green screen
[21:10] <blippyp> for old games it turns my 'cartoon cam' video into a 8bit pixel of me - so I look like a sprite from the game
[21:11] <blippyp> all blocky and shit
[21:11] <blippyp> and it's all automatic - I just synce the feeds
[21:11] <latenite> thats funny :D
[21:12] <latenite> so ffmpeg can to to "background removal" ?
[21:12] <latenite> like they do on the news/weather ?
[21:12] <blippyp> yeah - I get a kick out of it - it's not all completed yet - but I have the basics if not everthing working for all of these things - tested and proven to work already - I just have to get around to putting it all together...
[21:12] <blippyp> yup
[21:13] <blippyp> green screening isn't that hard - but you will need to learn how to use algorithms
[21:13] <blippyp> it's not a built in filter yet - but if you re-compile with frei0r enabled I think it has a filter for it - but I haven't tested it yet
[21:13] <blippyp> either way, i built my own already for it
[21:14] <latenite> sounds like a lot of work....but hey...its awesome
[21:14] <latenite> just please.. share it with the world one day :D
[21:15] <blippyp> it was a lot of work - but the scripts themselves are very small - getting the cartooning effect has been my biggest challenge - I recently got that to a point where I'm fairly happy with it now
[21:15] <blippyp> I probably will once I get it done
[21:16] <latenite> do you have a sample of the cartoon thingy?
[21:16] <latenite> I am curious what it looks like
[21:16] <blippyp> I haven't worked on it in a while - but I did just spend a lot of time working on the cartooning - I'm very excited that part is done now - I can spend a weekend on it and get it to an 'alpha' stage finally
[21:17] <blippyp> it's pretty cool actually - I have a few 'test' videos - but they're kind of lame - I look like shit and they all have something wrong with them... but I promise you it all works now - I just need to finally put it all together into one script
[21:18] <latenite> What gui video editor do you use?
[21:18] <blippyp> I can't wait for it actually - I can produce LP's like no one else at this point - and I can do it quickly - I could probably produce 2-3 videos in a day
[21:18] <blippyp> none - only ffmpeg
[21:18] <blippyp> linux sux for video editing - it's why I've been forced to do it this way - all the editors are buggy as hell
[21:19] <blippyp> and at their root - is basically ffmpeg - so I just went to the source
[21:19] <latenite> LP? whats that
[21:19] <blippyp> I use to use premiere and sony vegas on windows though
[21:19] <blippyp> the only thing I can't do with ffmpeg that I use to use editors for is tracking
[21:19] <blippyp> I literally have almost no need for them anymore
[21:20] <blippyp> unless I wanted to get really creative and use after effects or something
[21:20] <blippyp> which I've only used a couple of times before - but it is pretty sweet
[21:21] <blippyp> LP's - Let's Plays - which is the whole point of why I made the script
[21:21] <blippyp> I love watching them online - I would love to make my own
[21:21] <latenite> what is that?
[21:21] <latenite> I never head that
[21:21] <blippyp> people record themselves playing games
[21:21] <latenite> ahhh
[21:21] <blippyp> you've never heard of that?
[21:21] <latenite> I know what it is...sure....I just didn know the "term"
[21:21] <blippyp> wow - they're pretty cool if you find a good LP'er - most are annoying though
[21:22] <blippyp> but some are pretty good - I actually enjoy watching them as much as playing the games
[21:22] <latenite> so you "ego shoot" and talk while you record?...kind of like and enterrainer ? :D
[21:23] <blippyp> my initial method was very fast - I record and produced SO MANY videos - it was crazy - I was literally producing hours of video footage every day - and I NEVER had to re-encode the videos - my first attempts had literally like 200 30 minute videos in a weekend
[21:23] <blippyp> alll I had to do was play and the files were ready to go
[21:24] <blippyp> I've never seen an LP'er produce videos of that quantity
[21:24] <latenite> thats the power of linux.....thats like this in every field...
[21:24] <blippyp> But I wanted to do something special - And I think my current process that I'm working on is extremely unique - Enough to raise more than a few eyebrows
[21:24] <latenite> linux just makes you productive as hell
[21:24] <blippyp> linux had nothing to do with it - it was my recording process and having a PVR
[21:25] <latenite> PVR?
[21:25] <blippyp> my computers suck - so I don't game on them (unless they're old favorites) - I'm an old fart
[21:25] <blippyp> pvr - like a hauppauge hd pvr 2 (mine)
[21:26] <blippyp> it records 1080p video from hdmi/rca and encodes it for me
[21:26] <blippyp> I do my gaming on xbox
[21:26] <latenite> but how do you record on xbox?
[21:27] <blippyp> but I have LOTS of computers - like I'm sitting in front of one HUGE system, made up of a 7 computers with 12 monitors in front of me - I have 100 desktops and I switch to any of them instantly with a 2 key-combo...
[21:28] <blippyp> I use my pvr - I put the hdmi cable from my xbox into my pvr - and then out of the pvr to my tv
[21:28] <blippyp> my best systems are used for large encoding jobs (but even they suck compared to todays standars) - my main system is my laptop
[21:28] <blippyp> but I control them all with one keyboard/mouse
[21:29] <blippyp> I usually have them all off though unless I'm doing serious work
[21:29] <blippyp> brb
[21:29] <latenite> ok :D
[21:43] <blippyp> sorry about that - I'm back now
[21:44] <blippyp> I also want to make tutorials as well as LP's (been a programmer since I was a littlin') so there's tons of tutorials I'd like to make as well, so I wanted my script to do more than just what I wanted for LP'ing...
[21:46] <blippyp> the LP's are mostly just for fun, and since I play the games anyways, there's no reason not to record them - But the tutorials are what I really want to do. With a little luck the LP's will just help bring people to my youtube page - I don't know exactly what tutorials I want to do, but there are tons of things I can do a tutorial on - Like ffmpeg for instance - I could make tons of videos on ffmpeg alone...
[21:48] <blippyp> manolo: you still around - had any luck yet?
[21:48] <manolo> nope, I'm just chilling for a while
[21:49] <manolo> but will continue
[21:49] <blippyp> breaks are important...  ;)
[21:49] <manolo> what I know for sure is that i need a swf or flv file inthe end
[21:49] <blippyp> in my tests the swf output has been the best so far...
[21:49] <manolo> dude you are so kind blippyp, thanks a lot for your help :)
[21:49] <blippyp> but I really want to produce mp4's....
[21:50] <blippyp> no biggy - I like helping... ;)
[21:50] <manolo> yup, the swf can be played directly by the browser
[21:50] <blippyp> hence the whole tutorial talk....  haha
[21:50] <manolo> :)
[21:50] <blippyp> yes - but everyone is moving away from swf
[21:50] <blippyp> mp4 is the way to go with html5 now
[21:50] <manolo> i'm kind of mmm used to debian/ubuntu systems but this is becoming reaaaally hard
[21:50] <blippyp> it will be the standard for everyone soon
[21:50] <manolo> I c
[21:51] <blippyp> most browsers support it now
[21:51] <manolo> I will do my best, any way I understand im not asking for something completely average xD
[21:51] <manolo> with the netcat and such
[21:51] <blippyp> no - I think your piping is working - I don't think that's your problem
[21:52] <Mavrik> hmm
[21:52] <manolo> what about the versions?
[21:52] <blippyp> it's converting your feed back into the desired codec that ffserver wants
[21:52] <Mavrik> manolo, what are you doing exactly?
[21:52] <Mavrik> live streaming video to browser?
[21:52] <manolo> i mean 2.2 in the local 0.8 in the remote
[21:52] <manolo> yup Mavrik, that's a part
[21:52] <manolo> I have 2 computers
[21:52] <blippyp> possibly that could be an issue - you're also using ffmpeg with LibAV - they're completely seperate
[21:52] <blippyp> but like I said - I can't get it working either
[21:53] <Mavrik> manolo, I'm just commenting because swf/flv is almost never a solution for a problem in 2014 :P
[21:53] <Mavrik> but I missed the start of the conversation.
[21:53] <manolo> hahahahhaha
[21:54] <manolo> Mavrik, this is the whole tale xD: 2 computers, lets say local and remote. Local have a webcam attached and is behind a firewall I cannot configure
[21:54] <Mavrik> manolo, does it have to be a browser on the other side?
[21:54] <manolo> remote is my server and I have full control over it, I want to netcat or whatever the webcam capture and serv it like web to the clients, so they only type a url and see
[21:54] <Mavrik> aha, ok
[21:54] <manolo> yup 100% necessary
[21:54] <Mavrik> manolo, you need a streaming server on the computer under your control
[21:55] <Mavrik> then just use MPEG2-TS or some other streamable format (not flv horror) to push stream to it over UDP
[21:55] <manolo> no problem with that
[21:55] <manolo> avserver so far
[21:55] <manolo> hahahaha flv horror, I'm such a noob xD
[21:55] <Mavrik> flv isn't a format well built for streaming :)
[21:55] <blippyp> he was pushing it out in mpeg2-ts format though
[21:56] <Mavrik> we usually used Wowza as a streaming server (because it can server video to pretty much anything)
[21:56] <Mavrik> and just ffmpeg on the cam side
[21:56] <manolo> that sounds cool, just guide/point me to what you think can help me
[21:56] <blippyp> manolo - show your commands/process again - maybe mavrik can point out some issues
[21:56] <manolo> fair point that one, this is what i have so far:
[21:57] <Mavrik> but Wowza can cost alot, I've used stream-m for webm streaming (works only in chrome / firefox)
[21:57] <klaxa> i feel like i would be giving up freedom if i used wowza
[21:57] <Mavrik> huh.
[21:57] <Mavrik> dunno :)
[21:57] <klaxa> it's closed source, no?
[21:57] <Mavrik> it was by far the best piece of streaming software I've deployed
[21:57] <klaxa> and also costs on an instance basis
[21:57] <manolo> local comp: ffmpeg -f alsa -i plughw:CARD=Intel,DEV=0 -f video4linux2 -s vga -i /dev/video0 -f mpegts pipe:1 | sudo netcat ipaddr 110
[21:57] <Mavrik> rather cheap too considering the compatitors.
[21:57] <Mavrik> klaxa, well, streaming video business isn't really the flag carrier of OSS>
[21:58] <klaxa> yeah sadly
[21:58] <Mavrik> manolo, ugh... why :D
[21:58] <manolo> I dont know :_(
[21:58] <Mavrik> manolo, ffmpeg ... -f mpegts udp://<machine address>
[21:58] <Mavrik> manolo, ffmpeg ... -f mpegts udp://<machine address>:<port>
[21:58] <Mavrik> actually.
[21:58] <manolo> I c
[21:58] <Mavrik> and then on the other side just
[21:58] <manolo> and then in the remote comp?
[21:58] <Mavrik> ffmpeg -i udp://<local>
[21:59] <Mavrik> manolo, or if you're using ffserver or whatnot
[21:59] <Mavrik> it's remote by design
[21:59] <manolo> Mavrik, let's give it a try, ok?
[21:59] <manolo> what port do I have to open in the remote comp?
[21:59] <Mavrik> the one you're streaming on.
[21:59] <manolo> whatever I chose
[21:59] <manolo> cool
[22:00] <Mavrik> it's just a sequece of udp packets
[22:00] <manolo> udp is smart in this case
[22:00] <Mavrik> you can just use ffplay udp://<localaddress>:<port> to test if you're getting traffic through
[22:00] <manolo> I can only access via ssh the remote comp so I can ssh -X and then ffplay?
[22:02] <Mavrik> I doubt that will work for accelerated renderer.
[22:02] <Mavrik> you can just try a simple dump to disk
[22:02] <manolo> :S
[22:02] <manolo> but i can redirect to a file in the server
[22:02] <Mavrik> ffmpeg -i udp://<local>:<port> -codec copy out.ts
[22:02] <manolo> save it and scp it to check
[22:03] <Mavrik> also
[22:03] <manolo> ok, excuse my noobness xD
[22:03] <Mavrik> you're not specifying the encoder on your source machine
[22:03] <manolo> lets go first with the local-capturing
[22:03] <Mavrik> neither are you specifying the audio format
[22:03] <Mavrik> or quality.
[22:03] <manolo> nice nice I need that all
[22:04] <manolo> ffmpeg -f alsa -i plughw:CARD=Intel,DEV=0 -f video4linux2 -s vga -i /dev/video0 -f mpegts udp://<machine address>:<port>
[22:04] <manolo> let's start making it work and then we fine tune the quality, coding, compresion, etc, ok?
[22:04] <manolo> or if u think we can do all in one go, lets go for it
[22:04] <Mavrik> well
[22:04] <Mavrik> I'm gonna go have dinner now.
[22:05] <manolo> no hurries, I can wait
[22:05] <Mavrik> docs are your firends ;)
[22:06] <blippyp> that works manolo
[22:06] <manolo> cool
[22:06] <manolo> let's do it
[22:06] <blippyp> i used avi in the ffserver.conf
[22:06] <blippyp> like we discussed before
[22:06] <blippyp> then I used the exact command you had above (only I used plughw:0 only)
[22:06] <blippyp> ran ffplay like mavrik said and it connected
[22:07] <blippyp> looks like shit (due to encoding) but it works
[22:07] <manolo> avserver.conf and ffserver.conf remains kind of a mistery for me xD
[22:08] <blippyp> me to, but it's not that complicated
[22:08] <manolo> I have no idea of video formats and such
[22:08] <blippyp> that page I linked you to earlier seemed to have all the formats one could want
[22:08] <manolo> what I'm taking out of my webcam is raw video, is that it?
[22:08] <blippyp> I'm gonna try to get it working with mp4
[22:08] <manolo> nice move
[22:08] <manolo> I'll go for mp4 too
[22:08] <Mavrik> hmm, I think I wrote a blog post on that theme once
[22:08] <Mavrik> https://www.virag.si/2012/11/streaming-live-webm-video-with-ffmpeg/
[22:09] <Mavrik> there.
[22:09] <Mavrik> now bbl
[22:09] <blippyp> thanks mavrik
[22:09] <manolo> thanks a lit Mavrik
[22:10] <manolo> lit == lot xD
[22:10] <manolo> c'mon let's do this
[22:12] <manolo> blippyp, do you know about the ACL allow thing? should I stat to let everyone read?
[22:12] <manolo> state*
[22:15] <blippyp> if you want to allow anyone I think you use: ACL ALLOW
[22:15] <manolo> ok
[22:25] <blippyp> I can only get ffplay to connect - not mplayer
[22:26] <manolo> im strugling against the udp settings
[22:27] <blippyp> yeah me too - it works great with ffplay - but I can't figure out how to connect to it otherwise
[22:27] <blippyp> I'm gonna try out his webm example
[22:27] <manolo> how do you do it with ffplay?
[22:28] <blippyp> just like he said
[22:28] <blippyp> ffplay udp://localhost:8090
[22:28] <blippyp> but you can't specify a filename of any kind
[22:28] <manolo> i'll try local
[22:28] <blippyp> running mplayer with the same options crashes mplayer
[22:28] <blippyp> just change localhost to the ip of your server
[22:28] <blippyp> it's sending the feed there
[22:29] <manolo> yup in local if works PERFECT
[22:30] <manolo> well
[22:30] <manolo> audio and video are mmm
[22:30] <manolo> not synched
[22:32] <moskiteau> hello
[22:32] <blippyp> no - it will trail behind a bit - it's not technically 'real-time' - or do you mean the audio/video are out of sync?
[22:32] <manolo> out of sync by 20 segs not less
[22:33] <moskiteau> i am trying to demux an mp4 and i want to preserve the progressive download, anyone know how i can do so?
[22:33] <blippyp> moskiteau: explain a little more please
[22:33] <moskiteau> avconv -i input.mp4 -map 0:2 -c:v copy -movflags faststart video.m4v  -map 0:3 -c:a copy audio.m4a
[22:34] <moskiteau> i read that the -movflags faststart optimise the mp4 so the 'moov' atom is well ordered (not sure if i say it right)
[22:34] <ValdikSS> moskiteau: it's moved to the beginning of the file with faststart. Without faststart it's in the end.
[22:35] <ValdikSS> So that's what you need
[22:35] <moskiteau> ok, i tought so, but i have an error :(
[22:35] <moskiteau> Could not write header for output file #0 (incorrect codec parameters ?)
[22:39] <ValdikSS> moskiteau: It's libav issue, not ffmpeg, i suppose
[22:39] <ValdikSS> ffmpeg -i railgun.mkv -map v -c:v copy -movflags faststart video.m4v -map a -c:a copy audio.m4a
[22:39] <ValdikSS> worked fine here with ffmpeg 2.2.1
[22:42] <moskiteau> ffmpeg version 0.8.10-4:0.8.10-0ubuntu0.12.04.1, Copyright (c) 2000-2013 the Libav developers
[22:42] <moskiteau> lol, i guess the ubuntu package is out of date :/
[22:42] <blippyp> horribly - you can download a static ffmpeg from the ffmpeg site - I'd use that
[22:52] <blippyp> manolo: the webm seems to be working - but all I get is a still image and mplayer complains about the cache not filling...
[22:52] <manolo> I only got it working in local
[22:52] <moskiteau> wich one? the builds have date, not version numbers :P
[22:52] <moskiteau> http://ffmpeg.gusari.org/static/64bit/
[22:53] <moskiteau> nvm i found
[22:56] <moskiteau> working!
[22:56] <moskiteau> thanks guys
[23:21] <blippyp> manolo: according to the ffserver man page, streaming mpg and avi formats are out since it tries to send the whole file first...  which basically leaves webm...  :( or flash... webm would probably be better
[23:21] <manolo> I'm working with webm
[23:21] <blippyp> yeah me to - but not having any luck
[23:21] <manolo> this thing have an embeeded player :O
[23:21] <manolo> i'm on my way
[23:21] <blippyp> what thing?
[23:22] <blippyp> your web browser?
[23:23] <manolo> the webm
[23:23] <manolo> i almost got it
[23:23] <manolo> [mp2 @ 0x65c5e0] Header missing
[23:23] <manolo> I get some of this
[23:23] <blippyp> webm is a format I am fairly knowledgable about - but this thing just isn't working for me - some how I got it to display a single image, but it was 'frozen' - and my feed seems to stutter and freeze a lot regardless - there were a few times I got it to send a steady stream of frames, but it wouldn't play them giving me cache error issues
[23:24] <blippyp> I'm guessing you commented out the header line in the ffm - re-enable it....???? I couldn't get it to work without that line - no idea what it does though
[23:25] <manolo> mm where? in the avserver?
[23:25] <blippyp> ya
[23:25] <manolo> lemme
[23:25] <blippyp> in the AVOptionAudio (or Video) flags +global_header
[23:25] <blippyp> in the AVOptionAudio (and Video) flags +global_header
[23:26] <blippyp> there are two of them
[23:26] <manolo> mmm
[23:26] <blippyp> I had to disable the StartSendOnKey though or my frames just stutter and stop
[23:26] <manolo> :S
[23:26] <manolo> https://www.virag.si/2012/11/streaming-live-webm-video-with-ffmpeg/
[23:26] <blippyp> at least on my ffmpeg command - the video makes no difference, it either gives me cahce errors or shows one frame only
[23:26] <manolo> i'm using this guy's avserver.conf
[23:27] <blippyp> looking
[23:27] <manolo> copy and paste 99% xD
[23:27] <blippyp> I was using mavrik's
[23:28] <blippyp> oh - that's the same one
[23:28] <manolo> yup
[23:28] <manolo> I think i have to add something in the remote server
[23:28] <manolo> in the command i run in the remote server
[23:29] <manolo> local: sudo ffmpeg -f video4linux2 -s 640x480 -r 25 -i /dev/video0 -f alsa -i plughw:CARD=Intel,DEV=0 -f mpegts udp://
[23:29] <manolo> udp://...:port u know
[23:29] <manolo> then in the remote:
[23:29] <blippyp> don't use the udp
[23:29] <manolo> ?
[23:29] <blippyp> send it to the server or there's no file to connect to
[23:29] <blippyp> I don't get it either
[23:29] <blippyp> I can only get ffplay to connect when using udp
[23:30] <manolo> :S
[23:30] <blippyp> which means it's useless unless we figure out why
[23:30] <blippyp> I know that udp is what we want
[23:30] <manolo> sudo avconv -i udp://localhost:110 -s 640x480 -r 25 http://localhost:8080/feed1.ffm
[23:30] <manolo> in the remote
[23:30] <blippyp> but not sure how to get it working (it may be happening automatically for us with the server)
[23:31] <blippyp> ok
[23:31] <blippyp> hold on
[23:31] <manolo> cool cool no hurries
[23:31] <blippyp> oh yeah - since I'm completely local - I don't need that I don't think
[23:32] <blippyp> that saves you from having to pipe it I think
[23:32] <blippyp> it's not doing anything for me
[23:32] <blippyp> why is this so damn hard?
[23:32] <blippyp> it seems simple, but just doesn't want to work
[23:33] <manolo> hahaahah
[23:33] <manolo> 48 hours with this
[23:33] <manolo> i'm begining to feel retarded
[23:33] <blippyp> you and me both
[23:34] <manolo> pff
[23:34] <manolo> this is becoming someting personal
[23:34] <blippyp> I've actually stopped and started reading the ffserver man page because I never have - I feel I'm missing something stupid and obvious
[23:34] <manolo> I have to make 4 days of research before i can send a video file my god....
[23:34] <blippyp> for me too - and I have NO USE for it... haha
[23:34] <manolo> :_(
[23:34] <blippyp> I can get it working with swf - but I want webm now
[23:34] <manolo> that's it
[23:34] <blippyp> oh and mjpeg to - but that kind of sucks tbh
[23:35] <blippyp> but if I wanted to pipe it like you're doing - I'm screwed either way - so I still want to figure it out
[23:35] <manolo> do they give you scholarships for studing ffmpeg?
[23:35] <manolo> xDD
[23:35] <blippyp> haha
[23:36] <blippyp> nope - just BIG headaches  :P
[23:36] <manolo> how the change headaches to euro?
[23:36] <manolo> hahahaha
[23:36] <blippyp> but good rewards if you get it working...
[23:36] <blippyp> haha
[23:37] <manolo> I'll wait for Mavrik, maybe he can help me a lil after his diner
[23:37] <manolo> xD
[23:38] <blippyp> sometimes I get a codec bitrates do not match for stream 1 when running ffserver - not sure why
[23:38] <blippyp> but I finally figured out what the pre-roll option is though - you definitely want to keep that
[23:39] <blippyp> oh - think that solved my codec bitrates do not match issue
[23:41] <manolo> how?
[23:41] <manolo> xD
[23:41] <blippyp> don't know - I re-enabled it and the error disappeared....
[23:41] <blippyp> ;)
[23:41] <blippyp> it's your buffer - you might want to change it from 15 to something else, but you want definitely want it I think
[23:43] <manolo> what I like the most
[23:43] <manolo> is that you google something, and find a nice command, u put it on your term and it NEVER works ahahahaha
[23:43] <manolo> im losing my mind
[23:44] <blippyp> haha
[23:44] <blippyp> yup ain't it a blast
[23:47] <manolo> hahaahhha
[23:47] <blippyp> okay - switching my output from http://.....feed1.ffm to udp://....feed1.ffm definitely made that better
[23:47] <manolo> but I'm getting near
[23:47] <manolo> cool
[23:47] <manolo> i do like this in the remote comp
[23:47] <blippyp> but I'm still not getting the file when I play it - keep getting that damn cache issue
[23:47] <manolo> sudo avconv -i udp://localhost:110 http://localhost:8080/feed1.ffm
[23:48] <blippyp> try chaing your http:// to udp://
[23:48] <blippyp> chaing=changing
[23:48] <blippyp> it worked for me
[23:48] <manolo> in the remote too?
[23:48] <blippyp> yeah
[23:48] <manolo> i mean i want to acces by http://whatever:8080/test.webm
[23:49] <blippyp> yeah - it still gets served there
[23:49] <blippyp> at least it's showing it on my status page
[23:49] <manolo> status page is cool xD
[23:49] <manolo> looks like something work
[23:50] <manolo> http://whatever:8080/test.webm does not work
[23:50] <manolo> shows a nice player, but runs nothing
[23:50] <manolo> :(
[23:51] <blippyp> that's what happens to me too with luakit - that's why I use mplayer instead (which is what I prefer anyways)
[23:52] <manolo> what's luakit?
[23:53] <blippyp> my browser
[23:54] <blippyp> ff is a bloated beast - and with luakit I feel so much more secure since I have all plugins and stuff always disabled, but can instantly enable them per domain as I please and it remembers which ones I trust and don't trust...
[23:55] <ibisr> Hi all, when using the FFMPEG libraries to decode media, is there a simple way to determine whether the encoded media will have p or b frames?
[23:55] <blippyp> I've never seen any other browser do that - you either enable or disable them all
[23:56] <blippyp> ibisr: I don't know - you might need something else for that.... someone else might know. I've only seen options for that with other software (don't remember which ones)
[23:58] <ibisr> blippyp: thanks, I think I can handle it a different way, just wanted to make sure I wasn't being too dumb
[23:58] <manolo> first time I hear about that browser
[23:59] <blippyp> yeah, it's not common - and I think he stopped working on it - but I've been in love with it ever since I found it a few years ago
[23:59] <blippyp> it's not perfect - but I like it
[23:59] <blippyp> took some getting use to (uses a lot of vim-like key-bindings
[00:00] --- Fri May  2 2014

More information about the Ffmpeg-devel-irc mailing list