[Ffmpeg-devel-irc] ffmpeg-devel.log.20140522

burek burek021 at gmail.com
Fri May 23 02:05:02 CEST 2014

[01:59] <cone-362> ffmpeg.git 03Dale Curtis 07master:d5d6b8e25979: Fix compilation error around struct visibility when VDPAU disabled.
[01:59] <cone-362> ffmpeg.git 03Michael Niedermayer 07master:f932e5f71692: avcodec/vdpau_internal: move "struct vdpau_picture_context" up to avoid "#else"
[03:14] <kierank> http://embed.cs.utah.edu/creduce/
[03:16] <alpa_astero> kierank: http://alpaastero.wordpress.com/2014/05/19/tracking-down-a-bug-in-clang-fsanitizeundefined-is-not-bug-free/ :D
[03:17] <kierank> ah
[03:17] <kierank> :)
[03:17] <alpa_astero> (if you found it via hacker news, the post is by a guy who is a fellow Hacker School alum, who learned about it from my blog post) ^-^
[03:18] <alpa_astero> it's a good tool :)
[03:20] <alpa_astero> (here's Michael's patch to work around the clang bug - http://git.videolan.org/?p=ffmpeg.git;a=commit;h=bebce653e5601ceafa004db0eb6b2c7d4d16f0c0 - he did it within a few hours of my opening the bug report on the Libav bugtracker) :-)
[14:20] <nevcairiel> Daemon404: gcc 4.8.3 is out
[14:21] <Daemon404> \o/
[14:40] <Daemon404> nevcairiel, now gcc 4.9.1 where
[14:41] <Daemon404> eta N months
[14:48] <Case> nevcairiel: have you made a mingw set with that?
[14:49] <nevcairiel> i'm working on it
[14:50] <Daemon404> im making mine right now :P
[14:50] <nevcairiel> i finished compiling, just need to pack it up with zlib and upload it
[14:50] <Daemon404> nevcairiel, mingw is rather annoying for c++ right now...
[14:51] <Daemon404> there is a hard dep on winpthreads (bleck) if you want c++11 threads
[14:51] <Daemon404> kind of annoying
[14:51] <Daemon404> mind you, you may as well just use msvc for c++
[14:51] <Daemon404> ;)
[14:51] <nevcairiel> yeah i dont enable threads in gcc because of that nonsense
[14:52] <Daemon404> winpthreads is really bad still
[14:52] <Daemon404> lots of failed compiles, deadlocks, terrible perf
[14:52] <Daemon404> i wonder why they didntj ust import pthreads-win32
[14:53] <nevcairiel> NIH?
[14:53] <Daemon404> i guess so
[14:53] <nevcairiel> i switched back to building ffmpeg with win32threads anyway
[14:53] <Daemon404> why would you ever use pthreads on windows
[14:53] <nevcairiel> pthreads-w32 has a handle leak if you mix it with native windows threads
[14:53] <Daemon404> for ffmpeg anyway
[14:54] <nevcairiel> mostly because of some thing in the udp receiving code that caused packet loss without the worker thread, which only worked with pthreads
[14:54] <nevcairiel> but i hacked it together to work with win32threads now
[14:54] <Daemon404> is it submit-able?
[14:54] <Daemon404> also, gross.
[14:54] <nevcairiel> probably not
[14:55] <Daemon404> :/
[14:55] <nevcairiel> i mean, it works fine, since closing a socket on windows makes all blocking calls in other threads return immediately
[14:55] <nevcairiel> (which is what pthread_cancel does on *nix)
[14:55] <nevcairiel> http://git.1f0.de/gitweb?p=ffmpeg.git;a=commitdiff;h=b7c9992477d9d48dd211c7d1d2adc0f35dc3b6d4;js=1
[14:55] <nevcairiel> i just hacked it in :P
[14:56] <nevcairiel> (also, the API for pthread_cond_timedwait is just horrible)
[14:56] <Daemon404> thats not *that* bad
[14:56] <nevcairiel> why not just an api that says "wait 100 ms", noo, it has to be an API that takes a silly timespec with an absolute time
[14:57] <Daemon404> i was going to say "holy shit thats a lot of hacks" to your repo
[14:57] <Daemon404> but like 50% of them are haali
[14:57] <nevcairiel> well there is two other patches in the w32threads header to add the new function and add a few return values
[14:57] <nevcairiel> but yeah
[14:57] <nevcairiel> it felt kinda ugly
[14:57] <nevcairiel> but i tested it to work reliably at least
[14:58] <nevcairiel> (important to note, pthread_cancel in pthreads-w32 is pretty much a NOP)
[14:58] <nevcairiel> (i checked)
[14:58] <Daemon404> there are still a bunch of things you could submit i see
[14:58] <Daemon404> http://git.1f0.de/gitweb?p=ffmpeg.git;a=commit;h=f819cef397b46212bc8b2fbcc33b08dd61d232e0;js=1
[14:58] <Daemon404> this looks useful actually
[14:58] <Daemon404> i hit that a lot with user content
[14:59] <iive> nevcairiel: are you talking about classic mingw, or mingw64 ?
[14:59] <Daemon404> iive, mingw64
[14:59] <nevcairiel> classic mingw is dead
[14:59] <Daemon404> yea ^
[14:59] <iive> ok. so one problem less.
[15:00] <ubitux> could we get the github pull requests automatically forwarded to ffmpeg-devel?
[15:00] <Daemon404> should be easy enough with the github API
[15:00] <Daemon404> but i really think we ought to just autoreply with "send to the ML"
[15:00] <Daemon404> people who dont even take the time to figure out how to submit it to us... i question how goood their patches are
[15:00] <Daemon404> :P
[15:01] <ubitux> well for occasionnal patches, they might not want to mess with mailing-list
[15:01] <ubitux> typically this: https://github.com/FFmpeg/FFmpeg/pull/70
[15:02] <Daemon404> right
[15:02] <Daemon404> well such a script would be only a few lines of code + cron job
[15:03] <J_Darnley> Is it hard to say in your opening email "please CC me"?
[15:03] <Daemon404> J_Darnley, then you run into ML moderation
[15:03] <Daemon404> mind you, you can also use gmane
[15:03] <Daemon404> if you dont want to subscribe
[15:04] <J_Darnley> I think that's even worse that github's features
[15:04] <Daemon404> gmane is horrible
[15:04] <Daemon404> but also the best thing for what it does available
[15:04] <Daemon404> life sucks, etc
[15:07] <J_Darnley> I wonder if that's why some of my emails to other places have just disappeared.
[15:08] <Daemon404> nevcairiel, wtf is with gcc's mirrors
[15:08] <Daemon404> 4.8.3 isnt on any of them
[15:08] <nevcairiel> Daemon404: dunno, i got i t
[15:08] <Daemon404> which mirror
[15:08] <Daemon404> i tried 3 so far
[15:08] <nevcairiel> http://ftp.gnu.org/gnu/gcc/
[15:08] <Daemon404> ohlol
[15:08] <Daemon404> i was using the local mirror
[15:09] <Daemon404> as in closest
[15:09] <Daemon404> i guess nothing rsync'd it yet
[15:15] <nevcairiel> Case: http://files.1f0.de/mingw/mingw-w64-gcc-4.8.3-stable-r11.7z
[15:16] <Case> nice, thanks
[15:17] <Case> I wish they hurried up with fixed 4.9 release. It seems to have some nice performance improvements for compiled binaries
[15:19] <cone-833> ffmpeg.git 03Michael Niedermayer 07master:e8e9186a70ae: avcodec/pgssubdec: Use av_malloc(z)_array()
[15:19] <cone-833> ffmpeg.git 03Michael Niedermayer 07master:aca48725afe8: avcodec/proresdec2: Use av_malloc_array()
[15:19] <cone-833> ffmpeg.git 03Michael Niedermayer 07master:124c94a1c8de: avdevice/v4l2: Use av_malloc_array()
[15:23] <nevcairiel> updated my fate box as well, hopefully nothing breaks ;)
[15:32] <Daemon404> ;p
[15:32] <cone-833> ffmpeg.git 03Carl Eugen Hoyos 07master:eff913c9725b: Autodetect Asterisk raw pcm with extension "sln".
[15:32] <cone-833> ffmpeg.git 03Michael Niedermayer 07master:a996eacce269: Merge remote-tracking branch 'cehoyos/master'
[17:15] <Daemon404> oh nevcairiel 
[17:16] <nevcairiel> ?
[17:16] <Daemon404> https://github.com/FFMS/ffms2/commit/ead726b7964edaf7dc725c68c41ce00a82eb3d27
[17:16] <Daemon404> relevant to your haali code?
[17:16] <nevcairiel> I have a similar hack somewhere
[17:17] <nevcairiel> After a ass script with 1mb privates crashed
[17:17] <Daemon404> yea
[17:17] <Daemon404> same
[17:17] <Daemon404> it was for a .ass
[17:17] <nevcairiel> Silly alloca everywhere
[17:17] <Daemon404> yep
[17:18] <Plorkyeran_> probably should lower the limit for alloc to like 1KB
[17:19] <Plorkyeran_> since codecprivate sections seem to usually be more like 10 bytes
[17:19] <nevcairiel> http://git.1f0.de/gitweb?p=ffmpeg.git;a=commitdiff;h=f570ac731b90e12664b9617dd9b890915a5cbdb8;js=1
[17:19] <nevcairiel> Mine seems longer
[17:20] <nevcairiel> More error free
[17:20] <nevcairiel> I don't use alloca at all anymore for CP
[17:21] <j-b> (ASS files with > 1MB CodecPrivate) o_O
[17:22] <Plorkyeran_> fansubbers do dumb things
[17:22] <Plorkyeran_> the only reason I fixed it was because it was stopping you from opening the video track
[17:23] <nevcairiel> I should've looked into what was actually in that codec private block
[17:23] <Plorkyeran_> commented lines
[17:23] <nevcairiel> Can you have 1mb format rules?
[17:24] <Daemon404> if you hit such a stupid file, still better to fail than crash
[17:24] <Daemon404> as was the previous behavior
[17:24] <nevcairiel> It just crashed because the 2mb limit in the code was already too large
[17:25] <nevcairiel> At least on windows default stack is 1mb
[19:04] <cone-833> ffmpeg.git 03Vignesh Venkatasubramanian 07master:37cef8c77449: libavformat/matroskaenc: Add WebM DASH support
[20:16] <cone-833> ffmpeg.git 03Vignesh Venkatasubramanian 07master:bda8ceb9f8d9: maintainers: adding myself as a maintainer to webm dash
[21:39] <cone-833> ffmpeg.git 03Christophe Gisquet 07master:f8de35ebc4f2: x86: hpeldsp: kill hpeldsp_mmx.c
[21:39] <cone-833> ffmpeg.git 03Christophe Gisquet 07master:17ac9980555a: x86: hpeldsp: mark _xy2 versions as approximate
[21:39] <cone-833> ffmpeg.git 03Christophe Gisquet 07master:c081ca851c9b: x86: hpeldsp: avg_pixels_xy2 for mmx2&3dnow
[21:44] <kurosu> woah that went smoother than expected
[23:40] <cone-833> ffmpeg.git 03Florent Le Coz 07master:fdcb2873e1c8: Fix the mime types for MPEG and MPEG-TS formats
[23:59] <kurosu> jamrial, I have SSSE3 versions of _xy2 that should cause less yawns
[23:59] <kurosu> currently finetuning the loading of constants
[00:00] --- Fri May 23 2014

More information about the Ffmpeg-devel-irc mailing list