[Ffmpeg-devel-irc] ffmpeg.log.20140523

burek burek021 at gmail.com
Sat May 24 02:05:01 CEST 2014

[00:53] <temhawk> how do i prevent the black screen when i cut a video with -codec copy? i need to cut at a keyframe, right? how do i find out what frames are keyframes if my framerate is 29.97002?
[01:14] <c_14> It should cut by the nearest keyframe automatically.
[01:18] <temhawk> c_14: i think it does but there is no video for a moment when i then play it in VLC
[01:22] <temhawk> http://pastie.org/9200663
[01:24] <c_14> How long is the black/does the timestamp advance while the screen is black?
[01:26] <temhawk> between 3-4 seconds
[01:26] Action: debianuser "solved" the problem with file not detected as 3D - that's a player bug, after RENAMING files around several times all the same files were detected as 3d video.
[01:27] <c_14> And the timestamp advances? cc temhawk
[01:29] <temhawk> c_14: i don't know what you mean
[01:31] <c_14> vlc should tell you at which point in the video you are while playing, are the first three seconds of video literally black or is vlc just showing a black screen for three seconds and then playing
[01:32] <temhawk> c_14: ahh. it's not black in vlc. only in quicktime. in vlc it just shows the playlist until it starts after 3-4 seconds. the thingy moves during that time in both VLC and quicktime
[01:33] <c_14> thingy? progress bar?
[01:34] <temhawk> ye
[01:36] <temhawk> i have a gif maker app and when i open the video in it i can jump by frames and when i click "jump to next frame" it goes immediately to where the video starts between 3-4 seconds
[01:36] <temhawk> there is audio the whole time btw
[01:37] <c_14> Is ffmpeg seeking correctly? ie does the sound start where it's supposed to or does the video start where it's supposed to
[01:38] <temhawk> the video starts where it's supposed after 3-4 seconds (i.e. 4 seconds in compared to the original footage) and the audio is sync'd
[01:39] <temhawk> it almost seems like the audio was just not cut but the video appears sooner than 4 seconds...
[01:40] <c_14> Can you try it again using the trim and atrim filters instead of -ss and -t ?
[01:40] <c_14> -vf 'trim=4:19,atrim=4:19' should do it
[01:42] <temhawk> i'm using streamcopy
[01:42] <c_14> right, i forgot ehhh
[01:42] <temhawk> it says i can't use that with streamcopy
[01:43] <c_14> can you try using -ss as an input option?
[01:46] <temhawk> c_14: yeah, that works! except now the video is 19 seconds and the last 4 seconds is nothing!
[01:47] <c_14> adjust -t down by 4 seconds
[01:48] <temhawk> now it's 15 seconds but the last 4 seconds are still gone!
[01:48] <c_14> whaaaa
[01:49] <c_14> The last 4 seconds of audio are missing?
[01:49] <temhawk> both video and audio
[01:49] <temhawk> there's just a still frame
[01:49] <c_14> and with -t 19 the last 4 seconds were empty?
[01:50] <temhawk> no, -t 15 was 19 seconds, then i tried -t 11 after you said to reduce it by 4
[01:50] <temhawk> and both have the same problem at the end
[01:51] <c_14> you want everything from second 4 to second 19 in the original video?
[01:51] <temhawk> yes
[01:51] <temhawk> the framerate is 29.97002
[01:52] <c_14> The video stays at a frame but the audio progresses?
[01:52] <temhawk> no, no audio
[01:52] <c_14> How long is the original video?
[01:53] <temhawk> 38s
[01:54] <c_14> try using -to 15 and if that doesn't work -to 14 and then -to 13, I'm guessing it might be cutting at vframes somewhere and then just lengthening the video
[01:58] <temhawk> c_14: the same problem in all cases. last 4 seconds is no video or audio. -to 15 gives me a 19s video, -to 14 gives me an 18s video, etc
[02:02] <c_14> So -to 15 gives you everything you want plus 4 seconds of nothing?
[02:04] <temhawk> c_14: yeah!
[02:04] <temhawk> c_14: it gives me a little bit extra, actually
[02:04] <c_14> I'd probably blame that on the stream copying, the blank seconds are still bothering me a bit though.
[02:10] <temhawk> c_14: so i tried trimming the last 4 seconds off with another ffmpeg command and& mhmmmm& now the video starts where the ORIGINAL video starts!
[02:10] <c_14> wait, what? sure you grabbed the right file?
[02:11] <temhawk> yeah, i'm positive...
[02:12] <c_14> I'm relatively certain deleted video shouldn't be coming back from the dead.
[02:12] <c_14> Your computer is scaring me. :P
[03:36] <BtbN> What's the current situation with libavresample vs. libswresample? Are those compatible?
[03:54] <fuff> Has anybody used JPEG2000 with FFMPEG?
[03:54] <fuff> I would like to try encoding lossy intra-frame video. Anything but classic JPEG would be good.
[04:09] <fuff> wow, libopenjpeg is slow as hell
[06:28] <help_me> Is there a lossy intra-frame codec I can use that is actually playable?
[06:33] <help_me> I tried libopenjpeg (jpeg2000) on HD video and it could not play back in real-time. I am having trouble finding documentation on this.
[07:03] <BtbN> help_me, what about h264?
[07:06] <help_me> I did not know that h264 did intra-frame, or that it did it well
[07:07] <help_me> I'm leaning towards JPEG2000 because digital cinema packages use it
[07:07] <help_me> trouble is I can't get it to play (or encode) very fast
[07:07] <help_me> I think I may have it on losslessmode or something but I don't know how to change it
[07:08] <help_me> I want to experiment, like I've been doing with lossless codecs, but there doesn't seem to be much information on lossy intra-frame compression with FFMPEG
[08:21] <help_me> OK so it's j2k that is lossy, nt libopenjpeg
[08:21] <help_me> http://sinclairmediatech.com/use-ffmpeg-to-encode-jpeg2000-270mbit/
[08:31] <help_me> wrong again, it's jpeg2000 (I wish they'd stop renaming things)
[09:12] <ericbutters> hello, how do i configure/build libasound?
[09:22] <help_me> ericbutters: I can't help you (never compiled an ffmpeg component before) and pretty much nobody is online right now so I'm just hangin out and waiting
[09:23] <help_me> I've been trying to get JPEG2000 t work but it looks like the encoders and decoders for it seriously suck
[09:23] <help_me> http://dcinemaforum.com/forum/index.php?topic=44.0
[09:24] <help_me> The FOSS people haven't cracked the JPEG2000 thing yet for real-time decoding
[09:24] <help_me> pretty sure you need special hardware for it
[09:25] <help_me> Motion JPEG seems to run pretty fast, but macroblocking is a nightmare
[09:26] <help_me> I'm going to try AVC-intra next, and maybe se if I can get JPEG XR to work
[09:26] <help_me> that's about all of the losy intra-frame codecs there are though, so if none of those are satisfactory then I will be very sad
[09:32] <help_me> there's also webp I suppose
[09:40] <help_me> fuck, webp is too new and was aded less than a week ago
[09:40] <help_me> unbelievable
[09:53] <relaxed> help_me: my builds have had webp support for a while, http://johnvansickle.com/ffmpeg/
[09:54] <tm512> does -rtbufsize need to be located anywhere special in the command line?
[09:54] <tm512> because I'm still getting stuttering in my video
[09:55] <tm512> trying to do x11grab
[09:58] <help_me> thanks, relaxed
[09:58] <relaxed> tm512: did you try before the input?
[09:58] <relaxed> tm512: what's your command?
[09:58] <help_me> I prefer to use the official builds, but I might give yours a try for testing purposes
[10:00] <help_me> I am on Windows though
[10:00] <tm512> http://hastebin.com/cozasodezu
[10:01] <tm512> it's always had this weird issue of having the video freeze for a bit and then resume
[10:02] <relaxed> tm512: does it happen when you encode lossy?
[10:02] <tm512> I'm not recording lossy
[10:02] <relaxed> no shit, that's why I asked.
[10:03] <tm512> sorry, I'm tired and didn't read correctly
[10:03] <relaxed> try -crf 20 just to test
[10:07] <tm512> doesn't look like it happens
[10:07] <tm512> I thought the initial problem was an I/O one
[10:07] <tm512> but figured that rtbufsize would allow it to catch up
[10:09] <relaxed> see if it happens with -c:v rawvideo -pix_fmt yuv420p
[10:09] <tm512> was I mistaken?
[10:09] <relaxed> all is fine with -crf 20?
[10:10] <tm512> I'm double checking
[10:13] <relaxed> -c:v ffvhuff is lossless and might be faster
[10:13] <tm512> looks like all is fine but that isn't completely conclusive
[10:13] <tm512> why did you have me try -crf 20?
[10:14] <relaxed> I figured it would be less intensive than lossless mode
[10:14] <tm512> for i/o?
[10:15] <relaxed> yes
[10:15] <tm512> is -rtbufsize useless then?
[10:15] <relaxed> I've never used it
[10:15] <tm512> doesn't it buffer the input to make a smoother output?
[10:15] <Keestu> hi, i am reading packets from rtsp server through av_read_frame (context, finished, packet). How can i copy this particular packet ?
[10:18] <tm512> relaxed: rawvideo lags a lot
[10:18] <relaxed> and ffvhuff?
[10:21] <tm512> lags
[10:21] <help_me> you can give utvideo a try except it's intra-only (I have no idea what you guys are talking about BTW)
[10:21] <tm512> I'm going to see if rtbufsize is an input specific option
[10:22] <tm512> and put it after -f x11grab
[10:22] <tm512> then I'm going to sleep
[10:22] <rsdrsdrsdrsd> I have a bunch of videos on which the dar is ok, but the sar is wrong. The sar should be set to 1, is there a tool how I can reset the sar of the video to 1 without transcoding?
[10:23] <rsdrsdrsdrsd> If i play the video, it is really stretched because of the sar. I need it to be 1
[10:24] <DelphiWorld> hey FFmpegsters
[10:25] <relaxed> rsdrsdrsdrsd: there should be a way using certain players. I believe you'll have to rencode to fix it.
[10:26] <DelphiWorld> hey relaxed :D
[10:27] <rsdrsdrsdrsd> isn't there an option to just change the metadata info of sar
[10:28] <tm512> relaxed: also it might be worth noting that I thought these problems were fixed but they came back after getting a mouse (well, trackball) that polls a minimum of 4 times as much as my old mouse
[10:28] <tm512> not sure if that has anything to do with it
[10:28] <DelphiWorld> anyone know how to add main profile?
[10:28] <tm512> but it makes X11 take up more CPU
[10:28] <DelphiWorld> this is my ffmpeg line: /usr/local/bin/ffmpeg -re -i udp://@ -c:v libx264 -vb 512k -c:a libfdk_aac -ar 44100 -ac 2 -ab 64k -f flv rtmp://;
[10:29] <relaxed> DelphiWorld: -profile main
[10:29] <DelphiWorld> relaxed: vprofile or profile?
[10:29] <relaxed> er, -profile:v main
[10:30] <DelphiWorld> thank relaxed
[10:30] <DelphiWorld> relaxed, do you recomand adding vb to video?
[10:30] <relaxed> setting the video bitrate?
[10:31] <DelphiWorld> yes
[10:31] <DelphiWorld> otherwise how is bitrate defined if i dont usevb?
[10:31] <relaxed> I think using -crf is best
[10:31] <DelphiWorld> relaxed: crf is specifying bitrate right?
[10:32] <relaxed> https://trac.ffmpeg.org/wiki/x264EncodingGuide
[10:33] <rsdrsdrsdrsd> crf is specifying a quality
[10:33] <rsdrsdrsdrsd> try a few and choose your quality you can also set a max rate
[10:34] <DelphiWorld> rsdrsdrsdrsd: thank, i want to be bandwidth aware
[10:35] <tm512> also I specifically ran X and ffmpeg on different CPU cores to see if that had any effect but the stutturing still happens
[10:35] <rsdrsdrsdrsd> anyone know how to set the reset sar info
[10:36] <DelphiWorld> relaxed: its normal to specify profile if using crf?
[10:36] <relaxed> there's the setsar filter, but it recuires encoding
[10:36] <relaxed> requires*
[10:37] <DelphiWorld> also i dont know what preset must i use for live encoding
[10:38] <DelphiWorld> this is not file but stream
[10:38] <rsdrsdrsdrsd> yeah but from what i read it also changes the frame size
[10:38] <tm512> minimal choppiness in this lossless x264 recording with rtbufsize set after -f x11grab
[10:38] <rsdrsdrsdrsd> ok renecoding isn't a problem
[10:38] <tm512> dunno if it's just a fluke
[10:38] <rsdrsdrsdrsd> I can do copy codec
[10:39] <DelphiWorld> guys?
[10:42] <help_me> hi DelphiWorld
[10:42] <DelphiWorld> hi help_me
[10:42] <help_me> I'm tired
[10:42] <DelphiWorld> help_me: lol
[10:42] <help_me> and somewhat horny
[10:43] <help_me> I've been trying out lossy intra-frame codecs
[10:43] <help_me> they all suck
[10:43] <DelphiWorld> i dont realy know what quality must i chouse for IPTV
[10:43] <help_me> well
[10:44] <help_me> are you broadcasting? details please
[10:44] <DelphiWorld> help_me: i am getting streams from satellite and pushing to rtmp & hls
[10:44] <help_me> oh cool
[10:44] <help_me> well, it's easy to squeeze that into net-streamable bandwidth with good quality
[10:44] <help_me> provided you have a fast enough encoder
[10:45] <help_me> depends on the codec
[10:45] <tm512> and it doesn't look like rtbufsize is used at all in x11grab :/
[10:45] <DelphiWorld> help_me: i have a 16cors Server
[10:45] <DelphiWorld> and want H.264/AAC
[10:45] <tm512> guess I have a new programming project for tomorrow
[10:45] <help_me> then no problemo
[10:45] <help_me> DelphiWorld: your quality is limited only by your bandwidth
[10:46] <DelphiWorld> help_me: bandwidth... 1GB :)
[10:46] <help_me> then your quality is unlimited
[10:46] <DelphiWorld> help_me: lol
[10:46] <help_me> what exactly is the problem?
[10:46] <DelphiWorld> help_me: but what encoding settings you recomand
[10:46] <DelphiWorld> help_me: problem is confusion that's all
[10:47] <help_me> depends on the resolution of the streams
[10:47] <help_me> what's the width and height?
[10:47] <DelphiWorld> help_me: lol, pm
[10:47] <help_me> pm?
[10:47] <help_me> oh I see ok
[10:47] <DelphiWorld> help_me: private message:P
[11:27] <help_me1> DelphiWorld: my IRC client glitched out
[11:30] <help_me> I am having a really rough night
[11:40] <DelphiWorld> back
[11:43] <DelphiWorld> how to add a subtitle to a mp4 stream?
[12:44] <shoikan> hi folks.. I've got a question about the -f tee option, to output to two separate things...
[12:45] <shoikan> I've found the doc about it on the web, but I haven't been able to get it to work properly
[12:46] <shoikan> I am trying to use a single multicast input, encode this to 5 different bitrates plus aac audio, then output it in ismv format to 2 separate ingests (http servers)..
[12:47] <shoikan> if I specify -f ismv and indicate a single http server, it works like a charm...
[12:48] <shoikan> but when I do -f tee "[f=ismv]http://server1/url1|[f=ismv]http://server2/url2" it doesn't seem to produce any output on neither mountpoint)
[12:58] <\\matthias> Hey there im running version 1.2.1 on my server and im trying to convert an avi2mp4 but im getting "x264 [error]: high profile doesn't support 4:4:4" - what did i miss? :o
[12:58] <\\matthias> and i think that setting is kinda essential for the mp4 to work in web
[13:02] <\\matthias> i just tried the same with the latest available version for Win.
[13:02] <\\matthias> [libx264 @ 0000000002b9fca0] Error setting profile high.
[13:02] <\\matthias> [libx264 @ 0000000002b9fca0] Possible profiles: baseline main high high10 high422 high444
[13:02] <\\matthias> still getting those errors :(
[13:02] <\\matthias> im trying ffmpeg -i input.avi -codec:v libx264 -profile:v high -preset slow -b:v 500k -maxrate 500k -bufsize 1000k -vf scale=-1:480 -threads 0 -codec:a libfdk_aac -b:a 128k output.mp4
[13:37] <\\matthias> noone alive eh ? :/
[13:46] <spaam> \\matthias: or people have no idea on how to fix it :(
[13:47] <spaam> \\matthias: have you tried adding -level 4.1 or 4.0 after -profile:v high ?
[13:53] <\\matthias> -level ... ill try that :) and will pastebin the output.. just a moment.
[13:57] <\\matthias> http://pastebin.de/125918
[13:58] <\\matthias> now that was with version 1.2.1
[14:00] <\\matthias> no luck with -level
[14:03] <\\matthias> cant be too hard to convert avi 2 mp4 .. in a way that it is still good quality and playin in a browser
[14:05] <\\matthias> i converted the video earlier .. but i must say that all those who got converted cant be launched in a brwoser. meh :( ^^
[14:11] <klaxa> >793x480
[14:12] <klaxa> h264 can only encode videos with width and height divisible by 2
[14:12] <klaxa> cc: \\matthias
[14:17] <\\matthias> oh
[14:18] <\\matthias> so i would have to turn that avi into something else / diff resolution and then like rerun it
[14:23] <klaxa> \\matthias, you can use a filter, like -vf "scale=792x480"
[14:27] Action: DelphiWorld love -map
[14:36] <DelphiWorld> can rtmp have multi audio stream?
[14:37] <\\matthias> yeay
[14:37] <\\matthias> its working :d
[14:37] <\\matthias> :D
[14:37] <DelphiWorld> how?
[14:37] <\\matthias> thanks guys :D
[14:37] <DelphiWorld> lol
[14:38] <\\matthias> ias klaxa said. ffmpeg was not able to divide
[14:38] <\\matthias> because [klaxa] >793x480
[14:39] <\\matthias> so i used the scale setting first to rescale it (avi 2 avi) xD pretty "senselesse" but anyway
[14:39] <\\matthias> so the video now is 792x480
[14:39] <\\matthias> and then i was able to run the avi 2 mp4 command successfully :D
[14:40] <\\matthias> sry for my crap english but i think u get what i mean xD
[14:43] <DelphiWorld> lol
[14:48] <\\matthias> klaxa yea i did. but only when im doing "avi 2 avi" first it doesnt work inline directly when u want to go from avi 2 mp4
[14:48] <\\matthias> what so funny over there :D
[14:48] <\\matthias> xD
[14:48] <klaxa> it should work
[14:49] <\\matthias> i have some :D
[14:49] <\\matthias> u want some? xD
[14:49] <\\matthias> lol
[14:49] <klaxa> it's read-input -> decode -> filter -> encode -> write-output
[14:49] <klaxa> so there should be no problem filtering right away
[14:50] <DelphiWorld> guys. will rtmp support multi language video?
[15:21] <DelphiWorld> how to include subtitles if using mp4?
[15:21] <DelphiWorld> i am encoding mpeg2ts into mp4
[15:54] <DelphiWorld> hi guys
[15:54] <DelphiWorld> i'm doing hls like this
[15:55] <DelphiWorld> ffmpeg -re -i udp://@ -c:v libx264 -c:a libfdk_aac -ac 1 -ar 44100 -f segment -segment_time 4 \ -segment_list euronews.m3u8 -segment_format mpegts stream%05d.ts
[15:55] <DelphiWorld> but its saying output file #0 dont have any  stream
[16:06] <DelphiWorld> hls... guys
[16:06] <Keestu> dear all, could someone help me on this issue ?   http://ffmpeg.org/pipermail/libav-user/2014-May/006841.html
[16:14] <DelphiWorld> relaxed: any clue?
[16:15] <DelphiWorld> hls is not working for me guys
[16:15] <DelphiWorld> ffmpeg -re -i udp://@ -pix_fmt yuv420p -vcodec libx264 -acodec libfdk_aac -r 25 -profile:v baseline -b:v 512k -maxrate 1500k -force_key_frames 50 -s 640×360 -flags -global_header -f segment -segment_list /tmp/hls/euronews.m3u8 -segment_time 10 -segment_format mpeg_ts -segment_list_type m3u8 /tmp/hls/segment%05d.ts
[16:15] <DelphiWorld> Output file #0 does not contain any stream
[16:26] <DelphiWorld> saste: are you available to help with hls?
[16:35] <DelphiWorld> ffmpeg -re -i udp://@ -map 0:0 -map 0:2 -map 0:8 -c:v libx264 -vb 512k -c:a libfdk_aac -profile:a aac_he_v2 -b:a 24k -ac 2 -ar 44100 -f flv rtmp://localhost:1935/live/eu/join #videolan
[16:35] <DelphiWorld> oh
[17:00] <DelphiWorld> anyone using crtmpserver?
[18:13] <SpecialEd> Hey guys, having troubles getting my Haswell based dedicated server to use all CPU cores with ffmpeg to transcode with the libx264 codec.
[18:13] <SpecialEd> I configured (and compiled) ffmpeg manually with the flags: --enable-pthreads --enable-zlib --disable-stripping --enable-runtime-cpudetect --enable-postproc --enable-swscale
[18:14] <SpecialEd> Also when I use ffmpeg I use the flag -threads 8. However
[18:14] <SpecialEd> I'm only seeing about 40% usage across all 8 cores
[18:14] <c_14> try getting rid of -threads 8 or increasing it
[18:15] <c_14> libx264 should thread automatically
[18:15] <SpecialEd> ok
[18:15] <SpecialEd> I have a small sampling of files set aside
[18:15] <SpecialEd> and im timing how long it takes to run
[18:15] <SpecialEd> which is always 96 seconds
[18:16] <SpecialEd> so Ill try that right now without --threads # and then --threads 0
[18:16] <SpecialEd> so ill be back in about 192 seconds or so :)
[18:21] <SpecialEd> Almost no difference with --threads 0 or without even using the --threads flag... :(
[18:21] <SpecialEd> however when I dropped --threads flag it did complete the job 2 seconds faster @ 94 seconds
[18:21] <SpecialEd> sure thing, brb
[18:25] <SpecialEd> http://pastebin.com/5Uk9Zchw
[18:26] <SpecialEd> crap, I guess I posted my script, but its just the ffmpeg command wraped in a for loop for each file
[18:26] <SpecialEd> so its not like you'll need to decipher whats doin
[18:28] <SpecialEd> Also, I'm not sure if its related but I am also seeing the terminal getting spammed by ffmpeg with the following:
[18:28] <SpecialEd> [h264 @ 0x3b21620] missing picture in access unit with size 40
[18:28] <SpecialEd> [h264 @ 0x3b21620] AVC: nal size 21102622
[18:29] <SpecialEd> The videos still play fine so I just normally have --loglevel quiet set
[18:29] <c_14> hmm, I can't see anything about the command that would limit ffmpeg from using full cpu...
[18:30] <SpecialEd> yea, and I thought maybe it could be iowait but I checked the disk I/O and it was low
[18:30] <SpecialEd> this particular doesn't have SSDs, rather a RAID0 configuration of two 2TB disks
[18:31] <SpecialEd> well let me take a step back here then
[18:31] <c_14> I'm guessing the factor limiting the encoding speed isn't the x264 encoding, but rather the filter or something.
[18:31] <SpecialEd> I am running this on many files each day
[18:31] <SpecialEd> I could parallelize the script itself
[18:31] <SpecialEd> and that way I do see the CPU usage go up
[18:32] <SpecialEd> So overall, would it be faster if I were to parallelize the script 3x or would it be faster to get just 1 instance of it to use more CPU by itself?
[18:32] <SpecialEd> Does my question make sense?
[18:33] <c_14> In this case, I think it would be better to make the script run in parallel.
[18:33] <SpecialEd> ok
[18:34] <SpecialEd> What would be faster overall if lets say I had 10,000 videos to transcode to x264:
[18:34] <SpecialEd> 1. 3 parallel processes of ffmpeg running down a list of the files
[18:34] <SpecialEd> 2. 30 parallel processes of ffmpeg running down a list of the files
[18:35] <l0rd_hex> if I've already encoded a video with "ffmpeg -i input -t 20 -c:v libx264 -tune grain -preset veryslow -crf 16 -movflags +faststart output.mp4" and I want to adjust the crf value (higher) do I need to pass -tune and -preset again?
[18:35] <SpecialEd> Like, at any point does over parallelizing slow ffmpeg down? Obviously eventually you'll saturate the disk I/O which would be a bottleneck, but lets ignore that for the scope of the question.
[18:36] <c_14> SpecialEd: I would never increase the amount of cpu-dependent tasks over 1+numcpu, in this case I would probably go for 3 since that should fully saturate the cpu. Basically, use the smallest number that fully saturate the cpu.
[18:37] <c_14> l0rd_hex: you want to encode the output video again?
[18:37] <SpecialEd> OK, last question. Do you have any tips for any flags that I should try to help increase the transcode speed? Like should I try to specify -crf and -preset ?
[18:37] <c_14> l0rd_hex: it would probably be better to encode the input video again with a higher crf or else you'll introduce more loss
[18:38] <c_14> SpecialEd: if filesize doesn't matter, use -preset {faster,veryfast,ultrafast}
[18:38] <SpecialEd> ok ty
[18:38] <c_14> SpecialEd: -crf is mainly quality based and doesn't really influence encode speed
[18:38] <SpecialEd> gotcha, thanks
[18:39] <c_14> l0rd_hex: but, if you want to encode the output video again, yes I would pass tune and preset again
[19:06] <l0rd_hex> c_14: oops, stepped away
[19:06] <l0rd_hex> thanks, it's security cam footage so it actually looks the same crf 16 -> crf 20
[19:06] <l0rd_hex> I let it run in parallel and it didn't take very long
[19:11] <tm512> does -rtbufsize even do anything?
[19:12] <DelphiWorld> guys i want to serv a live stream over hls and i'm stuck
[19:12] <DelphiWorld> can someone help please
[19:14] <tm512> in the source code it looks like rtbufsize sets unsigned int max_picture_buffer; which is not used for anything other than printfs
[20:06] <alteregoa> someone has a static linked ffmpeg handy for mipsel? ty
[20:50] <rsdrsdrsdrsd> I want to convert to square pixels with a fixed height. Should I do setsar=1 before or after scale=trunc(dar*720/2)*2:720 ?
[20:50] <rsdrsdrsdrsd> This keeps me busy for a few days now
[20:50] <rsdrsdrsdrsd> and get come to a solution
[20:50] <rsdrsdrsdrsd> because all files are different
[20:50] <rsdrsdrsdrsd> The docs aren't clear enough for me
[20:51] <rsdrsdrsdrsd> does setsar change the frame size or not?
[21:07] <klaxa> it shouldn't
[21:07] <klaxa> sample aspect ratio is different from display aspect ratio
[21:08] <rsdrsdrsdrsd> yeah, but they are related to each other aren't they?
[21:09] <rsdrsdrsdrsd> if I do it before the frame size of the source is the same as the dar of the output
[21:10] <rsdrsdrsdrsd> if i do it after the dar of the output is the same as the frame size of the input times the sar of the input
[22:11] <sdfgdf> I forgot how to list the pixel formats supported by a codec
[22:11] <sdfgdf> internet searches are turning up nothing and -pix_fmt list is failing
[22:18] <c_14> -pix_fmts
[22:18] <sdfgdf> thank you, my savior
[22:19] <sdfgdf> wait no
[22:19] <c_14> -h encoder=$encoder
[22:19] <sdfgdf> I mean all of the pix_fmts supported by a secific codec
[22:19] <sdfgdf> there is a command for that but I forgot it
[22:19] <c_14> -h encoder=h264 should list them for h264 etc etc
[22:19] <sdfgdf> -h etc. tring...
[22:20] <sdfgdf> ah thank you
[22:21] <sdfgdf> hey, it looks like mjpeg does not suport more than 8 bits per pixel
[22:21] <sdfgdf> well, that's really all I need to know
[22:21] <sdfgdf> many thanks
[00:00] --- Sat May 24 2014

More information about the Ffmpeg-devel-irc mailing list