[Ffmpeg-devel-irc] ffmpeg.log.20150822

burek burek021 at gmail.com
Sun Aug 23 02:05:01 CEST 2015

[00:00:16 CEST] <Juli__> ollehippe: if i just stream local "ffmpeg -f video4linux2 -s 800x600 -r 15 -i /dev/video0 test.mp4" this works and create a file, but if i use http://ipaddress:8090/feed1.ffm instead of test.mp4 it didnt work and end in connection timed out
[00:05:23 CEST] <ollehippe> Juli__: I don't know how it's supposed to work but I am quite sure you can use http for transport the streamed data.
[00:06:00 CEST] <ollehippe> Juli__: Go through the streaming guide, there are some examples
[00:06:41 CEST] <Juli__> ollehippe: my problem is if i write http://... ffmpeg trys to send it on the webserver but this didnt answer. now i use /var/www/filename.end for output location
[00:06:43 CEST] <ollehippe> Juli__: hmpf, typo. "...but I am quite sure you can NOT use http for transporting the streamed data."
[00:07:59 CEST] <ollehippe> Juli__: this is not streaming - you write a file, which you then download?
[00:12:00 CEST] <Juli__> ollehippe: yeah found that out now aswell :/
[00:13:09 CEST] <ollehippe> Juli__: so it's working now?
[00:13:58 CEST] <Juli__> ollehippe: i need to get a stream working because i want a live stream of the camera for fpv
[00:14:08 CEST] <heoyea> c_14: Thanks that works, how would u set the subtitle colors also? it doesnt seem to allow multiple flags, subtitles=sub.srt:force_style='Fontsize=30,FontName=DejaVu Serif,PrimaryColour=&HAA00FF00'
[00:14:51 CEST] <c_14> that should work
[00:14:54 CEST] <c_14> Does it not work?
[00:16:28 CEST] <heoyea> c_14: no it doesnt
[00:16:38 CEST] <heoyea> works if i just have like 1
[00:16:40 CEST] <heoyea> [AVFilterGraph @ 0x5577a90342c0] No such filter: 'FontName'
[00:16:42 CEST] <heoyea> Error opening filters!
[00:16:46 CEST] <c_14> escape the commas
[00:17:06 CEST] <heoyea> doesnt the single qoutes alrady does that?
[00:17:19 CEST] <c_14> That escapes it for your shell, you need to escape it for ffmpeg
[00:17:28 CEST] <ollehippe> Juli__: I personally wouldn't stream (if it's not really necessary) I'd take a picture per second or the like...
[00:17:30 CEST] <c_14> you could but "" around the whole thing as well
[00:17:40 CEST] <c_14> the "" would escape for the shell and the '' should escape for ffmpeg
[00:17:49 CEST] <heoyea> c_14: it runs in my zshrc
[00:18:45 CEST] <c_14> hmm?
[00:18:58 CEST] <heoyea> but let me try it anyways
[00:21:26 CEST] <heoyea> c_14: seems like u do have to double bag it to escape it, Thanks
[00:22:43 CEST] <heoyea> c_14: for the PrimaryColour? are those HTML color codes or is there a list somewhere?
[00:33:08 CEST] <c_14> heoyea: it appears to be BGR
[00:33:11 CEST] <c_14> BBGGRR in hex
[00:34:15 CEST] <c_14> ah, wait
[00:34:18 CEST] <c_14> AABBGGRR
[00:34:22 CEST] <c_14> The first 2 are alpha
[00:34:33 CEST] <c_14> Man this "spec" is terrible
[00:35:00 CEST] <heoyea> yea confusing
[00:35:06 CEST] <Juli__> ollehippe: Dude thank you for help but im out for today.. but im close to get what i need, good night everyone else
[00:35:27 CEST] <ollehippe> Juli__: good night
[00:35:41 CEST] <heoyea> c_14: which page u looking at for theses?
[00:36:05 CEST] <c_14> heoyea: a random .doc file I found flying around in the internet that I then converted to pdf
[00:47:21 CEST] <heoyea> c_14: Thanks got it now, &HAABBGGRR just using a color picker http://www.zonums.com/gmaps/kml_color/
[01:53:51 CEST] <q3cpma> Hello, why can't I use "ffmpeg -i my.VOB -map 0:2 -c:v copy out.sub" to extract dvd_subtitles?
[01:54:07 CEST] <q3cpma> -c:s copy *
[01:54:45 CEST] <klaxa> what error do you get?
[01:55:36 CEST] <q3cpma> I get "Exactly one MicroDVD stream is needed."
[01:55:49 CEST] <q3cpma> And "Could not write header for output file #0 (incorrect codec parameters ?): Operation not permitted"
[01:56:17 CEST] <klaxa> can you pastebin the complete output of ffmpeg?
[01:56:35 CEST] <klaxa> it will include information about the input file which is necessary to understand what is going on
[01:57:44 CEST] <q3cpma> https://paste.kde.org/pl8soxcah
[01:59:17 CEST] <klaxa> hmm... can you try using the .dvdsub extension instead of .sub?
[01:59:35 CEST] <c_14> iirc ffmpeg can't mux dvbsub
[01:59:38 CEST] <c_14> At least not on it's own
[01:59:42 CEST] <klaxa> ah
[01:59:44 CEST] <c_14> try throwing it into an mkv or something
[02:00:31 CEST] <q3cpma> Well, the mkv trick did work
[02:40:40 CEST] <farad> hi
[02:41:00 CEST] <farad> I have run into problems using ffmpeg with my webcam
[02:41:54 CEST] <farad> it seems that it does not recognize the codec
[02:42:04 CEST] <farad> but it has worked some months ago
[02:43:41 CEST] <farad> I tried "ffmpeg -f v4l2 -list_formats all -i /dev/video0"
[02:44:10 CEST] <farad> the result was: "Compressed: Unsupported :                 PJPG : 160x120 320x240 640x480"
[02:46:40 CEST] <farad> do I miss some library?
[02:49:45 CEST] <relaxed> farad: pastebin your command and output where you attempt to grab video from it
[03:30:34 CEST] <farad> relaxed: I pasted it here: http://pastebin.com/DTpT1CsS
[03:32:56 CEST] <farad> but I do not think it contains much information
[03:37:22 CEST] <farad> except the codec was not found
[03:47:42 CEST] <farad> I pasted it once again together with "list_formats" for a better overview: http://pastebin.com/Db6vPny8
[07:54:28 CEST] <nanoEng> Could someone help me with compile error I am getting:  http://pastebin.com/eEiLkZQu  ??
[07:54:57 CEST] <nanoEng> ./configure --target-os=win64 --enable-sdl --disable-programs --disable-encoders --enable-ffplay --disable-d3d11va --disable-dxva2 --disable-shared --enable-static --disable-doc --prefix=TEST2 --disable-ffmpeg --disable-ffprobe --disable-ffserver --disable-network --enable-gpl --enable-swscale --enable-memalign-hack --enable-yasm --disable-mmx --disable-mmxext --arch=x86_64
[11:01:34 CEST] <nanoEng> Could someone help me with compile error I am getting:  http://pastebin.com/eEiLkZQu  ??
[12:38:14 CEST] <heoyea> distro?
[13:06:05 CEST] <ntt> Hi, i'm trying to use the function avcodec_find_encoder_by_name("libx264") with ubuntu, but it returns NULL. Someone can help me please?
[13:06:27 CEST] <JEEB> do you have libavcodec-extra installed?
[13:06:34 CEST] <JEEB> the default libavcodec has a lot of stuff disabled
[13:08:41 CEST] <ntt> JEEB: yes, i have to uninstall it?
[13:09:39 CEST] <JEEB> no, you have to replace normal libavcodec with the libavcodec-extra package
[13:10:03 CEST] <JEEB> it will tell it will remove the normal one and adds -extra
[13:10:34 CEST] <ntt> i'm trying....
[13:16:38 CEST] <fling> What is the best lossless video codec? libx264?
[13:17:09 CEST] <JEEB> libx264 is probably the best speed/perf ratio thing, but ffv1 seems pretty capable now too
[13:17:19 CEST] <JEEB> and after they added threading decoding that stuff is no longer slow as molasses
[13:17:36 CEST] <JEEB> (I once used ffv1 for shits and giggles before that, it was fucking horrible)
[13:18:08 CEST] <JEEB> so, uh, "best" depends on your use case a lot
[13:19:18 CEST] <ntt> JEEB: I installed libavcodec-extra and libavcodec-extra-54 but avcodec_find_encoder_by_name return NULL again
[13:19:21 CEST] <fling> JEEB: I have a 150G huffyuv 480p footage :P
[13:19:38 CEST] Action: fling is updating ffmpeg and libs to HEAD
[13:20:54 CEST] <JEEB> fling: so basically encoding speed is not that important, is decoding speed?
[13:21:15 CEST] <JEEB> anyways, I guess I'd use lossless AVC unless you have an alpha channel
[13:21:31 CEST] <JEEB> that would be quite fast to decode
[13:21:33 CEST] <fling> I don't have an alpha channel I think.
[13:21:45 CEST] <JEEB> not to mention the encoding is pretty quick, too
[13:21:48 CEST] <fling> video goes at 15 fps.
[13:22:04 CEST] <JEEB> ntt: which library are you linking against?
[13:22:10 CEST] <fling> I'd like to be able to decode atleast at 15fps too :P
[13:22:36 CEST] <JEEB> well I'm not sure how quick ffv1 is at this point (hopefully faster than it used to be), but AVC is a safe bet
[13:23:57 CEST] <ntt> not my own code, anyway:  #include <libavcodec/avcodec.h>
[13:24:14 CEST] <JEEB> yes, but you have to be linking against a libavcodec library
[13:24:32 CEST] <JEEB> is that library linked against libx264? the one you installed through libavcodec-extra should have it, but make sure
[13:26:39 CEST] <fling> JEEB: I will try both codecs on a small video chunk.
[13:33:47 CEST] <ntt> JEEB: i don't know but the code compiles correctly. A runtime, when it calls  avencoder_find_encoder_by_name("x264") it return null...
[13:34:27 CEST] <ntt> "libx264", not x264, sorry.
[13:34:33 CEST] <fling> JEEB: what is ffv1 coder, context and gop size?
[13:34:44 CEST] Action: fling is reading https://trac.ffmpeg.org/wiki/Encode/FFV1
[13:34:47 CEST] <JEEB> fling: no idea :P
[13:34:51 CEST] <fling> haha
[13:34:52 CEST] <JEEB> I just left those on defaults
[13:35:04 CEST] <fling> GOP size-g integer >= `10`_  For archival use, GOP-size should be "1".
[13:35:09 CEST] <fling> I gues I will set it to 1
[13:35:13 CEST] <JEEB> uhhh
[13:35:15 CEST] <JEEB> no
[13:35:18 CEST] <JEEB> I don't recommend that
[13:35:29 CEST] <fling> Why don't you?
[13:35:41 CEST] Action: fling wants to get the smallest file possible.
[13:35:49 CEST] <JEEB> basically the longer GOP size, the better compression because the less pictures have to be coded completely separately
[13:36:03 CEST] <JEEB> GOP size one means every picture is coded separately without any reference from other pictures
[13:36:33 CEST] <fling> omg. Then what does 'for archival use' mean there? :P
[13:36:51 CEST] <JEEB> let's just say that many people doing production etc. for whatever reason love single-frame GOPs
[13:37:13 CEST] <JEEB> I guess because they might want to slice and cut stuff without re-encoding wherever they want
[13:37:27 CEST] <JEEB> although I don't see too much of that, and the format should be quick enough to re-encode if needed
[13:37:48 CEST] <JEEB> also editors like quick seeking times, but GOP sizes of like 10 frames is usually OK'ish for that
[13:37:56 CEST] <fling> I just compiled the deps. ffmpeg time&
[13:38:18 CEST] <JEEB> (the last test someone made for seeking was around a few years ago and was OK with at least three frame GOPs for really-fast-seeking requirements)
[13:38:27 CEST] <fling> I will not be editing this probably&
[13:38:51 CEST] <JEEB> although ffv1 at least used to be slow as molasses to decode, so there it makes sense to want a single frame GOP size
[13:38:54 CEST] <fling> And I will test different GOP values haha
[13:39:06 CEST] <JEEB> just make sure when comparing to use the same value
[13:39:23 CEST] <fling> which valu?
[13:39:24 CEST] <JEEB> f.ex. libx264 defaults to 10 second GOP maximum length
[13:39:30 CEST] <fling> ohh right
[13:39:50 CEST] <JEEB> of course libx264 is adaptive, and I'm not sure what's the case with ffv1
[13:40:27 CEST] <JEEB> basically if you set a GOP size of 300, x264 can decide that it's a good idea to put an IRAP somewhere after the first 10% of that or so
[13:40:47 CEST] <fling> What is IRAP?
[13:40:58 CEST] <JEEB> Intra Random Access Picture
[13:41:01 CEST] Action: fling feels really not experienced in video encoding internals ;P
[13:41:13 CEST] <JEEB> basically the first picture of a GOP
[13:41:19 CEST] <JEEB> a thing you can start decoding from
[13:41:45 CEST] <JEEB> ntt: of course it will not fail to compile because you have no dependency on libx264 yourself
[13:42:10 CEST] <JEEB> it just really looks like the libavcodec you are linking against just isn't built against libx264
[13:42:27 CEST] <JEEB> which is why I asked which libavcodec library you were linking against
[13:42:57 CEST] <JEEB> if you are linking against shared libraries you can use ldd
[13:43:04 CEST] <JEEB> https://en.wikipedia.org/wiki/Ldd_%28Unix%29
[13:43:16 CEST] <JEEB> won't help with static dependencies of course
[13:43:54 CEST] <ntt> in the Makefile I see AVCLD= $(shell pkg-config --libs libswscale libswresample libpostproc libavdevice libavfilter libavcodec libavformat libavutil)
[13:44:54 CEST] <JEEB> which means it uses whatever finds through pkg-config
[13:44:59 CEST] <JEEB> *whatever it finds
[13:45:13 CEST] <ntt> libavcodec.so.56 => /home/ntt/Projects/ga/deps.posix/lib/libavcodec.so.56 (0x00007f8a3699b000)
[13:45:21 CEST] <JEEB> ok, so you are using something custom
[13:45:24 CEST] <ntt> yes
[13:45:30 CEST] <JEEB> and therein I feel your issue
[13:45:31 CEST] <JEEB> is
[13:45:43 CEST] <JEEB> I'm pretty sure you are not going to find libx264.so in there
[13:45:58 CEST] <ntt> There is a deps.src folder that I have to compile before compile the softwae
[13:46:21 CEST] <ntt> no.... I have libx264.so
[13:46:22 CEST] <ntt> !
[13:46:27 CEST] <JEEB> in the ldd output?
[13:47:05 CEST] <ntt> libx264.so.142 => /home/ntt/Projects/ga-/deps.posix/lib/libx264.so.142 (0x00007f8a3518a000)
[13:47:15 CEST] <ntt> and this file exists
[13:47:45 CEST] <ntt> the "-" in the path is a type
[13:47:48 CEST] <ntt> the "-" in the path is a typo*
[13:48:04 CEST] <JEEB> ok
[13:48:29 CEST] <JEEB> now you have to make sure that it's actually linked to the libavcodec
[13:48:39 CEST] <JEEB> and that you are loading those correct things on runtime
[13:49:37 CEST] <ntt> I have this problem only on ubuntu. Compiled on Centos6 and it works
[13:50:18 CEST] <JEEB> well that's why I'm noting those issues
[13:50:29 CEST] <ntt> lubuntu precisely
[13:50:41 CEST] <JEEB> with centos all the crap that comes with it is so old
[13:50:52 CEST] <JEEB> so you have little chance of getting system packages with similar versions :P
[13:51:21 CEST] <ntt> yes...because this project requires also libpulse and on centos6 it is in a really old version
[13:51:21 CEST] <JEEB> anyways, just make sure you are building against the right things
[13:51:32 CEST] <JEEB> and linking
[13:51:33 CEST] <JEEB> and loading
[13:51:48 CEST] <JEEB> and make sure that custom libavcodec of yours is actually linked to that libx264
[13:52:44 CEST] <JEEB> and if you are using custom stuff like that then I almost recommend uninstalling the system shared libraries (or at least the -dev packages) because those might just be making it all worse
[13:53:01 CEST] <JEEB> too bad I have no effing idea what you're doing exactly, so I can't exactly help you too much
[13:53:19 CEST] <ntt> yes.... i known
[13:53:20 CEST] <ntt> yes.... i know
[13:53:40 CEST] <JEEB> just make sure you are building against the right headers, linking against the right things and having those right things load up during runtime
[13:54:20 CEST] <ntt> So should I remove libavcodec-extra-dev package?
[13:55:51 CEST] <JEEB> well that does provide the headers, so if your thing suddenly fails to compile after that it means that you were using the headers from a wrong place :P
[13:55:57 CEST] <JEEB> or well
[13:56:03 CEST] <JEEB> with libavcodec-extra it should be the right place
[13:56:10 CEST] <JEEB> because it actually should have libx264 linked in
[13:56:13 CEST] <JEEB> but for you it's the wrong place
[13:56:33 CEST] <JEEB> since you are seemingly using a completely custom thing which for whatever reason is using shared libraries just to make it even more obnoxious
[14:06:16 CEST] <ntt> ok JEEB. However, thank you.
[14:26:55 CEST] <fling> JEEB: I ended up encoding lossy because the output is too huge.
[14:27:22 CEST] <fling> JEEB: also looks like libopus is now properly muxed into matroska
[14:27:23 CEST] <JEEB> well you already have a huge input, I would guess you could at least halve it with better lossless coders?
[14:27:49 CEST] <JEEB> also I hope you used long enough GOPs and slower presets with the libx264 part
[14:28:16 CEST] <fling> how to set gop with libx264? Do I really need to set it?
[14:28:56 CEST] <fling> The scene is never changing. There is no parts in the video.
[14:29:23 CEST] <fling> Is there a good '-tune &' value for a noisy video?
[14:30:04 CEST] <JEEB> well you're using ffmpeg so -g is the thing
[14:30:24 CEST] <JEEB> you might have to find out which -g parameter sets the thing that equals to libx264's keyint=infinite
[14:30:39 CEST] <JEEB> (that is the maximum which is what -g also sets)
[14:30:52 CEST] <JEEB> and if you're using lossless compression you just don't use -tune
[14:30:59 CEST] <JEEB> it's generally only useful with lossy compression
[14:31:32 CEST] <JEEB> you just want to make sure that you either set the quantizer or crf value to the one required for lossless, and then set the slowest preset that is still fast enough for you
[14:37:59 CEST] <fling> JEEB: I use lossy and set crf. I use veryslow preset. do I need keyint=infinite or gop setting?
[14:48:03 CEST] <JEEB> fling: if you want maximum compression and don't care about seeking speed then keyint=infinite is recommended, otherwise the 10 second gops libx264 creates by default are pretty good
[14:58:44 CEST] <fling> JEEB: thanks for the info ;>
[14:59:04 CEST] <fling> Another problem is the audio is too desynced. Looks like video is playing with a different speed somehow&
[15:09:09 CEST] <fling> I have this issue in multiple videos hmm hmmm&
[16:29:00 CEST] <olspookishmagus> I'm looking for information on ffmpeg's -ab option, and I don't find it here: https://ffmpeg.org/ffmpeg.html
[16:29:05 CEST] <c_14> -b:a
[16:33:29 CEST] <DHE> it's a deprecated notation for -b:a (bitrate of audio stream). Specifically note that it's in bits and you should specify a "k" prefix or add "000" to the end of it.
[16:33:36 CEST] <DHE> *suffix
[16:34:47 CEST] <olspookishmagus> thank you c_14 and DHE for that "bitrate of audio stream" hint
[16:36:05 CEST] <olspookishmagus> as I was trying to match that with "5.1 Stream Specifiers" in the documentation
[22:46:52 CEST] <solrize> anyone know if there's a recipe to encode webM from ffmpeg and upstream to icecast?  it looks like the icecast protocol is there
[22:47:26 CEST] <c_14> ffmpeg -i video -f webm icecast://
[22:47:28 CEST] <c_14> probably?
[22:47:36 CEST] <solrize> thanks i'll try that
[22:49:28 CEST] <BtbN> Isn't icecast some radio thing, so audio-only?
[22:50:38 CEST] <c_14> *shrug*
[23:16:21 CEST] <solrize> BtbN, icecast does webm video
[23:16:32 CEST] <solrize> any idea where to set the icecast options?  there's something i have to set to make the stream public
[23:16:37 CEST] <solrize> https://ffmpeg.org/ffmpeg-protocols.html#Icecast
[23:17:20 CEST] <BtbN> propably just -ice_public 1
[23:33:27 CEST] <solrize> yeah i got that to work, and the client connects ok but isn't showing any vid
[23:33:33 CEST] <solrize> trying to figure out what might be wrong
[00:00:00 CEST] --- Sun Aug 23 2015

More information about the Ffmpeg-devel-irc mailing list