[Ffmpeg-devel-irc] ffmpeg.log.20150823

burek burek021 at gmail.com
Mon Aug 24 02:05:01 CEST 2015

[02:23:08 CEST] <koz_> What open format for video maximizes compression?
[02:23:26 CEST] <koz_> (by 'video' I mean 'videos complete with audio', not 'video only')
[02:29:41 CEST] <c_14> I'm assuming you want "maximum compression at a decent quality". Probably vp9 + opus in webm/matroska or maybe even nut.
[02:30:11 CEST] <koz_> c_14: OK, thanks.
[02:49:06 CEST] <koz_> ffmpeg -i in.mp4 -codec:a opus -b:a 96k -codec:v vp9 -crf 10 -b:v 10M -cpu-used 8 -threads 4 out.mkv <-- is this the best way to write this command to use as much of my CPU and memory etc as possible?
[02:50:20 CEST] <c_14> Until someone adds a -placebo option, it should be ok.
[02:50:49 CEST] <koz_> c_14: Ouch, vp9 is certainly not running fast on my machine then.
[02:50:53 CEST] <koz_> I get like, 15fps :P
[02:53:15 CEST] <koz_> I'd think with my CPU, it'd be a *bit* faster...
[02:53:38 CEST] <c_14> Well, there are options to make it faster, but you'll lose compression
[02:54:17 CEST] <koz_> c_14: Ah, I see.
[02:54:39 CEST] <koz_> I'm guessing it's the compression that's making so much work for it?
[02:54:51 CEST] <c_14> Also the encoder isn't particularly optimized.
[02:55:26 CEST] <koz_> Ah, that would do it too.
[05:28:33 CEST] <tommd> I am trying to get a stream of frames on avfoundation (and v4l2 would be nice) for live video processing.
[05:30:19 CEST] <tommd> As a first step I figured I'd learn how to get input via avfoundation.  The CLI command `ffmpeg -f avfoundation -i "0:0" output.avi` yields an odd error of (paste incoming)
[05:31:34 CEST] <relaxed> did you see https://trac.ffmpeg.org/wiki/Capture/Webcam  ?
[05:32:09 CEST] <tommd> http://pastebin.com/TWwm21h3
[05:32:12 CEST] <tommd> Looking
[05:34:20 CEST] <tommd> I have seen that, it is how I have gotten this far.
[05:35:26 CEST] <tommd> So WRT the pasted error, manually setting the framerate via -frame_rate, -framerate, and -r all appear to have no affect.
[05:37:03 CEST] <relaxed> pastebin the output of, ffmpeg -f avfoundation -list_devices true -i ""
[05:38:03 CEST] <tommd> relaxed: Thank you for your time, obviously I have a ways to go to get to my desired goal, but this problem has suddenly been resoved by placing -framerate in the proper spot (before -i)
[05:38:21 CEST] <tommd> Would you like the output of that line anyway to figure out this behavior, which seems buggy?
[05:39:38 CEST] <tommd> That is, I don't think I should have to specify the framerate in the first place.
[05:40:52 CEST] <tommd> relaxed: If you desire the output then see http://pastebin.com/C764jNTw
[05:41:44 CEST] <tommd> If you're a dev and want to track this down then I'm happy to work with you on it - tommd here on freenode frequently, on github, and on keybase.
[05:42:25 CEST] <relaxed> try, ffmpeg -f avfoundation -i "default" -t 10 output.mkv
[05:45:34 CEST] <tommd> relaxed: Same error as previously pasted.
[07:36:32 CEST] <koz_> Can I use ffmpeg to convert music from one format to another?
[07:40:26 CEST] <durandal_1707> Yes
[07:40:46 CEST] <koz_> durandal_1707: What would be a good open format for music if space is at a premium?
[07:40:57 CEST] <koz_> Like, I want the best compression possible without severe quality degradation.
[07:42:55 CEST] <durandal_1707> opus, vorbis, flac..
[07:44:29 CEST] <koz_> OK, thanks.
[07:44:41 CEST] <koz_> How would I convert something to opus using ffmpeg?
[07:46:40 CEST] <solrize> koz_, you should probably use vorbis unless i'm behind the times... more players can decode it
[07:47:01 CEST] <solrize> ffmpeg -i whatever.wav whatever.ogg
[07:47:23 CEST] <solrize> there are a bunch of parameters you can set but that's the first thing to try
[07:47:27 CEST] <koz_> solrize: OK.
[07:48:18 CEST] <koz_> [mjpeg @ 0x562518ed2240] overread 8
[07:48:19 CEST] <koz_> [mjpeg @ 0x562518ed2240] EOI missing, emulating
[07:48:22 CEST] <koz_> What does this mean?
[07:48:48 CEST] <solrize> it's trying to convert video?  what's the input format?
[07:49:05 CEST] <koz_> .mp3 according to the extension
[07:49:11 CEST] <solrize> hmm
[07:49:31 CEST] <solrize> well are you getting playable output?
[07:50:18 CEST] <koz_> Yup.
[07:50:22 CEST] <solrize> i remember having some issues with non-bleeding-edge versions of ffmpeg and doing better by building from the git version
[07:51:05 CEST] <solrize> wow opus sounds pretty good
[07:53:16 CEST] <solrize> koz_, what country are you in?  the mp3 patents may have expired where you are
[07:53:21 CEST] <solrize> in the u.s. some last til 2017
[07:53:36 CEST] <koz_> solrize: New Zealand.
[07:53:44 CEST] <koz_> I'd rather use open formats if possible as a general rule.
[07:54:11 CEST] <solrize> what's the application?  if you're starting with mp3, transcoding will mess up the sound some
[07:54:21 CEST] <koz_> solrize: Personal listening.
[07:55:35 CEST] <solrize> well it's up to you... i'd say if you've already got the mp3's you might as well listen to them directly.  you could think of it as rebellion ;)
[07:55:53 CEST] <koz_> solrize: Thanks, lol.
[07:56:13 CEST] <solrize>  If only the known MP3 patents filed by December 1992 are considered, then MP3 decoding may be patent-free in the US by September 2015 when U.S. Patent 5,812,672 expires which had a PCT filing in Oct 1992.[61][62][63]
[07:56:29 CEST] <solrize> do you have like terabytes of mp3's or something?
[15:46:58 CEST] <thecoolguy> Hello
[15:49:14 CEST] <thecoolguy> how do i get ffmpeg to stream a file
[17:53:11 CEST] <FlorianBd> Hi :)
[17:53:51 CEST] <FlorianBd> when encoding to webm with  -y -deadline realtime -f webm   I get:  Unrecognized option 'deadline'. Error splitting the argument list: Option not found
[17:54:09 CEST] <FlorianBd> but the same command on another machine works. Any idea what can cause this?
[18:00:52 CEST] <JEEB> see what's your version
[18:01:05 CEST] <JEEB> ffmpeg -version
[18:01:23 CEST] <JEEB> also what encoder is getting picked in both cases, because -deadline is libvpx-specific
[18:06:23 CEST] <JEEB> wow, if you don't have -deadline with libvpx that must be an old old binary
[18:06:40 CEST] <JEEB> luca added those options on 26th of september, 2011
[18:45:29 CEST] <Fyr> is there a console tool for audio tagging?
[18:45:41 CEST] <Fyr> mp3, aac, flac, ogg etc?
[19:38:26 CEST] <durandal_1707> Fyr: you mean metadata?
[19:51:21 CEST] <FlorianBd> JEEB: sorry for the delay. No it's 2.7.1 natively compiled in 64
[19:51:59 CEST] <JEEB> then you don't have libvpx linked in
[19:52:11 CEST] <JEEB> because it's a libvpx specific option in ffmpeg
[19:52:46 CEST] <JEEB> so three possibilities: 1) too old ffmpeg (older than 2011) 2) libvpx not selected as encoder 3) libvpx not linked into your ffmpeg
[19:55:58 CEST] <FlorianBd> ah, probably 3) then. Thanks!  Let's see my configure options
[19:56:22 CEST] <FlorianBd> ./configure --prefix=/usr/local/ffmpeg-2.7.1-native64 --disable-debug --enable-shared --enable-stripping
[19:57:34 CEST] <JEEB> yes
[19:57:48 CEST] <JEEB> you haven't built libvpx then and --enable-libvpx is not set
[19:58:15 CEST] <Joergi> Hi guys!
[19:58:50 CEST] <Joergi> I recently did an upgrade to Windows 10 and now some mpg files can no longer be played back correctly: The video is not shown and the audio is interrupted.
[19:58:53 CEST] <JEEB> also if you are going to encode libvpx + vorbis or opus you will want to add either libvorbis or libopus for the encoding
[20:00:14 CEST] <Joergi> This is what ffmpeg -i filename.mpg gives me:
[20:00:15 CEST] <Joergi> http://pastebin.com/UYKuBDM2
[20:00:43 CEST] <Joergi> Do you have an idea, what I might do to get these files play back correctly in Windows Media Player on Windows 10?
[20:06:58 CEST] <Abbadon> Hey, is it possible to output segments and manifest for mpeg-dash live streaming?
[20:16:04 CEST] <JEEB> yes, there is a lavf mpeg-dash muxer in the latest versions
[20:16:37 CEST] <Abbadon> I can't find anything in the documentation
[20:17:01 CEST] <JEEB> ffmpeg -formats |grep dash
[20:24:32 CEST] <Abbadon> Are there any command line examples?
[20:29:27 CEST] <FlorianBd> JEEB: I did build libvpx-v1.3.0 native & optimized to /usr/local/libvpx-v1.3.0-native64   Should I add the path to LD_LIBRARY_PATH in addition to using --enable-libvpx ?
[20:30:02 CEST] <c_14> Either that, or add it to LD_RUN_PATH when compiling
[20:30:36 CEST] <FlorianBd> thanks, will try that right now
[20:41:08 CEST] <Fyr> durandal_1707, yes.
[20:41:39 CEST] <whoknows> hi guys
[20:42:17 CEST] <whoknows> is there a best way to convert swf to mp4? Regular methos gives .mp4 with sound only
[20:42:45 CEST] <c_14> You can only convert flash files that contain actual video. Animated flash is not supported.
[20:43:14 CEST] <whoknows> err...so convert it to flv first?
[20:46:27 CEST] <c_14> You're going to have to render the animated content with something.
[20:47:00 CEST] <whoknows> like what? vlc?
[20:47:05 CEST] <whoknows> or mplayer?
[20:47:22 CEST] <c_14> I don't think either can play animated flash.
[20:48:07 CEST] <c_14> The only 2 players I know that support animated flash are adobe flash, pepperflash, and gnash.
[20:48:42 CEST] <c_14> And I don't think any of those support rendering to file so you'd have to screen-capture.
[21:35:21 CEST] <q3cpma> Hello, does ffmpeg 2.7.2 need a compilation flag to have the ssim filter?
[21:35:42 CEST] <DelphiWorld> yo
[21:36:33 CEST] <q3cpma> Because I get "No such filter: 'ssim'" with -vf ssim
[21:37:45 CEST] <whoknows> okay, can it process zipped images?
[21:38:09 CEST] <c_14> q3cpma: I'm not sure that filter is in that release yet.
[21:38:25 CEST] <c_14> whoknows: don't think so
[21:38:36 CEST] <whoknows> ugh
[21:38:37 CEST] <q3cpma> c_14: Well, it's in the online doc
[21:39:07 CEST] <whoknows> also i ran out of memory when i was "rendering" swf to image sequence :(
[21:39:10 CEST] <c_14> q3cpma: because it's in the git release
[21:39:28 CEST] <q3cpma> c_14: i see. Anyway I can use the online doc with stable?
[21:39:50 CEST] <c_14> q3cpma: you could just use a static build
[21:39:53 CEST] <c_14> http://johnvansickle.com/ffmpeg/
[21:40:40 CEST] <q3cpma> c_14: It's easy for me to compile it. I mean, is there an online doc for the stable release?
[21:40:59 CEST] <c_14> Not that I know of. I'm relatively sure the online docs are only built for git.
[21:41:18 CEST] <c_14> If you built your own release, the htmlpages are built by default as well (if you have the requisite programs) as well as manpages and pdfs.
[21:41:27 CEST] <c_14> If you use a package, the manpages at least are usually included.
[21:41:42 CEST] <q3cpma> c_14: Well, that's quite curious, since stable is usually the advertised version. Anyway, you're right, I have the man.
[21:44:39 CEST] <c_14> The FFmpeg project advertises the git version.
[21:44:43 CEST] <c_14> Releases are only for distros.
[21:45:00 CEST] <c_14> (Since there are usually plenty of bugfixes in the git version that don't make it into releases)
[21:45:58 CEST] <q3cpma> c_14: Ok. Do you know a CLI program with PEVQ measurement?
[21:47:06 CEST] <c_14> ffmpeg has both ssim and that psnr. Old versions of ffmpeg have tools/simple-ssim (which your distro may or may not have packaged with ffmpeg)
[21:49:08 CEST] <c_14> At least I think there was a simple-ssim in tools somewhere
[21:49:17 CEST] <c_14> ah, tests/tiny_ssim
[21:49:41 CEST] <q3cpma> c_14: Looks like Arch didn't bother with it. I'll probably switch to the git version.
[21:50:10 CEST] <c_14> The psnr filter is older, you could always use that one.
[21:50:17 CEST] <DelphiWorld> sup c1
[21:50:25 CEST] <DelphiWorld> sup c_14
[21:50:29 CEST] <c_14> hi
[21:50:46 CEST] <q3cpma> c_14: I've used it, but it's pretty shit from what I've heard. Especially compared to ssim and pevq
[21:52:22 CEST] <c_14> If it's so much better, a patch adding it would probably be accepted. :)
[21:52:55 CEST] <q3cpma> c_14: It also seem pretty complex, hehe
[00:00:00 CEST] --- Mon Aug 24 2015

More information about the Ffmpeg-devel-irc mailing list