[Ffmpeg-devel-irc] ffmpeg.log.20150707

burek burek021 at gmail.com
Wed Jul 8 02:05:01 CEST 2015

[00:03:57 CEST] <c_14> The arm-linux one since you're cross-compiling (presumably)
[00:14:25 CEST] <heap__> c_14: no, no crosscompiling
[00:14:41 CEST] <heap__> c_14: i think both libs are from arm packages
[00:16:12 CEST] <c_14> Well, normally you compile all the libav* libs and then link ffmpeg against the libs you just compiled.
[00:17:28 CEST] <heap__> i installed all the libav packages and now compilling ffmepg
[00:18:02 CEST] <heap__> getting so many warning as libavcodec/hevc_ps.c:937:79: warning: array subscript is above array bounds [-Warray-bounds] sps->temporal_layer[i].max_latency_increase  = sps->temporal_layer[start].max_latency_increase;
[00:18:11 CEST] <heap__> during compliation
[00:32:34 CEST] <Nolski> kepstin-laptop: quick question, what do you mean when you say use a trim? I'd want the videos to start and end at the same time.
[00:32:53 CEST] <Nolski> or I suppose I mean, I wouldn't want to trim either of the overlaid videos
[00:34:53 CEST] <kepstin-laptop> Nolski, i'm not sure how you can have the videos start and end at the same time, they have different lengths
[00:35:28 CEST] <kepstin-laptop> so you have to remove part of one of them if you want them to be the same length, which means trimming bits off the longer one, or having the shorter one repeat frames.
[00:39:52 CEST] <Nolski> kepstin-laptop: Right, sorry I think I worded what I was saying poorly. I wouldn't want to trim the longer one because all of that content is important. The shorter one I want to only show (overlaid) for a part of the longer one.
[00:40:39 CEST] <Nolski> So trimming the longer one would remove content I want to be shown and for the shorter one I only want to see it for a portion of the longer one
[00:43:05 CEST] <kepstin-laptop> hmm. ok, so you want to delay the start of the shorter video rather than trim the longer one.
[00:43:32 CEST] <Nolski> kepstin-laptop: exactly
[00:44:03 CEST] <kepstin-laptop> I think to do that with the overlay filter, you might have to use the setpts filter to add some time to the pts values from the video (e.g. setpts=PTS+6 to delay the start by 6 seconds)
[00:44:13 CEST] <Nolski> So the idea is that the longer video is the main video and during some points of that video you might want to have a "picture in picture" type of deal with the shorter one
[00:44:52 CEST] <kepstin-laptop> the other alternative is to do it in chunks and concatenate them, which is what i ended up doing in my scripted stuff :/
[00:46:18 CEST] <Nolski> Ah yes... That would probably work too
[00:53:48 CEST] <heap__> ?
[00:55:20 CEST] <kepstin-laptop> Nolski, for the record, the 'do it in chunks and concatenate them' method is what I used for generating videos like http://recordings.blindsidenetworks.com/bn/eade3bee5915b437aa6fc1ab0f21aea4bbe1f959-1374785178888/capture/ ), which is done with the nasty ruby code in https://github.com/bigbluebutton/bigbluebutton/blob/master/record-and-playback/core/lib/recordandplayback/edl/video.rb
[00:56:41 CEST] <kepstin-laptop> I don't necessarily suggest copying that code, I'd probably do it a bit differently if i did it again ;)
[00:57:26 CEST] <pzich> hah
[00:58:23 CEST] <pzich> so this was assembled after, not realtime?
[00:58:28 CEST] <kepstin-laptop> yeah
[00:59:05 CEST] <kepstin-laptop> we just record the individual webcam videos and a file that records timings for events
[00:59:17 CEST] <pzich> ah makes sense
[01:02:08 CEST] <kepstin-laptop> realtime... that would be an interesting challenge :)
[01:02:13 CEST] <kepstin-laptop> might have to do it someday.
[01:02:41 CEST] Action: kepstin-laptop is off.
[01:05:10 CEST] <heap__> when i execute ffmpeg it says
[01:05:11 CEST] <heap__>   WARNING: library configuration mismatch
[01:05:31 CEST] <c_14> Dynamic compilation?
[01:05:37 CEST] <heap__> what do you mena?
[01:05:38 CEST] <heap__> mean
[01:05:41 CEST] <c_14> You probably need to set LD_LIBRARY_PATH correctly
[01:06:49 CEST] <heap__> hm
[01:07:24 CEST] <c_14> export LD_LIBRARY_PATH="path/to/ffmpeg/libraries:$LD_LIBRARY_PATH"
[01:07:40 CEST] <heap__> http://pasted.co/9505a72b
[01:08:33 CEST] <c_14> Where did you install the ffmpeg libraries?
[01:10:36 CEST] <heap__> idk./configure  --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-avisynth --enable-avresample -
[01:10:44 CEST] <heap__> so i assume /usr/lib?
[01:11:03 CEST] <c_14> If you `make install'ed, yes.
[01:11:08 CEST] <c_14> That should be in your path already though.
[01:11:13 CEST] <c_14> LD_LIBRARY_PATH that is
[01:11:25 CEST] <heap__> yes.
[01:11:33 CEST] <heap__> so i dont know what missmatch?
[01:11:42 CEST] <c_14> try `which ffmpeg' and `ldd `which ffmpeg`'
[01:12:01 CEST] <c_14> To find the path of the ffmpeg in your PATH, and what libraries it's linking against.
[01:13:23 CEST] <heap__> which ffmpeg
[01:13:24 CEST] <heap__> /usr/bin/ffmpeg
[01:14:15 CEST] <heap__> http://pastie.org/10276533
[01:15:07 CEST] <c_14> ok, geh
[01:15:20 CEST] <heap__> it points somewhere else?
[01:15:57 CEST] <c_14> yes, it's pointing to /usr/lib/arm-linux-gnueabihf/libav* instead of /usr/lib/libav*
[01:16:05 CEST] <heap__> so can i fix it?
[01:16:25 CEST] <c_14> You can try `export LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH'
[01:16:41 CEST] <heap__> i did
[01:16:45 CEST] <heap__> but same thing
[01:17:22 CEST] <heap__> everything points to arm-linux...
[01:17:53 CEST] <heap__> thats fucked up .. some of them points to usr/lib other to usr/lib/arm...
[01:18:35 CEST] <heap__> it works now
[01:18:40 CEST] <heap__> strange
[01:18:54 CEST] <c_14> You can try setting RPATH during compilation, setting the prefix to /usr/lib/arm-linux-gnueabihf, or using something like setrpath to set the rpath of the ELF executable
[01:19:10 CEST] <heap__> c_14: is there any other was as export LD_LIB ...
[01:19:37 CEST] <c_14> (the ELF executable in this case being the ffmpeg binary)
[01:23:46 CEST] <heap__> hold on why rpath to /usr/lib/arm?
[01:23:46 CEST] <c_14> No, rpath to /usr/lib
[01:23:46 CEST] <heap__> when i did export LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH it works now
[01:23:46 CEST] <c_14> the /usr/lib/arm would be to set the prefix there during compilation thereby overwriting those libs (which may or may not be safe)
[01:23:46 CEST] <heap__> some libs points to usr/lib other to /usr/lib/arm but it works
[01:23:46 CEST] <c_14> heap__: as long as the libav* libs point to usr/lib it's fine
[01:23:46 CEST] <heap__> but i have user.. that run emby as daemon
[01:23:46 CEST] <heap__> using init script
[01:23:46 CEST] <heap__> question is how can i replicate it if its system service
[01:23:46 CEST] <c_14> Either set LD_LIBRARY_PATH in the init script (the daemon should normally inherit environment variables from the init script) or do what I said regarding setting the rpath of the ELF executable (or recompile with the RPATH set to /usr/lib)
[01:23:46 CEST] <heap__> ok let me try it
[01:23:47 CEST] <heap__> c_14: thank you so much anyway
[01:28:09 CEST] <heap__> so looks like its ignored inside init script
[01:34:20 CEST] <zhanshan> hi
[01:34:31 CEST] <zhanshan> does this look like a good command line to you
[01:36:20 CEST] <zhanshan> ffmpeg -i 2015_07_06.mkv -acodec copy -vcodec libx264 -crf 18 -preset medium -vf ass=2015_07_06.ass 2015_07_06_hardsub.mkv
[01:36:21 CEST] <zhanshan> ?
[01:36:29 CEST] <zhanshan> or am I missing something?
[01:37:01 CEST] <c_14> You don't need -preset medium (it's the default)
[01:37:11 CEST] <zhanshan> I don't really have time to try a lot since I will have my verbal exam tomorrow
[01:37:53 CEST] <zhanshan> oh no: fontconfig: cannot find glyph U+0308 in font 'Aguafina Script', falling back to 'DejaVu Sans Bold'
[01:38:06 CEST] <c_14> Shouldn't matter.
[01:38:20 CEST] <c_14> If you have actual fonts embedded with the ass (in something like the source mkv) use the subtitles filter instead.
[01:43:39 CEST] <zhanshan> thanks c_14 !
[01:43:43 CEST] <zhanshan> It worked well
[01:54:56 CEST] <heap__> c_14: can i find out if ffmpeg is using gpu while transcoding video//flac?
[01:55:12 CEST] <c_14> It isn't.
[01:55:17 CEST] <c_14> (unless you explicitly enable it)
[01:57:59 CEST] <heap__> during compliation?
[01:58:03 CEST] <heap__> compilation
[01:58:06 CEST] <c_14> Both
[01:58:23 CEST] <heap__> i compiled it as --enable-mmal  --arch=armel
[01:58:24 CEST] <c_14> You need to compile it with the hardware support foo you want to use, and then enable it during execution.
[01:59:46 CEST] <heap__> is --enamble-mmal enought?
[02:00:05 CEST] <c_14> hmm, it looks like it registers as a decoder
[02:00:29 CEST] <heap__> dont know what you mean
[02:00:48 CEST] <c_14> check `ffmpeg -decoders' for mmal or something
[02:01:01 CEST] <heap__> /usr/bin/ffmpeg -i file:"/mnt/nfs4/storage/media-ro/music_lossless/Frank Zappa/[08 1969] Hot Rats/02 Willie The Pimp.flac" -threads 0 -vn -ab 192000 -ac 2 -id3v2_version 3 -write_id3v1 1 -y "/var/lib/emby/transcoding-temp/a5bfae6e26ecb1a09612e05ee4a3af10.mp3"
[02:01:05 CEST] <heap__> this is executed
[02:03:02 CEST] <c_14> I think mmal is h264 only
[02:03:13 CEST] <heap__> mmal is only video
[02:03:15 CEST] <heap__> right
[02:03:23 CEST] <heap__> but is there anything for audio?
[02:04:25 CEST] <c_14> Don't think so. Audio usually isn't complex enough to warrant it.
[02:06:14 CEST] <hanshenrik_> boobies
[02:09:49 CEST] <heap__> okay
[02:46:22 CEST] <Nolski> any reason why `ffmpeg -ss {timestamp} -t {duration} -i in.nut out.nut` would keep the total duration of in.nut even though it should be trimmed?
[03:38:11 CEST] <relaxed> Nolski: pastebin
[04:54:29 CEST] <MCourtenay> How would I go about combining concat from mylist.txt (as described in the documentation) with an rtmp stream?
[04:55:00 CEST] <MCourtenay> I tried ffmpeg -f concat -i mylist.txt -c copy rtmp:// but this resulted in: " Unable to find a suitable output format for 'rtmp://'
[04:55:00 CEST] <MCourtenay> rtmp:// Invalid argument"
[05:02:36 CEST] <klaxa> not sure if this would help, but try adding -f flv
[05:02:41 CEST] <klaxa> before rtmp://...
[05:03:54 CEST] <klaxa> it should at least fix the output format issue
[05:04:02 CEST] <klaxa> by forcing flv as the output format
[05:04:18 CEST] <klaxa> which is i think the only format rtmp supports?
[05:04:23 CEST] <MCourtenay> Well...that got the stream running but now I'm getting: "Non-monotonous DTS in output stream 0:0; previous: 31031, current: 31030; changing to 31031. This may result in incorrect timestamps in the output file."
[05:04:37 CEST] <MCourtenay> Yeah, I think it is
[05:05:06 CEST] <MCourtenay> Then at EOF, I got: "Failed to update header with correct duration.trate= 413.1kbits/s
[05:05:06 CEST] <MCourtenay> [flv @ 0xaa5600] Failed to update header with correct filesize."
[05:05:28 CEST] <klaxa> the non-monotonous dts might come from concatenating multiple files
[05:06:00 CEST] <klaxa> not sure how to fix that
[05:06:35 CEST] <MCourtenay> hmm
[05:06:54 CEST] <klaxa> random thing i would try would be -vf "setpts=PTS-STARTPTS"
[05:08:03 CEST] <MCourtenay> Okay thanks, let me give that a shot
[05:08:31 CEST] <MCourtenay> Does that go before rtmp:// ?
[05:08:59 CEST] <klaxa> yes
[05:09:25 CEST] <klaxa> general syntax is: ffmpeg [input options] -i [input] [output options] [output]
[05:12:55 CEST] <MCourtenay> thanks...
[05:13:06 CEST] <MCourtenay> Didn't work, here's what I got: "Filtergraph 'setpts=PTS-STARTPTS' was defined for video output stream 0:0 but codec copy was selected.
[05:13:06 CEST] <MCourtenay> Filtering and streamcopy cannot be used together."
[05:13:24 CEST] <klaxa> ah
[05:13:35 CEST] <klaxa> yeah well that makes sense...
[05:13:43 CEST] <klaxa> i guess
[05:14:42 CEST] <MCourtenay>  yeah
[05:14:44 CEST] <MCourtenay> oh well
[06:27:35 CEST] <well0ne> Hi
[06:27:44 CEST] <well0ne> Ive some question
[06:28:34 CEST] <well0ne> I'm using ffmpeg for streaming to an rtmp server (live stream), i'm using the draw filter to place some text
[06:28:56 CEST] <well0ne> is it possible to display the elapsed time from the specific file?
[06:29:03 CEST] <well0ne> i tried to google but no success so far
[11:34:04 CEST] <brontosaurusrex> what fps was interstellar shot at?
[11:35:56 CEST] <RobertNagy> when creating mxf xdcam50 files how to I pre-charge the video? i.e. set the start offset due to the extra frames that are required for starting on a keyframe?
[11:36:51 CEST] <RobertNagy> looking at the mxfenc.c code it seems to use the same timecode for all tracks without the possibility to add a offset to a specific track (i.e. video).
[12:36:29 CEST] <flying_toaster> hi there
[12:36:45 CEST] <flying_toaster> I am currently writing an encoder for ffmpeg
[12:37:01 CEST] <flying_toaster> is there a documentation somewhere about using slice threads ?
[12:38:16 CEST] <c_14> flying_toaster: if you're writing an encoder for ffmpeg, try asking in #ffmpeg-dev
[12:38:25 CEST] <flying_toaster> good point
[12:38:27 CEST] <flying_toaster> thanks
[12:38:50 CEST] <durandal_170> what encoder?
[12:40:16 CEST] <flying_toaster> I'm using a video device that needs a 4:2:2 10 bit packed format as input. Close to v210, but different
[12:42:35 CEST] <durandal_170> btw channel is ffmpeg-devel
[12:42:56 CEST] <durandal_170> not dev :)
[12:43:11 CEST] <flying_toaster> ok
[12:43:13 CEST] <flying_toaster> thanks
[12:44:13 CEST] <c_14> Oh, derp. My client decided that was too long and shortened the name...
[13:07:59 CEST] <chungy> Is it possible to crop the dimensions of a dvd_subtitle stream?
[13:11:26 CEST] <kni> Hi, can anyone tell me the option for ffplay to display a video clip on the Secondary display [projector] ?
[13:14:24 CEST] <JEEBsv> it's not a proper player; if you want a proper player I recommend mpv
[13:16:20 CEST] <kni> mmm, mpv I don know yet -- what's it's full name? (or where can I find it?)
[13:21:31 CEST] <kni> allright, I think I'll stick with MPC and VLC -- thanks anyway!
[13:24:18 CEST] <JEEBsv> kni: mpv.io
[13:56:14 CEST] <RuAnt> i've tried to google to find a good c# wrapper, but i'm only finding old projects thats dead. any recommendations?
[14:05:13 CEST] <JEEBsv> I'm pretty sure there are none
[14:12:29 CEST] <RuAnt> Hmm, ok. Thanks for the reply.
[16:42:15 CEST] <zarkone> hello all. To direct ffmpeg output to http:// i can use ffserver. But i want to use my own http server to translate video by websockets for example.. Is it good practice? docs?
[18:34:15 CEST] <Nolski> relaxed: https://pastebin.mozilla.org/8838810
[18:35:06 CEST] <Nolski> (most important are lines 20 and 42)
[18:35:32 CEST] <Nolski> zarkone: what do you mean translate video
[19:13:32 CEST] <chrisss123456> hey guys, im having difficulty converting simple audio files. i get the error that "Encoder (codec mp3) not found for output stream #0:1"
[19:13:37 CEST] <chrisss123456> can anyone help?
[19:13:57 CEST] <chrisss123456> it seems as though
[19:14:39 CEST] <JEEBsv> seems like you have no encoder called 'mp3'
[19:14:52 CEST] <JEEBsv> ffmpeg -codecs |grep "mp3"
[19:15:26 CEST] <chrisss123456> JEEBsv: running that line gives loads of results...
[19:15:38 CEST] <JEEBsv> without the grep I guess
[19:15:40 CEST] <chrisss123456> D.A.L. mp3                  MP3 (MPEG audio layer 3) (decoders: mp3 mp3float )
[19:15:40 CEST] <chrisss123456>  D.A.L. mp3adu               ADU (Application Data Unit) MP3 (MPEG audio layer 3) (decoders: mp3adu mp3adufloat )
[19:15:40 CEST] <chrisss123456>  D.A.L. mp3on4               MP3onMP4 (decoders: mp3on4 mp3on4float )
[19:15:55 CEST] <JEEBsv> yeah, so no E
[19:16:09 CEST] <JEEBsv> no encoders
[19:16:10 CEST] <JEEBsv> :P
[19:16:34 CEST] <chrisss123456> JEEBsv: ah. well that's probably it then. haha, how do i get an encoder?
[19:16:49 CEST] <JEEBsv> you build ffmpeg with LAME's library
[19:17:00 CEST] <JEEBsv> or install it, depending on how you got the binary
[19:17:16 CEST] <JEEBsv> for example Debian-based things have libavcodec and libavcodec-extra
[19:17:16 CEST] <chrisss123456> JEEBsv: there isn't a way of doing it without reinstalling it?
[19:17:33 CEST] <JEEBsv> and libavcodec-extra then replaces the lavc library with one that has more features
[19:17:42 CEST] <chrisss123456> JEEBsv: i've got libavcodec but not libavcodec-extra
[19:17:54 CEST] <chrisss123456> ah, i see
[19:18:09 CEST] <JEEBsv> so if you're on debian, try installing libavcodec-extra
[19:19:01 CEST] <chrisss123456> JEEBsv: hhmm... i seem to already have it
[19:19:28 CEST] <chrisss123456> except that ffmpeg doesnt think i do..?
[19:20:18 CEST] <JEEBsv> which OS are you on?
[19:20:27 CEST] <chrisss123456> ubuntu 14.10
[19:20:44 CEST] <JEEBsv> that uses libav
[19:20:54 CEST] <JEEBsv> so you want to check avconv -codecs |grep "mp3"
[19:21:37 CEST] <chrisss123456> i don't have avconv. :/
[19:22:00 CEST] <JEEBsv> libav-tools
[19:22:03 CEST] <JEEBsv> is the package name
[19:23:25 CEST] <chrisss123456> ok done :) thanks
[19:23:44 CEST] <JEEBsv> anyways, your version of ubuntu shouldn't have ffmpeg itself yet (it's there in 15.04), so I have no idea how you got that ffmpeg binary
[19:24:26 CEST] <chrisss123456> i got it myself for some other projects i had. ok so now, how do i make ffmpeg use the libavc-extra?
[19:24:35 CEST] <JEEBsv> you don't
[19:24:43 CEST] <JEEBsv> it's a libav lavc
[19:24:51 CEST] <JEEBsv> one does not simply mix those
[19:25:06 CEST] <chrisss123456> JEEBsv: ok now im confused
[19:25:33 CEST] <JEEBsv> libav and ffmpeg (projects) both provide mostly the same libraries
[19:25:45 CEST] <JEEBsv> the cli tools are called avconv and ffmpeg respectively
[19:26:08 CEST] <chrisss123456> ok
[19:26:55 CEST] <JEEBsv> so if you built ffmpeg yourself or so, if you just want to encode mp3 and don't want to recompile ffmpeg with --enable-* , it's just simpler to install the packaged libav :P
[19:27:15 CEST] <JEEBsv> I think there are some static ffmpeg binaries available as well, see the topic etc
[19:27:30 CEST] <chrisss123456> JEEBsv: ok, well ill try and do that. thanks for all the help! :)
[21:50:44 CEST] <BtbN> I have a slight feeling the h264 this webcam produces is very broken... I'm running out of idea what else would cause these strange issues when streaming it.
[22:30:45 CEST] <OstlerDev> I am wondering if there is a way to convert videos using FFMPEG while those videos are still downloading. Meaning that the video would not be fully downloaded at the time that I want the conversion to start. I always know the final size and length of the video if that helps.
[22:31:15 CEST] <Nolski> OstlerDev: I doubt it
[22:31:38 CEST] <c_14> As long as it's not mp4 and you don't convert faster than you download it should work. (assuming linear downloads)
[22:31:58 CEST] <Nolski> wait really?
[22:32:28 CEST] <c_14> Most formats store their metadata at the front of the file, so sure.
[22:32:52 CEST] <OstlerDev> Well I am converting to MP4, so that is not the issue
[22:32:55 CEST] <Nolski> dang. that's pretty cool then.
[22:33:03 CEST] <OstlerDev> Is there a way to limit the speed of the conversion?
[22:33:20 CEST] <OstlerDev> Because for mkv to MP4, sometimes I just will need to switch the container which happens rather fast.
[22:39:37 CEST] <c_14> None ffmpeg-internal that I know of.
[22:40:44 CEST] <OstlerDev> Hmm, got it
[22:40:57 CEST] <c_14> If you can control the speed of the input device or output device, that'll work.
[22:41:10 CEST] <c_14> (like piping it through your own script or something)
[22:42:35 CEST] <OstlerDev> hmm, well I can pipe the file, maybe that will work
[22:46:02 CEST] <c_14> As long as you don't send EOF until you reach the true end of the file, it'll work.
[22:47:46 CEST] <OstlerDev> Got it, thanks
[22:58:52 CEST] <debianuser> Hello, a short question. How can I mirror image left-to-right? Something like "-vf mirror" in mplayer?
[23:02:01 CEST] <debianuser> Ah, found "-vf hflip".
[00:00:00 CEST] --- Wed Jul  8 2015

More information about the Ffmpeg-devel-irc mailing list