[Ffmpeg-devel-irc] ffmpeg.log.20151231

burek burek021 at gmail.com
Fri Jan 1 02:05:01 CET 2016

[00:03:11 CET] <furq> what just happened
[09:20:42 CET] <Wiesel> Hey all, I have IP-Cam which streams an RTSP-Stream into my network. I want to convert this Stream to an webm Stream. Therefore I have configurated my ffserver.conf. But I don't really know how the command should looks like. Can you please help me? Thanks in advance.
[11:05:13 CET] <Guest93102> Hi i have some questions about ffmpeg (how remove some warnings), can someone help or point me to some info?
[11:10:21 CET] <Guest93102> i can't understand this warning: Side data: unknown side data type 10 (24 bytes)
[11:10:28 CET] <Guest93102> while using libx264
[11:10:43 CET] <Guest93102> i have found htis link https://ffmpeg.org/doxygen/trunk/vf__showinfo_8c_source.html
[11:10:55 CET] <Guest93102> but i have no idea how to remove that warning
[11:11:43 CET] <Guest93102> other thing that is more important is "100 buffers queued in output stream 0:1, something may be wrong."
[11:12:01 CET] <Guest93102> followed by "Queue input is backward in time" (repeated many times)
[11:12:04 CET] <Guest93102> this from libvorbis
[16:21:00 CET] <volar> hi all
[16:21:09 CET] <volar> can anybody help me?
[16:21:58 CET] <volar> I try to convert a video to mp4 in asp.net using ffmpeg
[16:22:17 CET] <volar> I use a process
[16:22:23 CET] <volar> my arguments are
[16:22:24 CET] <volar>         p.StartInfo.Arguments = String.Format("-i ""{0}"" -b 1500k -vcodec libx264  -s 640x360 ""{1}""", strInput, strOuput)
[16:22:49 CET] <volar> I have problems using vcodec libx264
[16:23:28 CET] <volar>         p.StartInfo.Arguments = String.Format("-i ""{0}"" -b 1500k -vcodec libx264  -s 640x360 ""{1}""", strInput, strOuput)
[16:23:36 CET] <volar> hi
[16:24:42 CET] <volar> anybody can help here?
[16:25:01 CET] <volar> any awaken people?
[16:25:40 CET] <c_14> Pastebin your complete console output
[16:26:26 CET] <volar> FFmpeg version SVN-r18639, Copyright (c) 2000-2009 Fabrice Bellard, et al.
[16:26:26 CET] <volar>   configuration: --enable-memalign-hack --enable-postproc --enable-gpl --enable-libfaac --enable-libfaad --enable-libgsm --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libx264 --enable-libxvid --disable-ffserver --enable-avisynth --enable-pthreads
[16:26:26 CET] <volar>   libavutil     50. 3. 0 / 50. 3. 0
[16:26:26 CET] <volar>   libavcodec    52.27. 0 / 52.27. 0
[16:26:26 CET] <volar>   libavformat   52.32. 0 / 52.32. 0
[16:26:54 CET] <volar> Did I paste well here?
[16:26:58 CET] <c_14> upload to a pastebin service
[16:27:04 CET] <c_14> don't paste into the channel
[16:27:12 CET] <volar> okis
[16:27:28 CET] <volar> what is pastebin service?
[16:28:03 CET] <relaxed> pastebin.com
[16:28:04 CET] <c_14> pastebin.com ix.io sprunge.us pastie.org etc
[16:28:11 CET] <volar> thanks
[16:28:32 CET] <volar> I will try pastebin.com
[16:29:23 CET] <volar> I am in this page, pastebin.com
[16:29:36 CET] <volar> what to do next, please?
[16:29:46 CET] <volar> I have to solve it today?
[16:30:07 CET] <c_14> Just paste the text into the "New Paste" box and press "Create New Past"
[16:30:22 CET] <c_14> Also, I just noticed but >FFmpeg version SVN-r18639
[16:30:26 CET] <c_14> Your version of FFmpeg is ancient
[16:30:33 CET] <c_14> you should update
[16:31:07 CET] <volar> What is the lastest version?
[16:31:26 CET] <volar> I paste in pastebin
[16:31:26 CET] <fritsch> www.ffmpeg.org
[16:31:31 CET] <volar> okis
[16:32:21 CET] <c_14> volar: after you press "create new paste" it should forward you to the your paste. copy the url and paste the url here
[16:32:37 CET] <volar> okis
[16:32:41 CET] <volar> I go there
[16:34:47 CET] <volar> http://pastebin.com/w3MU6c5Q
[16:34:52 CET] <volar> is it the url?
[16:35:00 CET] <volar> it is shown in the broser
[16:35:02 CET] <c_14> yep
[16:35:05 CET] <volar> okis
[16:35:08 CET] <fritsch> nice 6 years old
[16:35:16 CET] <volar> wow
[16:36:19 CET] <c_14> >Unable to find a suitable output format for 'ûvcodec'
[16:36:27 CET] <c_14> check for random unicode characters in your argument list
[16:36:43 CET] <c_14> That, or rewrite it from scratch
[16:37:43 CET] <volar> I am reviewin my argumente
[16:37:48 CET] <volar> arguments
[16:38:31 CET] <volar> this is my arguments
[16:38:34 CET] <volar>         p.StartInfo.Arguments = String.Format("-i ""{0}"" -b 1500k -vcodec libx264  -s 640x360 ""{1}""", strInput, strOuput)
[16:38:47 CET] <volar> no unicode characters
[16:39:20 CET] <fritsch> strOuput <-
[16:39:30 CET] <volar> okis, sorry, I forgot to paste in pastebin
[16:39:49 CET] <volar> it has spaces in the path
[16:39:56 CET] <volar> any problem with that?
[16:40:02 CET] <fritsch> you write that code :-)
[16:40:04 CET] <fritsch> not we
[16:42:19 CET] <volar> strOuput = Server.MapPath("../Anucios_publico/") &"ejemplo.mp4"
[16:42:34 CET] <volar> Can't I put server.mappath?
[16:42:37 CET] <volar> in asp.net
[16:42:50 CET] <volar> it is putting a \
[16:43:09 CET] <volar> strOuput = Server.MapPath("../Anucios_publico/") & "ejemplo.mp4"
[16:45:14 CET] <volar> I will paste in pastebin
[16:47:18 CET] <volar> http://pastebin.com/L5uKQPv6
[16:47:37 CET] <volar> thanks for the patience
[16:48:17 CET] <volar> can u help me, please?
[16:49:34 CET] <fritsch> no idea what the & means in asp.net behind the Server.MapPath
[16:49:43 CET] <fritsch> but this is for sure not an asp.net beginner's channel
[16:50:00 CET] <volar> it is a character for union
[16:50:03 CET] <volar> okis
[16:50:08 CET] <volar> thanks
[16:50:39 CET] <fritsch> a character for union?
[16:50:44 CET] <fritsch> you sure you don't need just "+" there?
[16:51:00 CET] <volar> I will try
[16:51:22 CET] <volar> it is & or +
[16:53:09 CET] <volar> and is it ok if i use \ in the path?
[16:53:26 CET] <fritsch> it's windows after all
[16:53:32 CET] <fritsch> directory path handling sucks
[16:53:43 CET] <fritsch> sometimes they use C:/whatever/whatever/whatever
[16:53:53 CET] <fritsch> or C:\\whatdo\\Iknow\\
[16:55:11 CET] <volar> okis
[16:56:48 CET] <volar> Another user tried the same code
[16:56:58 CET] <volar> he told he has the same problem
[16:57:17 CET] <volar> the file stroutput is not created
[16:57:32 CET] <volar> and the log is that i said
[17:09:41 CET] <fritsch> yeah - and the good thing all that has nothing to do with ffmpeg :-)
[18:28:51 CET] <volar> I don't know whah
[18:28:57 CET] <volar> why fails it
[18:33:17 CET] <volar> http://pastebin.com/aCwC6Am5
[18:33:32 CET] <volar> can u see that code?
[18:33:49 CET] <volar> I am trying to use ffmpeg in asp.net
[18:34:22 CET] <volar> I don't see any character non unicode
[18:34:37 CET] <volar> My output file is not generated
[18:35:12 CET] <volar> can u help me?
[18:36:38 CET] <volar> please
[18:37:45 CET] <waressea1cher2> volar: geht's es dir gut ?
[18:39:21 CET] <volar> english
[18:39:29 CET] <volar> can u talk in english?
[18:39:37 CET] <volar> thanks
[18:39:42 CET] <volar> TIA
[18:40:41 CET] <waressea1cher2> volar: ich will deutsch sprähen
[18:40:49 CET] <volar> okis
[18:41:08 CET] <volar> here we talk in english
[18:41:19 CET] <volar> I understand little germa
[18:41:21 CET] <volar> n
[18:41:42 CET] <volar> I am spanihs
[18:41:51 CET] <volar> new in this channel
[18:42:18 CET] <fritsch> volar: don't care about him, he / she / it spams everyone from time to time - he cannot help you
[18:42:34 CET] <volar> okis
[18:43:19 CET] <volar> I can't figure out what happens with the commands in asp.net
[18:43:27 CET] <fritsch> now go back to your asp program and print out the strings separately, and have a read here: http://stackoverflow.com/questions/10501599/define-stdstring-in-c-without-escape-characters
[18:43:31 CET] <fritsch> second answer
[18:43:56 CET] <volar> okis
[18:43:59 CET] <volar> thanks
[18:45:25 CET] <waressea1cher2> fritsch: so unhöflich
[18:45:42 CET] <fritsch> waressea1cher2: this is now the 50th time you spam people that search for help in here
[18:45:48 CET] <fritsch> if anything is "unhöflich" then you are
[18:46:32 CET] <waressearcher2> fritsch: deutsch bitte
[18:46:54 CET] <fritsch> this is an english channel, if that's a problem for you - work with google translater
[18:48:21 CET] <Mavrik> Stop figting with a troll.
[18:48:28 CET] <Mavrik> ubitux, mind getting rid of it? :)
[18:48:45 CET] <fritsch> Mavrik: hehe, you are right (just seen him now too often)
[19:06:22 CET] <volar> why fails it
[19:34:16 CET] <YairNet> Hi , Any can help here?
[19:37:23 CET] <volar> yes
[19:37:26 CET] <volar> tell us
[19:37:32 CET] <volar> hi
[19:38:16 CET] <Logicgate> Has llogan been around
[19:39:31 CET] <YairNet> Unknown encoder 'libx264' but ssh command 'x264 --help' work...
[19:39:54 CET] <YairNet> I come here
[19:39:54 CET] <YairNet> Long after Google Search
[19:40:26 CET] <BtbN> ffmpeg does not use x264 via cli, and even if it did, you'd still have to compile it with support for it.
[19:41:14 CET] <volar> what CLI stand for?
[19:41:25 CET] <volar> common languague?
[19:42:31 CET] <thereh> I have 1 minute video, its frame rate is 29.970, I converted it into images: "ffmpeg -i 1.avi -c:v png images/%5d.png" and got 1889 png images, then I converted video to frame rate 23.976, and after that converted it to images again, and got the same 1889 png images, so how two video thats frame rate differs 20% contain the same amount of frames ?
[19:43:39 CET] <thereh> also when I converted it from 29.970 to 23.976 the video became jittery, but still contains same amount of frames
[19:43:40 CET] <volar> okis
[19:44:04 CET] <YairNet> if i try configure i have error "ERROR: libx264 not found" (Centos 7)
[19:44:34 CET] <volar> then how to convert a video to .ogg?
[19:44:38 CET] <BtbN> thereh, why would the framerate affect the total amount of frames?
[19:45:05 CET] <BtbN> Even if it was a 1000 fps video, it'd still be the exact same
[19:55:03 CET] <YairNet> BtbN; if i try configure (--enable-libx264) i have error "ERROR: libx264 not found" (Centos 7)
[20:01:22 CET] <c_14> YairNet: you might need libx264-dev or something (whatever package on your system provides x264.pc)
[20:03:21 CET] <thereh> BtbN: there is a problem, I got 2 different videos one with 29.970 and 23.976, then cut two pieces piece_29 and piece_23 from both then converted piece_23 to png images and reassembled some images I needed into video again with 29.970 framerate and call it piece_23_to_29 so now two pieces I need are 29.970 framerate, then I concatenated piece_29 and piece_23_to_29, and it look smooth enough, then I uploaded it on youtube then downloaded it from youtube to chec
[20:03:47 CET] <thereh>  from youtube to check how it plays, if youtube's system made it worse or something and discovered that second half of the video from piece_23_to_29 is very jittery, so why is that and how to come around it ? should I average those pieces both to 23.976 framerate ?
[20:05:26 CET] <YairNet> c_14: http://pastebin.com/qx0TtthC its not include x264-dev?
[20:05:57 CET] <c_14> YairNet: did you make sure to export PKG_CONFIG_PATH ?
[20:06:01 CET] <c_14> (before running configure)
[20:09:18 CET] <YairNet> --prefix="$HOME/ffmpeg_build" --extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" --bindir="$HOME/bin"
[20:10:05 CET] <c_14> export PKG_CONFIG_PATH="$PKG_CONFIG_PATH:$HOME/ffmpeg_build/lib/pkgconfig"
[20:10:08 CET] <c_14> then run configure again
[20:13:12 CET] <YairNet> not fix :(
[20:13:49 CET] <c_14> Does $HOME/ffmpeg_build/lib/pkgconfig/x264.pc exist?
[20:14:16 CET] <YairNet> no :O
[20:15:18 CET] <thereh> BtbN: actyally I only now noticed the entire video from youtube is in 15 framerate, why would youtube do that ? it was 29.970 when I uploaded it
[20:19:46 CET] <c_14> YairNet: did you make install x264?
[20:23:04 CET] <Logicgate> llogan!
[20:29:24 CET] <YairNet> c_14; if i make normgal configure for x264 i have error: http://pastebin.com/xg8zqh09
[20:30:24 CET] <c_14> --disable-lavf
[20:33:36 CET] <YairNet> I've done it already I will try again
[20:39:43 CET] <volar> which vcodec to use to convert to .ogg?
[20:41:11 CET] <YairNet> c_14, ok now all ok tank you very much, you can give me basic guide for resize movie file (mp4,3gp...)
[20:42:02 CET] <c_14> https://trac.ffmpeg.org/wiki/Scaling%20(resizing)%20with%20ffmpeg
[21:08:27 CET] <YairNet> c_14: after finsh configure (no erros) but if i run ffmpeg resize give me again error: Unknown encoder 'libx264'
[21:09:19 CET] <YairNet> http://pastebin.com/uj2fn43J
[21:15:05 CET] <llogan> your configure line is blank. it needs --enable-gpl --enable-libx264 to use encoder libx264
[21:15:49 CET] <llogan> why are you using all of those x264 options instead of simply using an encoding preset?
[21:16:42 CET] <llogan> just get a static build and use it instead: http://johnvansickle.com/ffmpeg/
[21:19:57 CET] <YairNet> llogan: http://pastebin.com/zNDJhaUB (not blank)
[21:20:50 CET] <llogan> make sure you're executing the correct binary
[21:20:56 CET] <llogan> you may have several ffmpeg installed
[21:29:04 CET] <YairNet> how i select binary
[21:29:58 CET] <YairNet> binary = file run ?
[21:32:36 CET] <YairNet> how i chack on command if x264 load?
[21:33:43 CET] <llogan> /full/path/to/ffmpeg -i
[21:35:56 CET] <YairNet> ok # cp /root/ffmpeg-2.8.4/ffmpeg /usr/local/bin/ffmpeg - fix problem but now new problem :D Unknown encoder 'libfaac'
[21:36:17 CET] <YairNet> what i need to install
[21:39:09 CET] <llogan> libfaac is garbage, and you didn't compile ffmpeg to use it (no --enable-libfaac). use "aac" or "libfdk_aac"
[22:01:48 CET] <Buster> Happy New Year!!!
[22:12:26 CET] <YairNet> LLOGAN: http://pastebin.com/epJCaS3S
[23:11:06 CET] <volar> happy new year
[23:32:23 CET] <volar> hi all again
[23:41:32 CET] <YairNet> i resize file on this command (ffmpeg -i input.mp4 -s 640x352  -preset ultrafast  output.mp4) make me 80MB to 19MB i need more reisze meximum 16M what i can more to do?
[23:44:04 CET] <fritsch> YairNet: add -crf 50
[23:44:35 CET] <c_14> If you have a maximum filesize, use -b:v (assuming you know the length)
[23:44:43 CET] <fritsch> jep that's better
[23:55:42 CET] <YairNet> fritsch Quality too low (MB2.73)
[23:57:00 CET] <YairNet> c_14: you can give me full command plz?
[00:00:00 CET] --- Fri Jan  1 2016

More information about the Ffmpeg-devel-irc mailing list