[FFmpeg-devel] [PATCH] avcodec/mjpegdec: fix -Wparentheses warning

Anton Khirnov anton at khirnov.net
Wed Sep 28 17:45:12 EEST 2022


Quoting Zhao Zhili (2022-09-23 19:46:24)
> 
> 
> > -----Original Message-----
> > From: ffmpeg-devel-bounces at ffmpeg.org <ffmpeg-devel-bounces at ffmpeg.org> On Behalf Of Rémi Denis-Courmont
> > Sent: 2022年9月23日 22:35
> > To: ffmpeg-devel at ffmpeg.org
> > Subject: Re: [FFmpeg-devel] [PATCH] avcodec/mjpegdec: fix -Wparentheses warning
> > 
> > Le perjantaina 23. syyskuuta 2022, 20.40.30 EEST Zhao Zhili a écrit :
> > > From: Zhao Zhili <zhilizhao at tencent.com>
> > >
> > > Signed-off-by: Zhao Zhili <zhilizhao at tencent.com>
> > > ---
> > >  libavcodec/mjpegdec.c | 2 +-
> > >  1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/libavcodec/mjpegdec.c b/libavcodec/mjpegdec.c
> > > index c594950500..d77c644d3b 100644
> > > --- a/libavcodec/mjpegdec.c
> > > +++ b/libavcodec/mjpegdec.c
> > > @@ -2866,7 +2866,7 @@ the_end:
> > >          }
> > >      }
> > >
> > > -    if (e = av_dict_get(s->exif_metadata, "Orientation", e,
> > > AV_DICT_IGNORE_SUFFIX)) { +    if ((e = av_dict_get(s->exif_metadata,
> > > "Orientation", e, AV_DICT_IGNORE_SUFFIX))) { char *value = e->value +
> > > strspn(e->value, " \n\t\r"), *endptr; int orientation = strtol(value,
> > > &endptr, 0);
> > 
> > Isn't it easier to read if you break the assignment out, and use the result as
> > predicate??
> 
> I prefer the coding style of splitting into two lines personally, but current coding
> Style is used everywhere in the code base, so I'm not sure.

Not everywhere, it depends on the author.
I try to avoid assignments in conditions wherever possible, because they
are hard to read IMO.

-- 
Anton Khirnov


More information about the ffmpeg-devel mailing list