[MPlayer-users] Re: [-] TV-recording with mencoder, "video-buffer full"

Rainer Hantsch office at hantsch.co.at
Mon Mar 7 16:46:54 CET 2005

On Thu, 3 Mar 2005, Reimar Döffinger wrote:

| Hi,
| On Thu, Mar 03, 2005 at 09:16:28AM +0100, Rainer Hantsch wrote:
| > What I wonder is the bleeding and noisy red. I already reduced saturation, but
| > red areas appear, when I click pause, as orange and red interlaced stripes.
| > Some lines are red, then it comes to some orange, then back to red... The
| > vert. position of the orange lines varies heavily.
| > This only happens with RED. Other colors (or a dark red) have no noticable
| > effects.
| Well, red is the colour that causes most trouble on a normal TV set,
| too...
| But I am a bit irritated: the problem only happens when you play the
| recorded movie and pause it or did I misunderstand that?

Yes. This bad coloring is inside the recording. I can see it in every
frame when I use avidemux to cut the movie.

| But most importantly I think you need to get a newer version - preferably a
| CVS snapshot.

Sorry. I will surely NOT change anything on the software until I have recorded
the full series of Enterprise nx01... ;-)
If I can do something with changing options, it is easy to get back, but to
restore a previously working setup is more difficult. ;-)

| > # Aufnehmen...
| > mencoder -tv on:input=$vinput:driver=v4l:device=/dev/video0:\
| > -tv on is deprecated afaik, instead you must do -tv input=.... tv://
| > -vop crop=$width:$height,denoise3d=8:6:6,pp=md \
| -vop is deprecated, the option is now -vf and uses the opposite order of
| filters.

Well, but even when it is depreciated, it works? ;-)

| > -sws 2 -ssf ls=1 \
| As you don't scale anywhere those options seem rather useless to me...

This was the result after playing around a lot with mencoder to get away the
black border on top and bottom. I finally was happy that it recorded at
all. If it is useless, I could surely remove it.


  Ing. Rainer Hantsch

More information about the MPlayer-users mailing list