[MPlayer-users] mplayer crashes with ac3 audio

Ubitux ubitux at gmail.com
Mon Jul 27 12:58:52 CEST 2009

On Mon, Jul 27, 2009 at 12:55 PM, Roberto
Malinverni<roberto.malinverni at dico.coop.it> wrote:
> Mplayer built from fresh (yesterday) SVN checkout on fully updated
> ArchLinux.
> I read about a patch that addresses an issue regarding the internal liba52
> when _compiling_ mplayer with gcc 4.4.0 and I know that the problem is
> reported to be solved with gcc 4.4.1. The following seems to me different: I
> can compile Mplayer, but I'm experiencing crashes with ac3 audio. I tested
> mkv files and dvd, using liba52 as well as ffac3.
> (a) using gcc 4.4.0, Mplayer compiles fine but it crashes when playing ac3
> audio;
> (b) using gcc 4.4.0 and the above mentioned patch for the internal liba52,
> Mplayer still compiles fine and it works with ac3 audio, but if I use the
> "-ss" switch it crashes again.
> (c) using gcc 4.4.1 (and no patches at all), Mplayer compiles but crashes as
> in case (a)
> (d) all is fine using a "legacy" gcc 3.4.6.
> Regards,
> Roberto Malinverni
> --
> Il messaggio e' stato analizzato alla ricerca di virus o
> contenuti pericolosi da MailScanner, ed e'
> risultato non infetto.
> _______________________________________________
> MPlayer-users mailing list
> MPlayer-users at mplayerhq.hu
> https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users

I've reported it a while ago :
It's the same with gcc-4.4.1, so as you, I use the 3.4 release.

I've tried to compile it with --enable-debug, but then there is no
such segfault, so it's hard to help. I hope it will be fixed soon in
mplayer or gcc...


More information about the MPlayer-users mailing list