[MPlayer-users] audio leads video

Geoffrey Leach geoff at hughes.net
Wed Jul 29 00:32:09 CEST 2009

Carl, thanks for your info.  Questions below.

On 07/28/2009 11:17:04 AM, Carl Eugen Hoyos wrote:
> Geoffrey Leach <geoff <at> hughes.net> writes:
> > You should have KTXLtest_1225_for_5_1280x720_60hz_ts.mpeg2
> With this sample, I never see framedrops with vo vdpau, vo xv and vo
> gl (with or
> without yuv=2). CPU usage is very low (>80% idle, except for
> gl:yuv=0). The
> status line reports 0% vo usage with gl:yuv=2, 5% for xv and below 20
> for vdpau
> (note that these numbers are never exact, but iirc, it showed 70% for
> you, which
> is a problem imo).

The log file in my original post shows video codec CPU usage of 19% and 
video_out CPU usage of 75%. Are you referring to the 75%?  And it 
should be below 20%? If this is so, then is this is the source of my 

> With vc ffmpeg12vdpau, CPU usage is around 2%.
> A/V sync is fine in all cases, it does not matter (much) if I use -ac
> a52 or -ac
> ffac3.

When I run mplayer -vc ffmpeg12vdpau 
KTXLtest_1225_for_5_1280x720_60hz_ts.mpeg2 the dropped frames start at 
zero seconds. Adding -ao alsa::device=hw=0.3 gives me 3 min 22 sec of 
play before frames are dropped.

There's a minor problem comparing the clip you have and mine. The 
sample you have been using, KTXLtest_1225_for_5_1280x720_60hz_ts.mpeg2, 
is corrupted; you have only 30 seconds of a 5 minute clip. For what 
follows, I've switched to test_episode_1602_1280x720_60hz_ts.mpeg2, 
which you should also have. The full clip is just one minue, so its 
easier to do timing. When I run mplayer -vc ffmpeg12vdpau 
test_episode_1602_1280x720_60hz_ts.mpeg2, dropped frames start at zero 
seconds also.

> To test that you do not have an alsa issue, try:
> time mplayer KTXLtest_1225_for_5_1280x720_60hz_ts.mpeg2 -nosound
> -benchmark
> It finishes after 20sec for the usual vo's for me (with your 30 sec
> sample). If
> it does not take longer for you, try other ao's.

time mplayer -vc ffmpeg12vdpau  -nosound -benchmark 

  TS_PARSE: COULDN'T SYNC 98%  0.0% 0 0
  V:19687.8 3404/3404  0% 98%  0.0% 0 0

  BENCHMARKs: VC:   0.205s VO:  55.693s A:   0.000s Sys:   0.871s =   
  BENCHMARK%: VC:  0.3610% VO: 98.1044% A:  0.0000% Sys:  1.5346% = 

  real  0m56.947s
  user  0m0.842s
  sys   0m0.365s

Could you interpret this for me? If it shows I don't have an alsa 
problem, why is that? What is the significance of "TS_PARSE: COULDN'T 
SYNC"? How t oI interpret the BENCHMARK numbers? (As always, a link is 

> You could also test -lavdopts fast:threads=2 

time to dropped frames 9.1s -> 19.5s

> or even -lavdopts fast:threads=2:skipidct=all (degrades quality, see 
> manual)

time to dropped frames 9.1s -> 28.6s

Do either of these results suggest anything? 

> If you suspect something is wrong with your setup (or do all/some on
> board
> NVIDIA video cards have similar problems?) - consider a report at
> http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

I will follow up here. 

More information about the MPlayer-users mailing list