[MPlayer-users] Very Rare - mplayer exits immediately with End of file when playing something.

Andy Furniss adf.lists at gmail.com
Sat Feb 15 17:38:45 CET 2014

Reimar Döffinger wrote:

> Well, that gives as options: 1) try with -cache

Well that one will at least remind me why I stopped using -cache ages
ago apart from opticaldisk/stream. I am sure I had issues with eg.
seeking with -demuxer lavf - but they may well be gone now.

> 2) try dropping the caches and see if it causes the issue (something
> like echo 3 > /proc/sys/vm/drop_caches)

I have tried that along with filling memory, but it didn't help me 

> Also would be interesting if it ever happens on formats like mp4 or
> mkv. One last thing that might be worth it is running memtest to
> ensure it's not a hardware issue. The number of causes for such
> "random" behaviour are fairly limited: race conditions (which should
> be unlikely in most of MPlayer code), uninitialized data (though only
> if ASLR is enabled) or hardware bugs. Though the ASLR thing give an
> idea: you can try compiling with --disable-relocatable and see if
> that makes it go away. However especially for 32 bit builds that is
> not a very likely cause (and will be hard to track down and fix).

Thanks for the suggestions - it is 64 bit so I'll add
--disable-relocatable to my build. Of course I won't know for ages
whether it helps.

Assuming no one else sees this, maybe it's just some bug with whatever
versions of the system libs I run - it is cross LFS, so old and
untypical. Maybe it will just go away next time I build a clean system.

More information about the MPlayer-users mailing list