[MPlayer-users] LAVC can't find libfaac

Reimar Döffinger Reimar.Doeffinger at gmx.de
Sat Nov 29 14:04:39 CET 2014

On Sun, Nov 16, 2014 at 08:50:10PM +0000, Ambarish Sridharanarayanan wrote:
> On Fedora 20, running mencoder-1.1-22.20140414svn, ​I'm trying to reencode a video with some filters. I'd like to use the AAC audio codec. My first attempt was:
> 	mencoder -vf ... input.mp4 -ovc x264 -of lavf -o output.mp4 -oac faac
> Unfortunately, mencoder couldn't find the faac audio-codec, so I had to recompile from source --with faac. I tried again, and this time I got a number of encoding errors like so:
> 	[mp4 @ 0xb6d361e0]Malformed AAC bitstream detected: use audio bitstream filter 'aac_adtstoasc' to fix it ('-bsf:a aac_adtstoasc' option with ffmpeg)
> 	Error while writing frame.
> And sure enough, the result file was corrupt. I found this promising thread on this list:

Does it work with -faacopts raw or so?

> This gave me the following error message:
> 	Audio LAVC, couldn't find encoder for codec libfaac.
> I've even tried looking at mplayer's ./configure script: it has 2 flags, _faac and _faac_lavc, both autodetected to true on my system. Any ideas on how I can either get the faac codec to generate a valid file or the lavf codec to recognise libfaac?

That is not relevant if as I guess you use the mencoder package from
Fedora which I expect is linked against system FFmpeg.
You would need to install a FFmpeg with FAAC support.
And at that point you might want to just use FFmpeg directly.
Also, FFmpeg has a native AAC encoder which should work well enough
nowadays, so just using "aac" instead of "faac" might work.
If your FFmpeg is old you also need to specify strict=-1 or so for that.

More information about the MPlayer-users mailing list