[MPlayer-users] VDPAU missing out on AMD

Dominik 'Rathann' Mierzejewski dominik at greysector.net
Mon Dec 7 19:47:19 CET 2015


On Monday, 07 December 2015 at 07:39, Mikus Grinbergs wrote:
> I wanted to use hardware acceleration (playback) with an AMD video card, but
> I'm stymied.  My system runs 32-bit Fedora 23 with a Radeon HD 7770.  The
> DRI2 driver is 'radeonsi'.
> It's difficult to assemble information abut AMD video acceleration. I've
> installed all the packages I've seen mentioned in conjunction with AMD
> acceleration, such as 'mesa-vdpau'.
> Information on "What is needed to have MPlayer use video acceleration" isn't
> in one easy-to-understand place.  The main thing seems to be '-vo vdpau' to
> specify the "what" and '-vc ff...vdpau' to specify the "how".

It works for me rather well on a 64-bit Fedora 23 with Radeon HD 7950 (or
something like that). Please show the output of
rpm -qa '*vdpau*' 'mesa*' |sort

Also, /var/log/Xorg.0.log would be helpful (or are you running

> ----
> With '-vo vdpau' in MPayer 1.2-5.1.1 (from Fedora), if I put in any '-vc
> ff...vdpau' (appropriate to the video file I was trying to play - I tried
> h264 and hevc and vc1 videos), MPlayer told me "The selected video_out
> device is incompatible with this codec", as well as a bunch of "Unexpected
> decoder output format Planar YV12" lines, then exited.
> With '-vo vdpau' in MPlayer SVN-r37561-5.1.1 (I built), putting in any
> appropriate '-vc ff...vdpau' still had the same result, but with the hevc
> video the "Unexpected" lines kept coming until I stopped MPlayer.

What's in your ~/.mplayer/config file?

MPlayer http://mplayerhq.hu | RPM Fusion http://rpmfusion.org
There should be a science of discontent. People need hard times and
oppression to develop psychic muscles.
	-- from "Collected Sayings of Muad'Dib" by the Princess Irulan

More information about the MPlayer-users mailing list