[MPlayer-users] mplayer suddenly does not recognize keyboard input

Alayne McGregor alayne at ottawajazzscene.ca
Tue Sep 29 22:53:35 CEST 2015

I'm hoping someone can help me with an abrupt change in mplayer behaviour. 
I RTFMd and googled but couldn't find anything related to my problem.

I'm running MPlayer2 2.0-701-gd4c5b7f-2ubuntu2.

I use mplayer to play mp3, flac, and wav files (mostly mp3), from the 
command line on my Ubuntu 14.04 system. I mostly am transcribing the 
files, so I need to stop and start frequently and seek backwards and 

Up until this morning, it worked perfectly and was very useful.

This morning, when I played the mp3 file I was working on last night, the 
audio played fine but mplayer didn't recognize _any_ normal keyboard input 
(except CTL-C). I also got an error which I hadn't seen before: "Dead key 
input on file descriptor 0".

I hadn't changed any of my mplayer options or setup.

Late last night after I finished my work, I did a standard update on my 
machine, updating
- the kernel to 3.13.0-65-generic
- python-software-properties to
- libcuda1-340 to 340.76.0ubuntu0.1, 340.93.0ubuntu0.1
- nvidia-331 to 340.76.0ubuntu0.1, 340.93.0ubuntu0.1
- nvidia-340 to 340.76.0ubuntu0.1, 340.93.0ubuntu0.1 (plus several other 
nvidia packages)
- software-properties-kde to,
- software-properties-common to,
This is all that I changed on my system.

If I run
mplayer -v --no-consolecontrols file.mp3
the fd0 error no longer appears and the characters are echoed (i.e. a 
space shows up when I press the space bar), but mplayer still takes no 
action in response to the keypresses.

Has anyone else seen this behaviour before? Is there any workaround, 


More information about the MPlayer-users mailing list