[MPlayer-cvslog] CVS: main/libmpcodecs vf_scale.c,1.57,1.58

D Richard Felker III dalias at aerifal.cx
Mon Mar 7 06:52:56 CET 2005

On Sun, Mar 06, 2005 at 11:34:15PM +0200, Oded Shimon wrote:
> On Sunday 06 March 2005 23:15, Nico Sabbi CVS wrote:
> > +      vf->priv->w = -(-vf->priv->w & ~8);
> Why didn't you change this to
> vf->priv->w += 8;
> after all?
> As far as I can tell, it's completely identical, and much more readable...

You're an idiot sometimes.. :)
Reminds me of that guy who was talking with us about my ABS() macro on
irc the other day..

> Also personally in the 'if', I would've done '<= -8' instead of the mess that 
> is over there.
> Should I submit a cosmetics patch? :)

No, you should test your proposed nonsense first and see that it
doesn't work before proposing it. :)

BTW I have a nice idea for something you could probably implement for
mencoder that'd be really useful. I'll explain it later in a new
thread or on irc.


More information about the MPlayer-cvslog mailing list